summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:53:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:53:43 +0000
commitfec823adf189212129b5f6eaefc65e0b406e2cdd (patch)
treecdcdae1d9b33f248274fc82d1d24623ec4968f73 /dev-haskell/hdbc-postgresql
parentVersion bump. Requested by Christopher Howard (bug #367211). Removed old vers... (diff)
downloadgentoo-2-fec823adf189212129b5f6eaefc65e0b406e2cdd.tar.gz
gentoo-2-fec823adf189212129b5f6eaefc65e0b406e2cdd.tar.bz2
gentoo-2-fec823adf189212129b5f6eaefc65e0b406e2cdd.zip
Version bump. Requested by Christopher Howard (bug #367211). Removed old versions.
(Portage version: 2.1.10.1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hdbc-postgresql')
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog13
-rw-r--r--dev-haskell/hdbc-postgresql/files/hdbc-postgresql-helper.h16
-rw-r--r--dev-haskell/hdbc-postgresql/files/pgtypes.h66
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild23
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.1.0.ebuild23
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild49
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild62
7 files changed, 73 insertions, 179 deletions
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index fc934be69392..e0380544ae0f 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/hdbc-postgresql
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.14 2010/07/12 13:11:43 slyfox Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.15 2011/06/12 19:53:43 slyfox Exp $
+
+*hdbc-postgresql-2.2.3.3 (12 Jun 2011)
+
+ 12 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ -hdbc-postgresql-1.0.0.0.ebuild, -hdbc-postgresql-1.0.1.0.ebuild,
+ -hdbc-postgresql-1.1.3.0.ebuild, +hdbc-postgresql-2.2.3.3.ebuild,
+ -files/hdbc-postgresql-helper.h, -files/pgtypes.h:
+ Version bump. Requested by Christopher Howard (bug #367211). Removed old
+ versions.
12 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
hdbc-postgresql-1.1.3.0.ebuild:
diff --git a/dev-haskell/hdbc-postgresql/files/hdbc-postgresql-helper.h b/dev-haskell/hdbc-postgresql/files/hdbc-postgresql-helper.h
deleted file mode 100644
index 188e73ba3657..000000000000
--- a/dev-haskell/hdbc-postgresql/files/hdbc-postgresql-helper.h
+++ /dev/null
@@ -1,16 +0,0 @@
-#include <libpq-fe.h>
-
-typedef struct TAG_finalizeonce {
- void *encapobj;
- int refcount;
- int isfinalized;
- struct TAG_finalizeonce *parent;
-} finalizeonce;
-
-extern finalizeonce *wrapobjpg(void *obj, finalizeonce *parentobj);
-
-extern void PQfinish_app(finalizeonce *conn);
-extern void PQfinish_finalizer(finalizeonce *conn);
-
-extern void PQclear_app(finalizeonce *res);
-extern void PQclear_finalizer(finalizeonce *res);
diff --git a/dev-haskell/hdbc-postgresql/files/pgtypes.h b/dev-haskell/hdbc-postgresql/files/pgtypes.h
deleted file mode 100644
index abf1dcdbbc99..000000000000
--- a/dev-haskell/hdbc-postgresql/files/pgtypes.h
+++ /dev/null
@@ -1,66 +0,0 @@
-/* File: pgtypes.h
- *
- * Description: See "pgtypes.c"
- *
- * Comments: See "notice.txt" for copyright and license information.
- *
- */
-
-#ifndef __PGTYPES_H__
-#define __PGTYPES_H__
-
-/* the type numbers are defined by the OID's of the types' rows */
-/* in table pg_type */
-
-
-#if 0
-#define PG_TYPE_LO ???? /* waiting for permanent type */
-#endif
-
-#define PG_TYPE_BOOL 16
-#define PG_TYPE_BYTEA 17
-#define PG_TYPE_CHAR 18
-#define PG_TYPE_NAME 19
-#define PG_TYPE_INT8 20
-#define PG_TYPE_INT2 21
-#define PG_TYPE_INT2VECTOR 22
-#define PG_TYPE_INT4 23
-#define PG_TYPE_REGPROC 24
-#define PG_TYPE_TEXT 25
-#define PG_TYPE_OID 26
-#define PG_TYPE_TID 27
-#define PG_TYPE_XID 28
-#define PG_TYPE_CID 29
-#define PG_TYPE_OIDVECTOR 30
-#define PG_TYPE_SET 32
-#define PG_TYPE_CHAR2 409
-#define PG_TYPE_CHAR4 410
-#define PG_TYPE_CHAR8 411
-#define PG_TYPE_POINT 600
-#define PG_TYPE_LSEG 601
-#define PG_TYPE_PATH 602
-#define PG_TYPE_BOX 603
-#define PG_TYPE_POLYGON 604
-#define PG_TYPE_FILENAME 605
-#define PG_TYPE_FLOAT4 700
-#define PG_TYPE_FLOAT8 701
-#define PG_TYPE_ABSTIME 702
-#define PG_TYPE_RELTIME 703
-#define PG_TYPE_TINTERVAL 704
-#define PG_TYPE_UNKNOWN 705
-#define PG_TYPE_MONEY 790
-#define PG_TYPE_OIDINT2 810
-#define PG_TYPE_OIDINT4 910
-#define PG_TYPE_OIDNAME 911
-#define PG_TYPE_BPCHAR 1042
-#define PG_TYPE_VARCHAR 1043
-#define PG_TYPE_DATE 1082
-#define PG_TYPE_TIME 1083
-#define PG_TYPE_TIMESTAMP_NO_TMZONE 1114 /* since 7.2 */
-#define PG_TYPE_DATETIME 1184
-#define PG_TYPE_TIME_WITH_TMZONE 1266 /* since 7.1 */
-#define PG_TYPE_TIMESTAMP 1296 /* deprecated since 7.0 */
-#define PG_TYPE_NUMERIC 1700
-#define INTERNAL_ASIS_TYPE (-9999)
-
-#endif
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild
deleted file mode 100644
index 6661d0a5220f..000000000000
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild,v 1.4 2010/06/17 18:19:51 patrick Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-DESCRIPTION="PostgreSQL database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/postgresql-base-8"
-
-S="${WORKDIR}/${PN}"
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.1.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.1.0.ebuild
deleted file mode 100644
index 0ffe7aad2c80..000000000000
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.1.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.1.0.ebuild,v 1.4 2010/06/17 18:19:51 patrick Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-DESCRIPTION="PostgreSQL database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/postgresql-base-8"
-
-S="${WORKDIR}/${PN}"
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild
deleted file mode 100644
index ecd3129fe3be..000000000000
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.1.3.0.ebuild,v 1.4 2010/07/12 13:11:43 slyfox Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-MY_PN=HDBC-postgresql
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="PostgreSQL database driver for HDBC"
-HOMEPAGE="http://software.complete.org/hdbc-postgresql"
-SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- dev-haskell/mtl
- =dev-haskell/hdbc-${hdbc_PV}*
- dev-haskell/parsec
- >=dev-db/postgresql-base-8"
-
-S="${WORKDIR}/${MY_P}"
-
-CABAL_CONFIGURE_FLAGS="--constraint=base<4"
-
-src_unpack() {
- unpack ${A}
-
- cp "${FILESDIR}/hdbc-postgresql-helper.h" "${FILESDIR}/pgtypes.h" "${S}/"
- sed -i -e 's/GHC-Options: -O2 -Wall/GHC-Options: -fvia-C/' \
- -e '/include-dirs:/d' \
- -e '/^Extensions:/a \
- , ForeignFunctionInterface' \
- "${S}/${MY_PN}.cabal"
- echo "include-dirs: $(pg_config --includedir)," >> "${S}/${MY_PN}.cabal"
- echo " $(pg_config --includedir-server), ." >> "${S}/${MY_PN}.cabal"
-
- if version_is_at_least "6.8" "$(ghc-version)"; then
- sed -i -e '/Build-Depends:/a \
- , old-time' \
- "${S}/${MY_PN}.cabal"
- fi
-}
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
new file mode 100644
index 000000000000..7ce73f37ee8e
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild,v 1.1 2011/06/12 19:53:43 slyfox Exp $
+
+# ebuild generated by hackport 0.2.12
+
+EAPI="2"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-postgresql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+hdbc_PV=$(get_version_component_range 1-2)
+
+RDEPEND=">=dev-lang/ghc-6.8.2
+ =dev-haskell/hdbc-${hdbc_PV}*
+ dev-haskell/mtl
+ dev-haskell/parsec
+ dev-haskell/time
+ dev-haskell/utf8-string
+ >=dev-db/postgresql-base-8"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}