summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
new file mode 100644
index 000000000000..7ce73f37ee8e
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild,v 1.1 2011/06/12 19:53:43 slyfox Exp $
+
+# ebuild generated by hackport 0.2.12
+
+EAPI="2"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-postgresql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+hdbc_PV=$(get_version_component_range 1-2)
+
+RDEPEND=">=dev-lang/ghc-6.8.2
+ =dev-haskell/hdbc-${hdbc_PV}*
+ dev-haskell/mtl
+ dev-haskell/parsec
+ dev-haskell/time
+ dev-haskell/utf8-string
+ >=dev-db/postgresql-base-8"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}