summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-13 00:49:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-13 00:49:24 +0000
commitb4fc059769615caa0e26c2dd2b4c35c8d8da4928 (patch)
tree82a013f9e66ab1cf29ee1fc6b14d0f6af77fb848 /dev-games
parentVersion bump. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-b4fc059769615caa0e26c2dd2b4c35c8d8da4928.tar.gz
gentoo-2-b4fc059769615caa0e26c2dd2b4c35c8d8da4928.tar.bz2
gentoo-2-b4fc059769615caa0e26c2dd2b4c35c8d8da4928.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/poker-eval/ChangeLog8
-rw-r--r--dev-games/poker-eval/files/poker-eval-136.0-bash40.patch32
-rw-r--r--dev-games/poker-eval/poker-eval-136.0.ebuild28
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-games/poker-eval/ChangeLog b/dev-games/poker-eval/ChangeLog
index eae863be3fca..c696157cffbd 100644
--- a/dev-games/poker-eval/ChangeLog
+++ b/dev-games/poker-eval/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/poker-eval
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/ChangeLog,v 1.15 2009/07/21 11:59:35 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/ChangeLog,v 1.16 2009/08/13 00:49:24 mr_bones_ Exp $
+
+*poker-eval-136.0 (13 Aug 2009)
+
+ 13 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +poker-eval-136.0.ebuild, +files/poker-eval-136.0-bash40.patch:
+ version bump
21 Jul 2009; Alfredo Tupone <tupone@gentoo.org>
+files/poker-eval-135.0-bash40.patch, poker-eval-135.0.ebuild:
diff --git a/dev-games/poker-eval/files/poker-eval-136.0-bash40.patch b/dev-games/poker-eval/files/poker-eval-136.0-bash40.patch
new file mode 100644
index 000000000000..f9cc96388f50
--- /dev/null
+++ b/dev-games/poker-eval/files/poker-eval-136.0-bash40.patch
@@ -0,0 +1,32 @@
+--- tests/bug1823.old 2009-07-21 13:45:13.000000000 +0200
++++ tests/bug1823 2009-07-21 13:45:52.000000000 +0200
+@@ -27,7 +27,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As Qs Kh Jh 500 715 15 90 0 0 0 0.796
+ Ac Kd 5d 7h 15 15 715 90 224 0 0 0.204
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
+@@ -39,7 +40,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As 6s 7h 5h 250 324 0 496 0 0 168 0.675
+ Ac 7d 6d 5d 0 0 324 496 0 0 168 0.325
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
+@@ -51,7 +53,8 @@
+ cards scoop HIwin HIlos HItie LOwin LOlos LOtie EV
+ As 6s 7h 5h 289 381 352 87 12 0 157 0.504
+ Ac 8d 6d 5d 314 352 381 87 0 12 157 0.496
+-EOF)
++EOF
++)
+ if test "$r" != "$e" ; then
+ diff -u <(echo "$e") <(echo "$r")
+ exit 1
diff --git a/dev-games/poker-eval/poker-eval-136.0.ebuild b/dev-games/poker-eval/poker-eval-136.0.ebuild
new file mode 100644
index 000000000000..fcb92142491e
--- /dev/null
+++ b/dev-games/poker-eval/poker-eval-136.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/poker-eval-136.0.ebuild,v 1.1 2009/08/13 00:49:24 mr_bones_ Exp $
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A fast C library for evaluating poker hands"
+HOMEPAGE="http://pokersource.info/"
+SRC_URI="http://download.gna.org/pokersource/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bash40.patch
+}
+
+src_configure() {
+ econf --without-ccache || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO WHATS-HERE
+}