summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-21 05:45:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-21 05:45:18 +0000
commit3721ac58f9b7281f7ec5474c26e9e6be4a50afc5 (patch)
tree4ac3c84621e164c290ebd651347324e211187d8f /dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild
parentinitial commit (diff)
downloadgentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.tar.gz
gentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.tar.bz2
gentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.zip
initial commit
Diffstat (limited to 'dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild')
-rw-r--r--dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild b/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild
new file mode 100644
index 000000000000..cfbe6c2d28ab
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild,v 1.1 2003/10/21 05:45:15 robbat2 Exp $
+
+inherit eutils
+
+MY_PN="${PN/gpsim-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="2x20 LCD display module for GPSIM"
+HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html#modules http://www.dattalo.com/gnupic/lcd.html"
+SRC_URI="http://www.dattalo.com/gnupic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-embedded/gpsim-0.20*"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc33.patch
+}
+
+src_compile(){
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ cp -ra ${S}/examples ${D}/usr/share/doc/${PF}
+ find ${D}/usr/share/doc/${PF} -name 'Makefile*' -exec rm -f \{} \;
+}