summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-21 05:45:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-21 05:45:18 +0000
commit3721ac58f9b7281f7ec5474c26e9e6be4a50afc5 (patch)
tree4ac3c84621e164c290ebd651347324e211187d8f /dev-embedded/gpsim-lcd
parentinitial commit (diff)
downloadgentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.tar.gz
gentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.tar.bz2
gentoo-2-3721ac58f9b7281f7ec5474c26e9e6be4a50afc5.zip
initial commit
Diffstat (limited to 'dev-embedded/gpsim-lcd')
-rw-r--r--dev-embedded/gpsim-lcd/ChangeLog10
-rw-r--r--dev-embedded/gpsim-lcd/Manifest5
-rw-r--r--dev-embedded/gpsim-lcd/files/digest-gpsim-lcd-0.1.11
-rw-r--r--dev-embedded/gpsim-lcd/files/gpsim-lcd-0.1.1-gcc33.patch30
-rw-r--r--dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild38
-rw-r--r--dev-embedded/gpsim-lcd/metadata.xml5
6 files changed, 88 insertions, 1 deletions
diff --git a/dev-embedded/gpsim-lcd/ChangeLog b/dev-embedded/gpsim-lcd/ChangeLog
new file mode 100644
index 000000000000..35cd06f5118c
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-embedded/gpsim-lcd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim-lcd/ChangeLog,v 1.1 2003/10/21 05:45:15 robbat2 Exp $
+
+*gpsim-lcd-0.1.1 (20 Oct 2003)
+
+ 20 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> gpsim-lcd-0.1.1.ebuild,
+ files/gpsim-lcd-0.1.1-gcc33.patch:
+ initial commit
+
diff --git a/dev-embedded/gpsim-lcd/Manifest b/dev-embedded/gpsim-lcd/Manifest
index 1ea8772b3cf2..258a7a91aec5 100644
--- a/dev-embedded/gpsim-lcd/Manifest
+++ b/dev-embedded/gpsim-lcd/Manifest
@@ -1,2 +1,5 @@
-MD5 4873836575378ef73fe3da15d5b511a3 gpsim-lcd-0.1.1.ebuild 860
+MD5 3a20e46954cecd8ea0a223792023411e gpsim-lcd-0.1.1.ebuild 931
+MD5 420df847a3db1c4969aff20243f656dd metadata.xml 165
+MD5 d2ddd3d35fda5328cf98860c18967361 ChangeLog 390
MD5 6afce2c0050a1d6a1a5a16c5818a54db files/digest-gpsim-lcd-0.1.1 61
+MD5 61f40c22ba6832f8704ba79fb8cfe31e files/gpsim-lcd-0.1.1-gcc33.patch 906
diff --git a/dev-embedded/gpsim-lcd/files/digest-gpsim-lcd-0.1.1 b/dev-embedded/gpsim-lcd/files/digest-gpsim-lcd-0.1.1
new file mode 100644
index 000000000000..d06a9820d044
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/files/digest-gpsim-lcd-0.1.1
@@ -0,0 +1 @@
+MD5 4004d8632bf94b840fd561637dad15a3 lcd-0.1.1.tar.gz 149360
diff --git a/dev-embedded/gpsim-lcd/files/gpsim-lcd-0.1.1-gcc33.patch b/dev-embedded/gpsim-lcd/files/gpsim-lcd-0.1.1-gcc33.patch
new file mode 100644
index 000000000000..8de3e24c77e6
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/files/gpsim-lcd-0.1.1-gcc33.patch
@@ -0,0 +1,30 @@
+diff -ur lcd-0.1.1.old/lcd.cc lcd-0.1.1/lcd.cc
+--- lcd-0.1.1.old/lcd.cc 2000-08-27 14:19:12.000000000 -0700
++++ lcd-0.1.1/lcd.cc 2003-10-20 22:18:24.000000000 -0700
+@@ -86,7 +86,7 @@
+ // tracing, stimulus interface, etc.). The LcdPort class extends
+ // IOPORT by redirecting changes to the LCD state machine.
+
+-Lcd_Port::Lcd_Port (unsigned int _num_iopins=8) : IOPORT(_num_iopins)
++Lcd_Port::Lcd_Port (unsigned int _num_iopins) : IOPORT(_num_iopins)
+ {
+
+ }
+@@ -114,7 +114,7 @@
+ }
+
+
+-DataPort::DataPort (unsigned int _num_iopins=8) : Lcd_Port(_num_iopins)
++DataPort::DataPort (unsigned int _num_iopins) : Lcd_Port(_num_iopins)
+ {
+
+ }
+@@ -146,7 +146,7 @@
+
+ //-----------------------------------------------------
+
+-ControlPort::ControlPort (unsigned int _num_iopins=8) : Lcd_Port(_num_iopins)
++ControlPort::ControlPort (unsigned int _num_iopins) : Lcd_Port(_num_iopins)
+ {
+ break_delta = 100000;
+ }
diff --git a/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild b/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild
new file mode 100644
index 000000000000..cfbe6c2d28ab
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim-lcd/gpsim-lcd-0.1.1.ebuild,v 1.1 2003/10/21 05:45:15 robbat2 Exp $
+
+inherit eutils
+
+MY_PN="${PN/gpsim-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="2x20 LCD display module for GPSIM"
+HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html#modules http://www.dattalo.com/gnupic/lcd.html"
+SRC_URI="http://www.dattalo.com/gnupic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-embedded/gpsim-0.20*"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc33.patch
+}
+
+src_compile(){
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ cp -ra ${S}/examples ${D}/usr/share/doc/${PF}
+ find ${D}/usr/share/doc/${PF} -name 'Makefile*' -exec rm -f \{} \;
+}
diff --git a/dev-embedded/gpsim-lcd/metadata.xml b/dev-embedded/gpsim-lcd/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/gpsim-lcd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>