summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:10:31 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:10:31 +0000
commitde0496643eed603fd6e7d381f6f191353290a418 (patch)
treedb2623812841a2104d46124e2dd45163205f0e60 /dev-dotnet/xsp/xsp-1.2.6.ebuild
parentdev-lang/mono-basic-1.2.6: version bump (diff)
downloadgentoo-2-de0496643eed603fd6e7d381f6f191353290a418.tar.gz
gentoo-2-de0496643eed603fd6e7d381f6f191353290a418.tar.bz2
gentoo-2-de0496643eed603fd6e7d381f6f191353290a418.zip
dev-dotnet/xsp-1.2.6: version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-dotnet/xsp/xsp-1.2.6.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-1.2.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-1.2.6.ebuild b/dev-dotnet/xsp/xsp-1.2.6.ebuild
new file mode 100644
index 000000000000..9010596592f8
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.2.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.2.6.ebuild,v 1.1 2007/12/14 20:10:30 jurek Exp $
+
+inherit mono multilib autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/mono-${PV}"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ "${S}"/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
+ "${D}"/usr/bin/xsp{,2} \
+ "${D}"/usr/bin/mod-mono-server{,2} \
+ "${D}"/usr/bin/asp-state{,2} \
+ "${D}"/usr/bin/dbsessmgr{,2} \
+ || die
+
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}