summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:10:31 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-12-14 20:10:31 +0000
commitde0496643eed603fd6e7d381f6f191353290a418 (patch)
treedb2623812841a2104d46124e2dd45163205f0e60 /dev-dotnet
parentdev-lang/mono-basic-1.2.6: version bump (diff)
downloadgentoo-2-de0496643eed603fd6e7d381f6f191353290a418.tar.gz
gentoo-2-de0496643eed603fd6e7d381f6f191353290a418.tar.bz2
gentoo-2-de0496643eed603fd6e7d381f6f191353290a418.zip
dev-dotnet/xsp-1.2.6: version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/xsp/ChangeLog9
-rw-r--r--dev-dotnet/xsp/files/1.2.6/mod-mono-server.confd34
-rw-r--r--dev-dotnet/xsp/files/1.2.6/mod-mono-server.initd81
-rw-r--r--dev-dotnet/xsp/files/1.2.6/xsp.confd12
-rw-r--r--dev-dotnet/xsp/files/1.2.6/xsp.initd38
-rw-r--r--dev-dotnet/xsp/files/digest-xsp-1.2.63
-rw-r--r--dev-dotnet/xsp/xsp-1.2.6.ebuild66
7 files changed, 242 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index 480f6621f2d4..f201ac085c3d 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.48 2007/09/11 10:24:03 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.49 2007/12/14 20:10:30 jurek Exp $
+
+*xsp-1.2.6 (14 Dec 2007)
+
+ 14 Dec 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/1.2.6/mod-mono-server.confd, +files/1.2.6/mod-mono-server.initd,
+ +files/1.2.6/xsp.confd, +files/1.2.6/xsp.initd, +xsp-1.2.6.ebuild:
+ Version bump
11 Sep 2007; Jurek Bartuszek <jurek@gentoo.org> Manifest:
Fixed digests (bug #192076)
diff --git a/dev-dotnet/xsp/files/1.2.6/mod-mono-server.confd b/dev-dotnet/xsp/files/1.2.6/mod-mono-server.confd
new file mode 100644
index 000000000000..65c9d0c8caad
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.6/mod-mono-server.confd
@@ -0,0 +1,34 @@
+# Config file for /etc/init.d/mod-mono-server
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.6/mod-mono-server.confd,v 1.1 2007/12/14 20:10:31 jurek Exp $
+
+# Configuration directives for mod-mono-server.exe. For more information on
+# these variables, see the man page for xsp(1).
+
+# This is the document root; trailing slash is not necessary
+#MonoServerRootDir="/usr/lib/xsp/test"
+
+# Directory to search for files with an `.webapp' extension.
+#MonoApplicationsConfigDir="/usr/lib/xsp/test"
+
+# Comma separated list of directories (in the form virtual:real) for all
+# applications managed by the server. For example:
+# /app1:/var/www/localhost/htdocs/app1,/app2:/var/www/localhost/htdocs/app2
+MonoApplications="/mono:/usr/lib/xsp/test"
+
+# The communication channel used between mod-mono-server and mod_mono.
+# unix - A unix socket
+# tcp - A TCP connection
+MonoServerChannel="unix"
+
+# When the comm. channel is "unix", the local filename used by the socket.
+UnixSocketFileName="/tmp/mod_mono_server"
+
+# When the comm. channel is "tcp", IP address for the server to listen on.
+#MonoServerAddress=127.0.0.1
+
+# When the comm. channel is "tcp", port for the server to listen on.
+#MonoServerPort=8080
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchaged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/1.2.6/mod-mono-server.initd b/dev-dotnet/xsp/files/1.2.6/mod-mono-server.initd
new file mode 100644
index 000000000000..03128a345e86
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.6/mod-mono-server.initd
@@ -0,0 +1,81 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.6/mod-mono-server.initd,v 1.1 2007/12/14 20:10:31 jurek Exp $
+
+depend() {
+ use net
+ after dotnet
+}
+
+start() {
+ [ -z "$MonoServerRootDir" ] && \
+ MonoServerRootDir="/usr/lib/xsp/test"
+ [ -z "$MonoApplications" ] && \
+ MonoApplications="/mono:/usr/lib/xsp/test,/:."
+ [ -z "$UnixSocketFileName" ] && \
+ UnixSocketFileName="/tmp/mod_mono_server"
+ [ -z "$MonoServerAddress" ] && \
+ MonoServerAddress=127.0.0.1
+ [ -z "$MonoServerPort" ] && \
+ MonoServerPort=8080
+ [ -z "$MonoServerVersion" ] && \
+ MonoServerVersion=1
+
+ MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
+--applications ${MonoApplications} --nonstop"
+
+ [ -n "$MonoApplicationsConfigDir" ] && \
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--appconfigdir ${MonoApplicationsConfigDir}"
+
+ case "$MonoServerChannel" in
+ "tcp" )
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--address ${MonoServerAddress} --port ${MonoServerPort}"
+ ;;
+
+ "unix" )
+ [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--filename ${UnixSocketFileName}"
+ ;;
+
+ * )
+ eerror "Please set a valid value for MonoServerChannel"
+ return 1
+ ;;
+ esac
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ modmonoserverpath=1.0/mod-mono-server.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ modmonoserverpath=2.0/mod-mono-server2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
+ return 1
+ fi
+
+ export MONO_SHARED_DIR=/tmp
+
+ ebegin "Starting mod-mono-server"
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/mod-mono-server.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
+ -- $MONO_SERVER_OPTS
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mod-mono-server"
+
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/mod-mono-server.pid
+
+ eend $?
+}
diff --git a/dev-dotnet/xsp/files/1.2.6/xsp.confd b/dev-dotnet/xsp/files/1.2.6/xsp.confd
new file mode 100644
index 000000000000..46784d13b71c
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.6/xsp.confd
@@ -0,0 +1,12 @@
+# Config file for /etc/init.d/xsp
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.6/xsp.confd,v 1.1 2007/12/14 20:10:31 jurek Exp $
+
+# This is the document root; trailing slash is not necessary
+MonoServerRoot=/usr/lib/xsp/test
+
+# Port for the server to run on
+MonoServerPort=8000
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchanged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/1.2.6/xsp.initd b/dev-dotnet/xsp/files/1.2.6/xsp.initd
new file mode 100644
index 000000000000..a2a4d27e1cd1
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.6/xsp.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.6/xsp.initd,v 1.1 2007/12/14 20:10:31 jurek Exp $
+
+depend() {
+ need net
+ after dotnet
+}
+
+start() {
+ ebegin "Starting xsp"
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ xsppath=1.0/xsp.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ xsppath=2.0/xsp2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your config file"
+ return 1
+ fi
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/xsp.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${xsppath} -- --root ${MonoServerRoot} --port ${MonoServerPort} --nonstop
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xsp"
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/xsp.pid
+ eend $?
+}
+
diff --git a/dev-dotnet/xsp/files/digest-xsp-1.2.6 b/dev-dotnet/xsp/files/digest-xsp-1.2.6
new file mode 100644
index 000000000000..2de4d67f52bc
--- /dev/null
+++ b/dev-dotnet/xsp/files/digest-xsp-1.2.6
@@ -0,0 +1,3 @@
+MD5 61dd61398f041002292e5514c28decd3 xsp-1.2.6.tar.bz2 239078
+RMD160 820db0443dc0956aaffb6448c75259295da86bd7 xsp-1.2.6.tar.bz2 239078
+SHA256 5cecf84ee068c744fb4a54fb4701da60bdc0a53fc64c424aca60543601a54093 xsp-1.2.6.tar.bz2 239078
diff --git a/dev-dotnet/xsp/xsp-1.2.6.ebuild b/dev-dotnet/xsp/xsp-1.2.6.ebuild
new file mode 100644
index 000000000000..9010596592f8
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.2.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.2.6.ebuild,v 1.1 2007/12/14 20:10:30 jurek Exp $
+
+inherit mono multilib autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/mono-${PV}"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ "${S}"/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
+ "${D}"/usr/bin/xsp{,2} \
+ "${D}"/usr/bin/mod-mono-server{,2} \
+ "${D}"/usr/bin/asp-state{,2} \
+ "${D}"/usr/bin/dbsessmgr{,2} \
+ || die
+
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}