summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-25 00:10:09 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-25 00:10:09 +0000
commit1a9c579045e167845ddff5c3c1a06f2e24ead06d (patch)
treee8dc7438ddd8ab4eb96a415295d415a88d0d8b2d /dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild
parentarm/sh love #178071 (diff)
downloadgentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.tar.gz
gentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.tar.bz2
gentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.zip
dev-dotnet/mysql-connector-net: version bump -> 1.0.9 (fixing bug #114013)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild')
-rw-r--r--dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild b/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild
new file mode 100644
index 000000000000..a24e3542ca5b
--- /dev/null
+++ b/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild,v 1.1 2007/06/25 00:10:09 jurek Exp $
+
+inherit eutils multilib mono
+
+DESCRIPTION="MySql ADO.NET connector"
+HOMEPAGE="http://www.mysql.com/products/connector/net/"
+SRC_URI="mirror://mysql/Downloads/Connector-Net/${P}-noinstall.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-lang/mono-1.0
+ dev-dotnet/nant
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir ${WORKDIR}/${P}; cd ${WORKDIR}/${P};
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}.patch || die
+
+ sed -i 's:AssemblyKeyFile.*:AssemblyKeyFile(\@\"'${S}'\/\'${PN}'.key")]:' mysqlclient/AssemblyInfo.cs
+}
+
+src_compile() {
+ # Generate signing key
+ ebegin "Generating a signed key"
+ /usr/bin/sn -k ${PN}.key > /dev/null
+ eend
+
+ # Make dll
+ /usr/bin/nant -t:mono-1.0 || die "build failed"
+}
+
+src_install() {
+ # Install dll into the GAC
+ ebegin "Installing dlls into the GAC"
+ gacutil -i mysqlclient/bin/mono-1.0/release/MySql.Data.dll -root ${D}/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package ${PN} > /dev/null
+ eend
+
+ dodoc CHANGES README EXCEPTIONS
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins doc/MySql.Data.chm
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Samples
+ fi
+}
+
+pkg_postinst() {
+ elog "Adding the path for this connector in your mod_mono"
+ elog "configuration may be needed:"
+ elog "MonoPath \"/usr/lib/mono/1.0/${PN}/\""
+}