summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-25 00:10:09 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-25 00:10:09 +0000
commit1a9c579045e167845ddff5c3c1a06f2e24ead06d (patch)
treee8dc7438ddd8ab4eb96a415295d415a88d0d8b2d /dev-dotnet
parentarm/sh love #178071 (diff)
downloadgentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.tar.gz
gentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.tar.bz2
gentoo-2-1a9c579045e167845ddff5c3c1a06f2e24ead06d.zip
dev-dotnet/mysql-connector-net: version bump -> 1.0.9 (fixing bug #114013)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/mysql-connector-net/ChangeLog8
-rw-r--r--dev-dotnet/mysql-connector-net/files/digest-mysql-connector-net-1.0.93
-rw-r--r--dev-dotnet/mysql-connector-net/files/mysql-connector-net-1.0.9.patch68
-rw-r--r--dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild63
4 files changed, 141 insertions, 1 deletions
diff --git a/dev-dotnet/mysql-connector-net/ChangeLog b/dev-dotnet/mysql-connector-net/ChangeLog
index 0a2a131aec58..6edf819b54ea 100644
--- a/dev-dotnet/mysql-connector-net/ChangeLog
+++ b/dev-dotnet/mysql-connector-net/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/mysql-connector-net
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mysql-connector-net/ChangeLog,v 1.7 2007/02/03 02:05:16 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mysql-connector-net/ChangeLog,v 1.8 2007/06/25 00:10:09 jurek Exp $
+
+*mysql-connector-net-1.0.9 (25 Jun 2007)
+
+ 25 Jun 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/mysql-connector-net-1.0.9.patch, +mysql-connector-net-1.0.9.ebuild:
+ Version bump (fixing bug #114013)
03 Feb 2007; Steve Dibb <beandog@gentoo.org>
mysql-connector-net-1.0.4.ebuild:
diff --git a/dev-dotnet/mysql-connector-net/files/digest-mysql-connector-net-1.0.9 b/dev-dotnet/mysql-connector-net/files/digest-mysql-connector-net-1.0.9
new file mode 100644
index 000000000000..3f120b1378ca
--- /dev/null
+++ b/dev-dotnet/mysql-connector-net/files/digest-mysql-connector-net-1.0.9
@@ -0,0 +1,3 @@
+MD5 7ef86895df5186ea5f467c9674780df1 mysql-connector-net-1.0.9-noinstall.zip 1297921
+RMD160 011e330b8824276f0649a62b5c731abc63af0667 mysql-connector-net-1.0.9-noinstall.zip 1297921
+SHA256 cbd08fdc17bcffc493a453ea2df2875023f9d2b13df169db189cddba2d39ad75 mysql-connector-net-1.0.9-noinstall.zip 1297921
diff --git a/dev-dotnet/mysql-connector-net/files/mysql-connector-net-1.0.9.patch b/dev-dotnet/mysql-connector-net/files/mysql-connector-net-1.0.9.patch
new file mode 100644
index 000000000000..2a258f7a18f9
--- /dev/null
+++ b/dev-dotnet/mysql-connector-net/files/mysql-connector-net-1.0.9.patch
@@ -0,0 +1,68 @@
+diff -aurN connector-net-old/Client.build connector-net/Client.build
+--- connector-net-old/Client.build 2007-01-11 16:00:24.000000000 +0100
++++ connector-net/Client.build 2007-02-27 18:25:22.000000000 +0100
+@@ -7,7 +7,7 @@
+ <!-- filesets -->
+ <fileset id="Source">
+ <include name="mysqlclient/common/*.cs"/>
+- <include name="mysqlclient/Types/*.cs"/>
++ <include name="mysqlclient/types/*.cs"/>
+ <include name="mysqlclient/zlib/*.cs"/>
+ <include name="mysqlclient/*.cs"/>
+ </fileset>
+@@ -34,8 +34,7 @@
+ </if>
+
+ <!-- builds the client on all supported frameworks -->
+- <target name="allframeworks" depends="net-1.1">
+- <call target="Docs"/>
++ <target name="allframeworks" depends="mono-1.0">
+ </target>
+
+ <!-- core managed driver target -->
+@@ -73,6 +72,7 @@
+ </references>
+ <sources refid="Source"/>
+ </csc>
++<!--
+ <csc output="${outdir}/MySql.Data.Tests.dll" target="library"
+ debug="${debug}" define="${defines}" optimize="${opt}"> <arg value="/nowarn:0679"/>
+ <sources>
+@@ -85,6 +85,7 @@
+ <include name="${nunit-lib}/nunit.framework.dll"/>
+ </references>
+ </csc>
++//-->
+ </target>
+
+ <!-- core managed driver target 1.0 -->
+@@ -123,7 +124,7 @@
+ </target>
+
+ <!-- testing targets -->
+- <target name="alltests" depends="test-net-1.1">
++ <target name="alltests" depends="test-mono-1.0">
+ </target>
+
+ <target name="test-net-1.1" depends="net-1.1">
+@@ -250,7 +251,7 @@
+ <target name="clean" description="Remove all generated files">
+ <delete failonerror="false">
+ <fileset>
+- <include name="bin/**" />
++ <include name="mysqlclient/bin/**" />
+ </fileset>
+ </delete>
+ </target>
+diff -aurN connector-net-old/mysqlclient/AssemblyInfo.cs connector-net/mysqlclient/AssemblyInfo.cs
+--- connector-net-old/mysqlclient/AssemblyInfo.cs 2007-02-01 15:14:58.000000000 +0100
++++ connector-net/mysqlclient/AssemblyInfo.cs 2007-02-27 19:24:27.000000000 +0100
+@@ -78,7 +78,5 @@
+ // documentation for more information on this.
+ //
+ [assembly: AssemblyDelaySign(false)]
+-#if FINAL
+ [assembly: AssemblyKeyFile("")]
+-[assembly: AssemblyKeyName("ConnectorNet")]
+-#endif
++[assembly: AssemblyKeyName("")]
diff --git a/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild b/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild
new file mode 100644
index 000000000000..a24e3542ca5b
--- /dev/null
+++ b/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mysql-connector-net/mysql-connector-net-1.0.9.ebuild,v 1.1 2007/06/25 00:10:09 jurek Exp $
+
+inherit eutils multilib mono
+
+DESCRIPTION="MySql ADO.NET connector"
+HOMEPAGE="http://www.mysql.com/products/connector/net/"
+SRC_URI="mirror://mysql/Downloads/Connector-Net/${P}-noinstall.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-lang/mono-1.0
+ dev-dotnet/nant
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir ${WORKDIR}/${P}; cd ${WORKDIR}/${P};
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}.patch || die
+
+ sed -i 's:AssemblyKeyFile.*:AssemblyKeyFile(\@\"'${S}'\/\'${PN}'.key")]:' mysqlclient/AssemblyInfo.cs
+}
+
+src_compile() {
+ # Generate signing key
+ ebegin "Generating a signed key"
+ /usr/bin/sn -k ${PN}.key > /dev/null
+ eend
+
+ # Make dll
+ /usr/bin/nant -t:mono-1.0 || die "build failed"
+}
+
+src_install() {
+ # Install dll into the GAC
+ ebegin "Installing dlls into the GAC"
+ gacutil -i mysqlclient/bin/mono-1.0/release/MySql.Data.dll -root ${D}/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package ${PN} > /dev/null
+ eend
+
+ dodoc CHANGES README EXCEPTIONS
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins doc/MySql.Data.chm
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Samples
+ fi
+}
+
+pkg_postinst() {
+ elog "Adding the path for this connector in your mod_mono"
+ elog "configuration may be needed:"
+ elog "MonoPath \"/usr/lib/mono/1.0/${PN}/\""
+}