summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-03 15:37:55 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-03 15:37:55 +0000
commit3fec4c78d36454aeded8e3bde7e5e3b6e50c9617 (patch)
tree8175456d02973bd33668de41a10a7372c84c187a /app-text/spellutils
parentppc stable #252747 (diff)
downloadgentoo-2-3fec4c78d36454aeded8e3bde7e5e3b6e50c9617.tar.gz
gentoo-2-3fec4c78d36454aeded8e3bde7e5e3b6e50c9617.tar.bz2
gentoo-2-3fec4c78d36454aeded8e3bde7e5e3b6e50c9617.zip
QA: Respect CC (bug 243756)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/spellutils')
-rw-r--r--app-text/spellutils/ChangeLog7
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild19
2 files changed, 14 insertions, 12 deletions
diff --git a/app-text/spellutils/ChangeLog b/app-text/spellutils/ChangeLog
index ee6198c8c852..6900546e7237 100644
--- a/app-text/spellutils/ChangeLog
+++ b/app-text/spellutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/spellutils
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/ChangeLog,v 1.12 2007/05/14 20:13:36 bangert Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/ChangeLog,v 1.13 2009/01/03 15:37:55 angelos Exp $
+
+ 03 Jan 2009; Christoph Mende <angelos@gentoo.org> spellutils-0.7.ebuild:
+ QA: Respect CC (bug 243756)
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
index 03710245dcbc..89d112ff3aaa 100644
--- a/app-text/spellutils/spellutils-0.7.ebuild
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.10 2005/04/24 11:43:09 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.11 2009/01/03 15:37:55 angelos Exp $
-IUSE="nls"
+inherit toolchain-funcs
DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
SRC_URI="http://home.worldonline.dk/byrial/spellutils/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa amd64"
-
-DEPEND="virtual/libc"
+IUSE="nls"
src_compile() {
- econf `use_enable nls` || die
- emake || die
+ econf $(use_enable nls)
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
- einstall
- dodoc FILES NEWS README ABOUT-NLS COPYING INSTALL
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README
}