summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/spellutils/spellutils-0.7.ebuild')
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
index 03710245dcbc..89d112ff3aaa 100644
--- a/app-text/spellutils/spellutils-0.7.ebuild
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.10 2005/04/24 11:43:09 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.11 2009/01/03 15:37:55 angelos Exp $
-IUSE="nls"
+inherit toolchain-funcs
DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
SRC_URI="http://home.worldonline.dk/byrial/spellutils/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa amd64"
-
-DEPEND="virtual/libc"
+IUSE="nls"
src_compile() {
- econf `use_enable nls` || die
- emake || die
+ econf $(use_enable nls)
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
- einstall
- dodoc FILES NEWS README ABOUT-NLS COPYING INSTALL
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README
}