summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-13 13:28:45 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-13 13:28:45 +0000
commit8ee6d58b3c8a594a32bb52789908a4df9abcf54e (patch)
tree5c6bafbc53a039af2c1eab9aa0c3f5033ab2b65b /app-shells
parentUpdate and FHS fix (diff)
downloadgentoo-2-8ee6d58b3c8a594a32bb52789908a4df9abcf54e.tar.gz
gentoo-2-8ee6d58b3c8a594a32bb52789908a4df9abcf54e.tar.bz2
gentoo-2-8ee6d58b3c8a594a32bb52789908a4df9abcf54e.zip
USE fixees
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/files/digest-sash-3.4-r32
-rw-r--r--app-shells/sash/sash-3.4-r2.ebuild17
-rw-r--r--app-shells/sash/sash-3.4-r3.ebuild56
3 files changed, 68 insertions, 7 deletions
diff --git a/app-shells/sash/files/digest-sash-3.4-r3 b/app-shells/sash/files/digest-sash-3.4-r3
new file mode 100644
index 000000000000..7974abfbe86e
--- /dev/null
+++ b/app-shells/sash/files/digest-sash-3.4-r3
@@ -0,0 +1,2 @@
+MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz
+MD5 43cbfb670d42e6e15b58f3b528f75ca0 sash-3.x-readline.diff.gz
diff --git a/app-shells/sash/sash-3.4-r2.ebuild b/app-shells/sash/sash-3.4-r2.ebuild
index 71ca950bea6d..c68694b990d5 100644
--- a/app-shells/sash/sash-3.4-r2.ebuild
+++ b/app-shells/sash/sash-3.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.5 2001/04/13 13:28:45 achim Exp $
P=sash-3.4
A="${P}.tar.gz sash-3.x-readline.diff.gz"
@@ -10,24 +10,27 @@ DESCRIPTION="A small UNIX Shell with readline suppport"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- >=sys-libs/readline-4.1"
+ readline? ( >=sys-libs/readline-4.1 )"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
- cp Makefile Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" \
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+ fi
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" \
-e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
}
src_compile() {
cd ${S}
- try make
+ try make LDFLAGS=\"\"
}
src_install() {
diff --git a/app-shells/sash/sash-3.4-r3.ebuild b/app-shells/sash/sash-3.4-r3.ebuild
new file mode 100644
index 000000000000..005b2e3f1139
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r3.ebuild,v 1.1 2001/04/13 13:28:45 achim Exp $
+
+P=sash-3.4
+A="${P}.tar.gz sash-3.x-readline.diff.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="A small UNIX Shell with readline suppport"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 )"
+
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${A}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" \
+ -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ fi
+}
+src_compile() {
+
+ if [ "`use static`" ]
+ then
+ try make
+ else
+ try make LDFLAGS=\"\"
+ fi
+}
+
+src_install() {
+
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+
+
+
+
+
+