summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/sash/sash-3.4-r2.ebuild')
-rw-r--r--app-shells/sash/sash-3.4-r2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-shells/sash/sash-3.4-r2.ebuild b/app-shells/sash/sash-3.4-r2.ebuild
index 71ca950bea6d..c68694b990d5 100644
--- a/app-shells/sash/sash-3.4-r2.ebuild
+++ b/app-shells/sash/sash-3.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.5 2001/04/13 13:28:45 achim Exp $
P=sash-3.4
A="${P}.tar.gz sash-3.x-readline.diff.gz"
@@ -10,24 +10,27 @@ DESCRIPTION="A small UNIX Shell with readline suppport"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- >=sys-libs/readline-4.1"
+ readline? ( >=sys-libs/readline-4.1 )"
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
- cp Makefile Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" \
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+ fi
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" \
-e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
}
src_compile() {
cd ${S}
- try make
+ try make LDFLAGS=\"\"
}
src_install() {