summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-03-15 15:52:32 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-03-15 15:52:32 +0000
commit106cfc2f0be8dc93862b182e491638cc41c4d96a (patch)
treeb0c7b32bccee20d7a8ae36ad9ec740eabc72e8a6 /app-misc
parentUpdated to use new fixlocalpod function from perl-module.eclass instead of th... (diff)
downloadgentoo-2-106cfc2f0be8dc93862b182e491638cc41c4d96a.tar.gz
gentoo-2-106cfc2f0be8dc93862b182e491638cc41c4d96a.tar.bz2
gentoo-2-106cfc2f0be8dc93862b182e491638cc41c4d96a.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/alexandria/ChangeLog8
-rw-r--r--app-misc/alexandria/Manifest12
-rw-r--r--app-misc/alexandria/alexandria-0.5.0.ebuild48
-rw-r--r--app-misc/alexandria/files/digest-alexandria-0.5.01
4 files changed, 58 insertions, 11 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index 8e4926764570..cab69a9f62e9 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.4 2005/01/04 15:45:06 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.5 2005/03/15 15:52:32 citizen428 Exp $
+
+*alexandria-0.5.0 (15 Mar 2005)
+
+ 15 Mar 2005; Michael Kohl <citizen428@gentoo.org>
+ +alexandria-0.5.0.ebuild:
+ Version bump.
04 Jan 2005; Michael Kohl <citizen428@gentoo.org> alexandria-0.4.0.ebuild:
Marked stable on x86.
diff --git a/app-misc/alexandria/Manifest b/app-misc/alexandria/Manifest
index 6480f8b5d787..6e902f99b537 100644
--- a/app-misc/alexandria/Manifest
+++ b/app-misc/alexandria/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 28c34d5d6dc300ab1d5fddd067c07eb0 alexandria-0.5.0.ebuild 1214
MD5 303a0e9cbfcccb107accbeeef2fbcdc0 alexandria-0.4.0.ebuild 1375
MD5 7bf82984d9d92ee07eb323a2f56fb50c ChangeLog 605
MD5 8efa6365a12e903001e60e3f38150264 metadata.xml 274
MD5 341d3725f27c89e493daf66c2d07217d files/digest-alexandria-0.4.0 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFB2roP/UDVUK2NELYRAk9CAKDNgEcj02JebT9jASHwI62jMYXJ2ACfTzml
-+doxF9lXnf4XyofGxdE2JBM=
-=E868
------END PGP SIGNATURE-----
+MD5 aafb80203d611fa22e8152615b0f004f files/digest-alexandria-0.5.0 68
diff --git a/app-misc/alexandria/alexandria-0.5.0.ebuild b/app-misc/alexandria/alexandria-0.5.0.ebuild
new file mode 100644
index 000000000000..77b17e6510bf
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.5.0.ebuild,v 1.1 2005/03/15 15:52:32 citizen428 Exp $
+
+inherit ruby gnome2
+
+IUSE=""
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/3445/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+USE_RUBY="ruby18"
+
+DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+
+RDEPEND="virtual/ruby
+ >=ruby-gettext-0.6.1
+ >=ruby-gnome2-0.10.1
+ >=ruby-libglade2-0.10.1
+ >=ruby-gconf2-0.10.1
+ >=ruby-gdkpixbuf2-0.10.1
+ >=ruby-amazon-0.8.3"
+
+src_compile() {
+ #echo $GCONF_CONFIG_SOURCE
+ ruby install.rb config || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+}
+
+pkg_postinst() {
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ # More or less copied from gnome2_gconf_install, which didn't work here
+ export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+ einfo "Installing GNOME 2 GConf schemas"
+ ${ROOT}/usr/bin/gconftool-2 --makefile-install-rule ${S}/schemas/* 1>/dev/null
+}
diff --git a/app-misc/alexandria/files/digest-alexandria-0.5.0 b/app-misc/alexandria/files/digest-alexandria-0.5.0
new file mode 100644
index 000000000000..fd3e1889f9ac
--- /dev/null
+++ b/app-misc/alexandria/files/digest-alexandria-0.5.0
@@ -0,0 +1 @@
+MD5 d5a7bf954560faefb9b9556051e1ffda alexandria-0.5.0.tar.gz 123506