summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/alexandria/alexandria-0.5.0.ebuild')
-rw-r--r--app-misc/alexandria/alexandria-0.5.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/alexandria/alexandria-0.5.0.ebuild b/app-misc/alexandria/alexandria-0.5.0.ebuild
new file mode 100644
index 000000000000..77b17e6510bf
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.5.0.ebuild,v 1.1 2005/03/15 15:52:32 citizen428 Exp $
+
+inherit ruby gnome2
+
+IUSE=""
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/3445/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+USE_RUBY="ruby18"
+
+DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+
+RDEPEND="virtual/ruby
+ >=ruby-gettext-0.6.1
+ >=ruby-gnome2-0.10.1
+ >=ruby-libglade2-0.10.1
+ >=ruby-gconf2-0.10.1
+ >=ruby-gdkpixbuf2-0.10.1
+ >=ruby-amazon-0.8.3"
+
+src_compile() {
+ #echo $GCONF_CONFIG_SOURCE
+ ruby install.rb config || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+}
+
+pkg_postinst() {
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ # More or less copied from gnome2_gconf_install, which didn't work here
+ export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+ einfo "Installing GNOME 2 GConf schemas"
+ ${ROOT}/usr/bin/gconftool-2 --makefile-install-rule ${S}/schemas/* 1>/dev/null
+}