summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-27 18:50:00 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-27 18:50:00 +0000
commitaf194d6389066e0a66445b1465cc7d42daced62d (patch)
treeee21a252554d48bcf1b988fc4e486914556b431b /app-forensics
parentVersion bump, fixing bug #423311, thanks Jauhien Piatlicki (diff)
downloadgentoo-2-af194d6389066e0a66445b1465cc7d42daced62d.tar.gz
gentoo-2-af194d6389066e0a66445b1465cc7d42daced62d.tar.bz2
gentoo-2-af194d6389066e0a66445b1465cc7d42daced62d.zip
Use autotools and prune_libtool_files instead of the autotools-utils eclass.
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog5
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild28
2 files changed, 20 insertions, 13 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 48270fcf5f53..ddcfb9fddf35 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.56 2012/03/02 05:58:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.57 2012/06/27 18:50:00 radhermit Exp $
+
+ 27 Jun 2012; Tim Harder <radhermit@gentoo.org> sleuthkit-3.2.3.ebuild:
+ Use autotools and prune_libtool_files instead of the autotools-utils eclass.
02 Mar 2012; Tim Harder <radhermit@gentoo.org> -sleuthkit-2.09.ebuild,
-sleuthkit-3.0.0-r1.ebuild, -sleuthkit-3.1.0.ebuild,
diff --git a/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
index cd8eea509953..d4a7ae612e8e 100644
--- a/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild,v 1.2 2012/02/28 02:29:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild,v 1.3 2012/06/27 18:50:00 radhermit Exp $
EAPI="4"
-AUTOTOOLS_AUTORECONF=1
-inherit eutils autotools-utils
+inherit eutils autotools
DESCRIPTION="A collection of file system and media management forensic analysis tools"
HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
@@ -24,15 +23,20 @@ RDEPEND="${DEPEND}
DOCS=( NEWS.txt README.txt )
-PATCHES=(
- "${FILESDIR}"/${P}-system-sqlite.patch
- "${FILESDIR}"/${P}-tools-shared-libs.patch
-)
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-system-sqlite.patch
+ epatch "${FILESDIR}"/${P}-tools-shared-libs.patch
+ eautoreconf
+}
src_configure() {
- local myeconfargs=(
- $(use_with aff afflib)
- $(use_with ewf libewf)
- )
- autotools-utils_src_configure
+ econf \
+ $(use_with aff afflib) \
+ $(use_with ewf libewf) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
}