summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild')
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
index cd8eea509953..d4a7ae612e8e 100644
--- a/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild,v 1.2 2012/02/28 02:29:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.2.3.ebuild,v 1.3 2012/06/27 18:50:00 radhermit Exp $
EAPI="4"
-AUTOTOOLS_AUTORECONF=1
-inherit eutils autotools-utils
+inherit eutils autotools
DESCRIPTION="A collection of file system and media management forensic analysis tools"
HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
@@ -24,15 +23,20 @@ RDEPEND="${DEPEND}
DOCS=( NEWS.txt README.txt )
-PATCHES=(
- "${FILESDIR}"/${P}-system-sqlite.patch
- "${FILESDIR}"/${P}-tools-shared-libs.patch
-)
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-system-sqlite.patch
+ epatch "${FILESDIR}"/${P}-tools-shared-libs.patch
+ eautoreconf
+}
src_configure() {
- local myeconfargs=(
- $(use_with aff afflib)
- $(use_with ewf libewf)
- )
- autotools-utils_src_configure
+ econf \
+ $(use_with aff afflib) \
+ $(use_with ewf libewf) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
}