summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-02-10 06:32:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-02-10 06:32:50 +0000
commit56aab367cf61fd6e8263da6f8ec789cc264d8f4a (patch)
tree150a277f4a240b9d7197b47041f83377524a2a2f /app-emulation/bochs/bochs-2.4.1.ebuild
parentMake conditional so we don't die w/ USE="-wxwidgets" when wxGTK (diff)
downloadgentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.tar.gz
gentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.tar.bz2
gentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.zip
Revert back to conditional so we don't die with USE="-wxwidgets" when
wxGTK was built with USE="-X". (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/bochs/bochs-2.4.1.ebuild')
-rw-r--r--app-emulation/bochs/bochs-2.4.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/bochs/bochs-2.4.1.ebuild b/app-emulation/bochs/bochs-2.4.1.ebuild
index 1c902e700d02..ce26c06806e3 100644
--- a/app-emulation/bochs/bochs-2.4.1.ebuild
+++ b/app-emulation/bochs/bochs-2.4.1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.3 2010/02/10 03:52:03 dirtyepic Exp $
-
-WX_GTK_VER=2.6
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.4 2010/02/10 06:32:50 dirtyepic Exp $
inherit eutils wxwidgets
@@ -44,6 +42,11 @@ src_unpack() {
}
src_compile() {
+ WX_GTK_VER=2.6
+
+ use wxwidgets && \
+ need-wxwidgets ansi
+
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"