summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-02-10 06:32:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-02-10 06:32:50 +0000
commit56aab367cf61fd6e8263da6f8ec789cc264d8f4a (patch)
tree150a277f4a240b9d7197b47041f83377524a2a2f /app-emulation
parentMake conditional so we don't die w/ USE="-wxwidgets" when wxGTK (diff)
downloadgentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.tar.gz
gentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.tar.bz2
gentoo-2-56aab367cf61fd6e8263da6f8ec789cc264d8f4a.zip
Revert back to conditional so we don't die with USE="-wxwidgets" when
wxGTK was built with USE="-X". (Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog8
-rw-r--r--app-emulation/bochs/bochs-2.3.6.ebuild9
-rw-r--r--app-emulation/bochs/bochs-2.3.7.ebuild9
-rw-r--r--app-emulation/bochs/bochs-2.3.ebuild9
-rw-r--r--app-emulation/bochs/bochs-2.4.1.ebuild9
5 files changed, 31 insertions, 13 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index d4efa5fb4fdc..5d5cf1dd4158 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/bochs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.86 2010/02/10 03:52:03 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.87 2010/02/10 06:32:50 dirtyepic Exp $
+
+ 10 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> bochs-2.3.ebuild,
+ bochs-2.3.6.ebuild, bochs-2.3.7.ebuild, bochs-2.4.1.ebuild:
+ Revert back to conditional so we don't die with USE="-wxwidgets" when
+ wxGTK
+ was built with USE="-X".
10 Feb 2010; Ryan Hill <dirtyepic@gentoo.org> bochs-2.3.ebuild,
bochs-2.3.6.ebuild, bochs-2.3.7.ebuild, bochs-2.4.1.ebuild:
diff --git a/app-emulation/bochs/bochs-2.3.6.ebuild b/app-emulation/bochs/bochs-2.3.6.ebuild
index 2947c5d59cd6..e8f811eb3a13 100644
--- a/app-emulation/bochs/bochs-2.3.6.ebuild
+++ b/app-emulation/bochs/bochs-2.3.6.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.5 2010/02/10 03:52:03 dirtyepic Exp $
-
-WX_GTK_VER=2.6
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.6 2010/02/10 06:32:50 dirtyepic Exp $
inherit eutils wxwidgets
@@ -44,6 +42,11 @@ src_unpack() {
}
src_compile() {
+ WX_GTK_VER=2.6
+
+ use wxwidgets && \
+ need-wxwidgets ansi
+
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
diff --git a/app-emulation/bochs/bochs-2.3.7.ebuild b/app-emulation/bochs/bochs-2.3.7.ebuild
index 3647951167ad..8d1363d1e337 100644
--- a/app-emulation/bochs/bochs-2.3.7.ebuild
+++ b/app-emulation/bochs/bochs-2.3.7.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.7 2010/02/10 03:52:03 dirtyepic Exp $
-
-WX_GTK_VER=2.6
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.8 2010/02/10 06:32:50 dirtyepic Exp $
inherit eutils wxwidgets
@@ -47,6 +45,11 @@ src_unpack() {
}
src_compile() {
+ WX_GTK_VER=2.6
+
+ use wxwidgets && \
+ need-wxwidgets ansi
+
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"
diff --git a/app-emulation/bochs/bochs-2.3.ebuild b/app-emulation/bochs/bochs-2.3.ebuild
index 774272eb5c0c..131326699841 100644
--- a/app-emulation/bochs/bochs-2.3.ebuild
+++ b/app-emulation/bochs/bochs-2.3.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.9 2010/02/10 03:52:03 dirtyepic Exp $
-
-WX_GTK_VER=2.6
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.10 2010/02/10 06:32:50 dirtyepic Exp $
inherit eutils wxwidgets autotools
@@ -52,6 +50,11 @@ src_unpack() {
}
src_compile() {
+ WX_GTK_VER=2.6
+
+ use wxwidgets && \
+ need-wxwidgets ansi
+
[[ "$ARCH" == "x86" ]] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
diff --git a/app-emulation/bochs/bochs-2.4.1.ebuild b/app-emulation/bochs/bochs-2.4.1.ebuild
index 1c902e700d02..ce26c06806e3 100644
--- a/app-emulation/bochs/bochs-2.4.1.ebuild
+++ b/app-emulation/bochs/bochs-2.4.1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.3 2010/02/10 03:52:03 dirtyepic Exp $
-
-WX_GTK_VER=2.6
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.4 2010/02/10 06:32:50 dirtyepic Exp $
inherit eutils wxwidgets
@@ -44,6 +42,11 @@ src_unpack() {
}
src_compile() {
+ WX_GTK_VER=2.6
+
+ use wxwidgets && \
+ need-wxwidgets ansi
+
use x86 && \
myconf="--enable-idle-hack --enable-fast-function-calls"