summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-15 20:11:44 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-15 20:11:44 +0000
commit36953e4f8f1da5d09ea9b157e2b3c2a1094e451c (patch)
treeeeacf800212d78356077b3d7f86adea0ce911fc6 /app-emacs/gnus
parentStable on ppc64 (diff)
downloadgentoo-2-36953e4f8f1da5d09ea9b157e2b3c2a1094e451c.tar.gz
gentoo-2-36953e4f8f1da5d09ea9b157e2b3c2a1094e451c.tar.bz2
gentoo-2-36953e4f8f1da5d09ea9b157e2b3c2a1094e451c.zip
Replaced emake by einstall, fixed a typo.
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-emacs/gnus')
-rw-r--r--app-emacs/gnus/ChangeLog7
-rw-r--r--app-emacs/gnus/files/digest-gnus-5.10.8-r13
-rw-r--r--app-emacs/gnus/gnus-5.10.8-r1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/app-emacs/gnus/ChangeLog b/app-emacs/gnus/ChangeLog
index 44d1ff950c2e..d4d566a5fb17 100644
--- a/app-emacs/gnus/ChangeLog
+++ b/app-emacs/gnus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gnus
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.24 2007/04/10 19:56:34 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.25 2007/04/15 20:11:44 ulm Exp $
+
+*gnus-5.10.8-r1 (15 Apr 2007)
+
+ 15 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +gnus-5.10.8-r1.ebuild:
+ Replaced emake by einstall; added a missing dollar sign. Fixes bug #174524.
10 Apr 2007; Christian Faulhammer <opfer@gentoo.org> gnus-5.10.8.ebuild:
added FDL license, restructured, added a die comment and added some quotes
diff --git a/app-emacs/gnus/files/digest-gnus-5.10.8-r1 b/app-emacs/gnus/files/digest-gnus-5.10.8-r1
new file mode 100644
index 000000000000..cd87954879c7
--- /dev/null
+++ b/app-emacs/gnus/files/digest-gnus-5.10.8-r1
@@ -0,0 +1,3 @@
+MD5 385e1db2a0cb0a89db30870f0a37453b gnus-5.10.8.tar.gz 2496529
+RMD160 4a2fdea20961d7a714670b59f4d34864ebcaa930 gnus-5.10.8.tar.gz 2496529
+SHA256 4855d339470c252055b9d848ded8a8cad151c178d10d2bd8328960c32c446a90 gnus-5.10.8.tar.gz 2496529
diff --git a/app-emacs/gnus/gnus-5.10.8-r1.ebuild b/app-emacs/gnus/gnus-5.10.8-r1.ebuild
new file mode 100644
index 000000000000..a28bc94f808e
--- /dev/null
+++ b/app-emacs/gnus/gnus-5.10.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/gnus-5.10.8-r1.ebuild,v 1.1 2007/04/15 20:11:44 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Gnus newsreader and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+SITEFILE=70${PN}-gentoo.el
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --without-w3 --without-url"
+ econf \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/gnus \
+ --with-etcdir=/usr/share/emacs/etc \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall \
+ lispdir="${D}/usr/share/emacs/site-lisp/gnus" \
+ etcdir="${D}/usr/share/emacs/etc" install \
+ || die "einstall failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find "${D}/usr/share/info" -type f -exec mv {} {}.info \;
+}