summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/gnus/gnus-5.10.8-r1.ebuild')
-rw-r--r--app-emacs/gnus/gnus-5.10.8-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/gnus/gnus-5.10.8-r1.ebuild b/app-emacs/gnus/gnus-5.10.8-r1.ebuild
new file mode 100644
index 000000000000..a28bc94f808e
--- /dev/null
+++ b/app-emacs/gnus/gnus-5.10.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/gnus-5.10.8-r1.ebuild,v 1.1 2007/04/15 20:11:44 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Gnus newsreader and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+SITEFILE=70${PN}-gentoo.el
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --without-w3 --without-url"
+ econf \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/gnus \
+ --with-etcdir=/usr/share/emacs/etc \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ einstall \
+ lispdir="${D}/usr/share/emacs/site-lisp/gnus" \
+ etcdir="${D}/usr/share/emacs/etc" install \
+ || die "einstall failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find "${D}/usr/share/info" -type f -exec mv {} {}.info \;
+}