summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-04-28 16:06:17 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-04-28 16:06:17 +0000
commit7a6daf0ab1750ef226f5da84b506c412ba6e4692 (patch)
tree7119a0ebd05965eeddc1a51e6fdb66b9a834e406 /app-editors/teco
parentPointing SRC_URI to mirror://gentoo. (diff)
downloadgentoo-2-7a6daf0ab1750ef226f5da84b506c412ba6e4692.tar.gz
gentoo-2-7a6daf0ab1750ef226f5da84b506c412ba6e4692.tar.bz2
gentoo-2-7a6daf0ab1750ef226f5da84b506c412ba6e4692.zip
Initial import of two TECO-style editors, one classic, one visual.
Diffstat (limited to 'app-editors/teco')
-rw-r--r--app-editors/teco/teco-1.00.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/teco/teco-1.00.ebuild b/app-editors/teco/teco-1.00.ebuild
new file mode 100644
index 000000000000..a202aec964c4
--- /dev/null
+++ b/app-editors/teco/teco-1.00.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00.ebuild,v 1.1 2003/04/28 16:06:17 taviso Exp $
+
+# "Real mans editor" quote from package's lsm ;)
+DESCRIPTION="Classic TECO editor, Predecessor to EMACS. Real mans editor."
+HOMEPAGE="http://www.ibiblio.org/pub/linux/apps/editors/tty/"
+SRC_URI="http://www.ibiblio.org/pub/linux/apps/editors/tty/teco.tar.gz"
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ sys-libs/libtermcap-compat
+ >=sys-apps/sed-4"
+RDEPEND="virtual/glibc
+ sys-libs/libtermcap-compat"
+S=${WORKDIR}
+
+src_compile() {
+ sed -i 's/CFLAGS = -O//' Makefile
+ emake || die "compilation failed"
+}
+
+src_install() {
+ insinto /usr/bin
+ dobin te
+ dodoc sample.tecorc sample.tecorc2 READ.ME MANIFEST
+ doman te.1
+}
+
+pkg_postinst() {
+ einfo "The TECO binary is called te."
+ einfo "Sample configurations are available in /usr/share/doc/"
+}