summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/teco/teco-1.00.ebuild35
-rw-r--r--app-editors/videoteco/videoteco-4.69.ebuild28
2 files changed, 63 insertions, 0 deletions
diff --git a/app-editors/teco/teco-1.00.ebuild b/app-editors/teco/teco-1.00.ebuild
new file mode 100644
index 000000000000..a202aec964c4
--- /dev/null
+++ b/app-editors/teco/teco-1.00.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00.ebuild,v 1.1 2003/04/28 16:06:17 taviso Exp $
+
+# "Real mans editor" quote from package's lsm ;)
+DESCRIPTION="Classic TECO editor, Predecessor to EMACS. Real mans editor."
+HOMEPAGE="http://www.ibiblio.org/pub/linux/apps/editors/tty/"
+SRC_URI="http://www.ibiblio.org/pub/linux/apps/editors/tty/teco.tar.gz"
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ sys-libs/libtermcap-compat
+ >=sys-apps/sed-4"
+RDEPEND="virtual/glibc
+ sys-libs/libtermcap-compat"
+S=${WORKDIR}
+
+src_compile() {
+ sed -i 's/CFLAGS = -O//' Makefile
+ emake || die "compilation failed"
+}
+
+src_install() {
+ insinto /usr/bin
+ dobin te
+ dodoc sample.tecorc sample.tecorc2 READ.ME MANIFEST
+ doman te.1
+}
+
+pkg_postinst() {
+ einfo "The TECO binary is called te."
+ einfo "Sample configurations are available in /usr/share/doc/"
+}
diff --git a/app-editors/videoteco/videoteco-4.69.ebuild b/app-editors/videoteco/videoteco-4.69.ebuild
new file mode 100644
index 000000000000..694926a4017d
--- /dev/null
+++ b/app-editors/videoteco/videoteco-4.69.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/videoteco/videoteco-4.69.ebuild,v 1.1 2003/04/28 16:06:17 taviso Exp $
+
+DESCRIPTION="Enhanced Visual TECO clone"
+HOMEPAGE="ftp://ftp.mindlink.net/pub/teco/cantrell-teco/"
+SRC_URI="ftp://ftp.mindlink.net/pub/teco/cantrell-teco/teco_4_69.tar.gz
+ ftp://ftp.mindlink.net/pub/teco/cantrell-teco/unofficial_patches/4.69/patch1"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ sys-libs/libtermcap-compat"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/teco_4_69
+
+src_compile() {
+ epatch ${FILESDIR}/teco_linux_gcc3.patch || die "patching failed."
+ epatch ${DISTDIR}/patch1 || die "patching failed."
+ emake || die "compilation failed"
+}
+
+src_install() {
+ insinto /usr/bin
+ dobin teco
+ dodoc README RELEASE_NOTES
+}