summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:48:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:48:31 +0000
commitfbdbbb5186993b279eb01cdb9053c1d3d12b0f2a (patch)
treea1e081d399393d9082f5c76352ee0a6e7ab36af0 /app-arch
parentDelete older ebuilds. (diff)
downloadgentoo-2-fbdbbb5186993b279eb01cdb9053c1d3d12b0f2a.tar.gz
gentoo-2-fbdbbb5186993b279eb01cdb9053c1d3d12b0f2a.tar.bz2
gentoo-2-fbdbbb5186993b279eb01cdb9053c1d3d12b0f2a.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/ChangeLog6
-rw-r--r--app-arch/rpm/rpm-4.4.6-r6.ebuild7
-rw-r--r--app-arch/rpm/rpm-4.4.7-r4.ebuild9
-rw-r--r--app-arch/rpm/rpm-5.1.6.ebuild5
4 files changed, 14 insertions, 13 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 5a178e2fa4a4..b4b3d40a8a0d 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.105 2010/02/08 09:01:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.106 2010/04/04 21:48:31 arfrever Exp $
+
+ 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ rpm-4.4.6-r6.ebuild, rpm-4.4.7-r4.ebuild, rpm-5.1.6.ebuild:
+ Delete calls to deprecated python_version().
08 Feb 2010; Peter Volkov <pva@gentoo.org> rpm-5.0.0.ebuild,
rpm-5.0.3.ebuild, rpm-5.1.6.ebuild:
diff --git a/app-arch/rpm/rpm-4.4.6-r6.ebuild b/app-arch/rpm/rpm-4.4.6-r6.ebuild
index b902ce7b2eb2..2f09e9773380 100644
--- a/app-arch/rpm/rpm-4.4.6-r6.ebuild
+++ b/app-arch/rpm/rpm-4.4.6-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r6.ebuild,v 1.10 2009/09/06 19:27:42 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r6.ebuild,v 1.11 2010/04/04 21:48:31 arfrever Exp $
inherit eutils autotools distutils perl-module flag-o-matic
@@ -60,12 +60,11 @@ src_compile() {
# Until strict aliasing is porperly fixed...
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
- python_version
econf \
--enable-posixmutexes \
--without-javaglue \
--without-selinux \
- $(use_with python python ${PYVER}) \
+ $(use_with python python $(python_get_version)) \
$(use_with doc apidocs) \
$(use_with perl) \
$(use_with sqlite) \
diff --git a/app-arch/rpm/rpm-4.4.7-r4.ebuild b/app-arch/rpm/rpm-4.4.7-r4.ebuild
index d0514ab4230d..1c26d32317d8 100644
--- a/app-arch/rpm/rpm-4.4.7-r4.ebuild
+++ b/app-arch/rpm/rpm-4.4.7-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r4.ebuild,v 1.3 2009/09/06 19:27:42 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r4.ebuild,v 1.4 2010/04/04 21:48:31 arfrever Exp $
inherit eutils autotools distutils perl-module flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="nls python perl doc sqlite"
RDEPEND="=sys-libs/db-3.2*
@@ -61,12 +61,11 @@ src_compile() {
# Until strict aliasing is porperly fixed...
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
- python_version
econf \
--enable-posixmutexes \
--without-javaglue \
--without-selinux \
- $(use_with python python ${PYVER}) \
+ $(use_with python python $(python_get_version)) \
$(use_with doc apidocs) \
$(use_with perl) \
$(use_with sqlite) \
diff --git a/app-arch/rpm/rpm-5.1.6.ebuild b/app-arch/rpm/rpm-5.1.6.ebuild
index ebf6458c73dd..6fcbdf08438c 100644
--- a/app-arch/rpm/rpm-5.1.6.ebuild
+++ b/app-arch/rpm/rpm-5.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-5.1.6.ebuild,v 1.4 2010/02/08 09:01:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-5.1.6.ebuild,v 1.5 2010/04/04 21:48:31 arfrever Exp $
inherit eutils multilib distutils python
@@ -61,7 +61,6 @@ src_compile() {
# $(use_with keyutils) \
# $(use_with xar) \
# --with-libelf
- use python && python_version
econf \
$(use_with berkdb db) \
$(use_with bzip2) \
@@ -77,7 +76,7 @@ src_compile() {
$(use_with sqlite) \
$(use berkdb || use sqlite || echo --with-db) \
--with-path-lib="/usr/$(get_libdir)/rpm" \
- --with-python-lib-dir="/usr/$(get_libdir)/python${PYVER}" \
+ --with-python-lib-dir="$(python_get_libdir)" \
|| die "econf failed"
emake || die "emake failed"
}