summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:46:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:46:10 +0000
commitb7f0e30c41f92ba2799e509d44cfeb9035979929 (patch)
tree902c4cc98a790e5f656d4c7ab21ca6eaaec1be3b /app-arch
parentDelete calls to deprecated python_version(). (diff)
downloadgentoo-2-b7f0e30c41f92ba2799e509d44cfeb9035979929.tar.gz
gentoo-2-b7f0e30c41f92ba2799e509d44cfeb9035979929.tar.bz2
gentoo-2-b7f0e30c41f92ba2799e509d44cfeb9035979929.zip
Delete older ebuilds.
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/rpm-4.4.7-r1.ebuild98
-rw-r--r--app-arch/rpm/rpm-4.4.7-r2.ebuild103
-rw-r--r--app-arch/rpm/rpm-5.0.0.ebuild104
-rw-r--r--app-arch/rpm/rpm-5.0.3.ebuild104
4 files changed, 0 insertions, 409 deletions
diff --git a/app-arch/rpm/rpm-4.4.7-r1.ebuild b/app-arch/rpm/rpm-4.4.7-r1.ebuild
deleted file mode 100644
index 90d090d0b177..000000000000
--- a/app-arch/rpm/rpm-4.4.7-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r1.ebuild,v 1.4 2009/09/06 19:27:42 idl0r Exp $
-
-inherit eutils autotools distutils perl-module
-
-DESCRIPTION="Red Hat Package Management Utils"
-HOMEPAGE="http://www.rpm.org/"
-SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls python perl doc sqlite"
-
-RDEPEND="=sys-libs/db-3.2*
- >=sys-libs/zlib-1.2.3-r1
- >=app-arch/bzip2-1.0.1
- >=dev-libs/popt-1.7
- >=app-crypt/gnupg-1.2
- dev-libs/elfutils
- virtual/libintl
- >=dev-libs/beecrypt-3.1.0-r1
- python? ( >=dev-lang/python-2.2 )
- perl? ( >=dev-lang/perl-5.8.8 )
- nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3.3.5 )
- net-misc/neon"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
- epatch "${FILESDIR}"/rpm-4.4.7-stupidness.patch
- epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
- epatch "${FILESDIR}"/rpm-4.4.6-buffer-overflow.patch
-
- # rpm uses AM_GNU_GETTEXT() but fails to actually
- # include any of the required gettext files
- cp /usr/share/gettext/config.rpath . || die
-
- # the following are additional libraries that might be packaged with
- # the rpm sources. grep for "test -d" in configure.ac
- cp file/src/{file,patchlevel}.h tools/
- rm -rf beecrypt elfutils neon popt sqlite zlib intl file
-
- sed -i -e "s:intl ::" Makefile.am
- sed -i -e "s:intl/Makefile ::" configure.ac
- AT_NO_RECURSIVE="yes" eautoreconf
- # TODO Get rid of internal copies of lua, db and db3
-}
-
-src_compile() {
- python_version
- econf \
- --enable-posixmutexes \
- --without-javaglue \
- --without-selinux \
- $(use_with python python ${PYVER}) \
- $(use_with doc apidocs) \
- $(use_with perl) \
- $(use_with sqlite) \
- $(use_enable nls) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
-
- mv "${D}"/bin/rpm "${D}"/usr/bin
- rmdir "${D}"/bin
-
- use nls || rm -rf "${D}"/usr/share/man/??
-
- keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
-
- dodoc CHANGES CREDITS GROUPS README* RPM*
- use doc && dohtml -r apidocs/html/*
-
- # Fix perllocal.pod file collision
- use perl && fixlocalpod
-}
-
-pkg_postinst() {
- if [[ -f "${ROOT}"/var/lib/rpm/Packages ]] ; then
- einfo "RPM database found... Rebuilding database (may take a while)..."
- "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
- else
- einfo "No RPM database found... Creating database..."
- "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
- fi
-
- distutils_pkg_postinst
-}
diff --git a/app-arch/rpm/rpm-4.4.7-r2.ebuild b/app-arch/rpm/rpm-4.4.7-r2.ebuild
deleted file mode 100644
index 6620775e066c..000000000000
--- a/app-arch/rpm/rpm-4.4.7-r2.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r2.ebuild,v 1.4 2009/09/06 19:27:42 idl0r Exp $
-
-inherit eutils autotools distutils perl-module flag-o-matic
-
-DESCRIPTION="Red Hat Package Management Utils"
-HOMEPAGE="http://www.rpm.org/"
-SRC_URI="http://wraptastic.org/pub/rpm-4.4.x/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls python perl doc sqlite"
-
-RDEPEND="=sys-libs/db-3.2*
- >=sys-libs/zlib-1.2.3-r1
- >=app-arch/bzip2-1.0.1
- >=dev-libs/popt-1.7
- >=app-crypt/gnupg-1.2
- dev-libs/elfutils
- virtual/libintl
- >=dev-libs/beecrypt-3.1.0-r1
- python? ( >=dev-lang/python-2.2 )
- perl? ( >=dev-lang/perl-5.8.8 )
- nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3.3.5 )
- net-misc/neon"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
- epatch "${FILESDIR}"/rpm-4.4.7-stupidness.patch
- epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
- epatch "${FILESDIR}"/rpm-4.4.6-buffer-overflow.patch
- epatch "${FILESDIR}"/${P}-qa-implicit-function-to-pointer.patch
- epatch "${FILESDIR}"/${P}-qa-fix-undefined.patch
-
- # rpm uses AM_GNU_GETTEXT() but fails to actually
- # include any of the required gettext files
- cp /usr/share/gettext/config.rpath . || die
-
- # the following are additional libraries that might be packaged with
- # the rpm sources. grep for "test -d" in configure.ac
- cp file/src/{file,patchlevel}.h tools/
- rm -rf beecrypt elfutils neon popt sqlite zlib intl file
-
- sed -i -e "s:intl ::" Makefile.am
- sed -i -e "s:intl/Makefile ::" configure.ac
- AT_NO_RECURSIVE="yes" eautoreconf
- # TODO Get rid of internal copies of lua, db and db3
-}
-
-src_compile() {
- # Until strict aliasing is porperly fixed...
- filter-flags -fstrict-aliasing
- append-flags -fno-strict-aliasing
- python_version
- econf \
- --enable-posixmutexes \
- --without-javaglue \
- --without-selinux \
- $(use_with python python ${PYVER}) \
- $(use_with doc apidocs) \
- $(use_with perl) \
- $(use_with sqlite) \
- $(use_enable nls) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
-
- mv "${D}"/bin/rpm "${D}"/usr/bin
- rmdir "${D}"/bin
-
- use nls || rm -rf "${D}"/usr/share/man/??
-
- keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
-
- dodoc CHANGES CREDITS GROUPS README* RPM*
- use doc && dohtml -r apidocs/html/*
-
- # Fix perllocal.pod file collision
- use perl && fixlocalpod
-}
-
-pkg_postinst() {
- if [[ -f "${ROOT}"/var/lib/rpm/Packages ]] ; then
- einfo "RPM database found... Rebuilding database (may take a while)..."
- "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
- else
- einfo "No RPM database found... Creating database..."
- "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
- fi
-
- distutils_pkg_postinst
-}
diff --git a/app-arch/rpm/rpm-5.0.0.ebuild b/app-arch/rpm/rpm-5.0.0.ebuild
deleted file mode 100644
index 67d38722799c..000000000000
--- a/app-arch/rpm/rpm-5.0.0.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-5.0.0.ebuild,v 1.4 2010/02/08 09:01:27 pva Exp $
-
-inherit eutils multilib distutils python
-
-MY_P=${P/_alpha/a}
-MY_P=${P/_beta/b}
-
-DESCRIPTION="RPM Package Manager"
-HOMEPAGE="http://rpm5.org/"
-SRC_URI="http://rpm5.org/files/rpm/rpm-5.0/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="berkdb bzip2 doc lua magic neon nls pcre perl python selinux sqlite"
-
-# dmalloc? ( dev-libs/dmalloc )
-# efence? ( dev-util/efence )
-# keyutils? ( sys-apps/keyutils )
-# xar? ( app-arch/xar )
-RDEPEND="dev-libs/beecrypt
- dev-libs/popt
- berkdb? ( sys-libs/db )
- bzip2? ( app-arch/bzip2 )
- lua? ( dev-lang/lua )
- neon? ( net-misc/neon )
- pcre? ( dev-libs/libpcre )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- selinux? ( sys-libs/libselinux )
- sqlite? ( dev-db/sqlite )"
-# comes bundled with modified zlib
-# >=sys-libs/zlib-1.2.3-r1
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm -rf file xar #db
- sed -i \
- -e '/^pkgconfigdir/s:=.*:=$(libdir)/pkgconfig:' \
- scripts/Makefile.in || die
-}
-
-src_compile() {
-# $(use_with dmalloc) \
-# $(use_with efence) \
-# $(use_with keyutils) \
-# $(use_with xar) \
- # --with-libelf
- use python && python_version
- econf \
- $(use_with berkdb db) \
- $(use_with bzip2) \
- $(use_with doc apidocs) \
- $(use_with magic file) \
- $(use_with lua) \
- $(use_with neon) \
- $(use_with nls) \
- $(use_with pcre) \
- $(use_with perl) \
- $(use_with python) \
- $(use_with selinux) \
- $(use_with sqlite) \
- $(use berkdb || use sqlite || echo --with-db) \
- --with-path-lib="/usr/$(get_libdir)/rpm" \
- --with-python-lib-dir="/usr/$(get_libdir)/python${PYVER}" \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
- dodoc CHANGES CREDITS NEWS README TODO
-}
-
-pkg_preinst() {
- enewgroup rpm 37
- enewuser rpm 37 /bin/sh /var/lib/rpm rpm
-}
-
-pkg_postinst() {
- chown -R rpm:rpm "${ROOT}"/usr/$(get_libdir)/rpm
- chown -R rpm:rpm "${ROOT}"/var/lib/rpm
- chown rpm:rpm "${ROOT}"/usr/bin/rpm{,2cpio,build,constant}
- if [[ ${ROOT} == "/" ]] ; then
- if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
- einfo "RPM database found... Rebuilding database (may take a while)..."
- "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
- else
- einfo "No RPM database found... Creating database..."
- "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
- fi
- fi
- chown rpm:rpm "${ROOT}"/var/lib/rpm/*
-
- distutils_pkg_postinst
-}
diff --git a/app-arch/rpm/rpm-5.0.3.ebuild b/app-arch/rpm/rpm-5.0.3.ebuild
deleted file mode 100644
index 54dec349bfcf..000000000000
--- a/app-arch/rpm/rpm-5.0.3.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-5.0.3.ebuild,v 1.5 2010/02/08 09:01:27 pva Exp $
-
-inherit eutils multilib distutils python
-
-MY_P=${P/_alpha/a}
-MY_P=${P/_beta/b}
-
-DESCRIPTION="RPM Package Manager"
-HOMEPAGE="http://rpm5.org/"
-SRC_URI="http://rpm5.org/files/rpm/rpm-5.0/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="berkdb bzip2 doc lua magic neon nls pcre perl python selinux sqlite"
-
-# dmalloc? ( dev-libs/dmalloc )
-# efence? ( dev-util/efence )
-# keyutils? ( sys-apps/keyutils )
-# xar? ( app-arch/xar )
-RDEPEND="dev-libs/beecrypt
- dev-libs/popt
- berkdb? ( sys-libs/db )
- bzip2? ( app-arch/bzip2 )
- lua? ( dev-lang/lua )
- neon? ( net-misc/neon )
- pcre? ( dev-libs/libpcre )
- perl? ( dev-lang/perl )
- python? ( dev-lang/python )
- selinux? ( sys-libs/libselinux )
- sqlite? ( dev-db/sqlite )"
-# comes bundled with modified zlib
-# >=sys-libs/zlib-1.2.3-r1
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm -rf file xar #db
- sed -i \
- -e '/^pkgconfigdir/s:=.*:=$(libdir)/pkgconfig:' \
- scripts/Makefile.in || die
-}
-
-src_compile() {
-# $(use_with dmalloc) \
-# $(use_with efence) \
-# $(use_with keyutils) \
-# $(use_with xar) \
- # --with-libelf
- use python && python_version
- econf \
- $(use_with berkdb db) \
- $(use_with bzip2) \
- $(use_with doc apidocs) \
- $(use_with magic file) \
- $(use_with lua) \
- $(use_with neon) \
- $(use_with nls) \
- $(use_with pcre) \
- $(use_with perl) \
- $(use_with python) \
- $(use_with selinux) \
- $(use_with sqlite) \
- $(use berkdb || use sqlite || echo --with-db) \
- --with-path-lib="/usr/$(get_libdir)/rpm" \
- --with-python-lib-dir="/usr/$(get_libdir)/python${PYVER}" \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
- dodoc CHANGES CREDITS NEWS README TODO
-}
-
-pkg_preinst() {
- enewgroup rpm 37
- enewuser rpm 37 /bin/sh /var/lib/rpm rpm
-}
-
-pkg_postinst() {
- chown -R rpm:rpm "${ROOT}"/usr/$(get_libdir)/rpm
- chown -R rpm:rpm "${ROOT}"/var/lib/rpm
- chown rpm:rpm "${ROOT}"/usr/bin/rpm{,2cpio,build,constant}
- if [[ ${ROOT} == "/" ]] ; then
- if [[ -f ${ROOT}/var/lib/rpm/Packages ]] ; then
- einfo "RPM database found... Rebuilding database (may take a while)..."
- "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
- else
- einfo "No RPM database found... Creating database..."
- "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
- fi
- fi
- chown rpm:rpm "${ROOT}"/var/lib/rpm/*
-
- distutils_pkg_postinst
-}