summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-19 16:23:22 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-19 16:23:22 +0000
commit1f80d4e198839f8c77c95a693614f6e70876fe50 (patch)
tree074294398ce1d5ce38be96cc47e526e6e8f44b22 /app-antivirus
parentstable sparc, bug 265780 (diff)
downloadgentoo-2-1f80d4e198839f8c77c95a693614f6e70876fe50.tar.gz
gentoo-2-1f80d4e198839f8c77c95a693614f6e70876fe50.tar.bz2
gentoo-2-1f80d4e198839f8c77c95a693614f6e70876fe50.zip
Bumped klamav to 0.46. Thanks to Richard Cox - fixes bug 264887.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/klamav/ChangeLog8
-rw-r--r--app-antivirus/klamav/klamav-0.46.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/app-antivirus/klamav/ChangeLog b/app-antivirus/klamav/ChangeLog
index 5e67e2e3defb..d46a51a5e1bc 100644
--- a/app-antivirus/klamav/ChangeLog
+++ b/app-antivirus/klamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-antivirus/klamav
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/ChangeLog,v 1.54 2009/02/25 12:50:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/ChangeLog,v 1.55 2009/04/19 16:23:22 jmbsvicetto Exp $
+
+*klamav-0.46 (19 Apr 2009)
+
+ 19 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +klamav-0.46.ebuild:
+ Bumped klamav to 0.46. Thanks to Richard Cox - fixes bug 264887.
25 Feb 2009; Joseph Jezak <josejx@gentoo.org> klamav-0.44.ebuild:
Marked ppc stable for bug #245552.
diff --git a/app-antivirus/klamav/klamav-0.46.ebuild b/app-antivirus/klamav/klamav-0.46.ebuild
new file mode 100644
index 000000000000..e9af690d4348
--- /dev/null
+++ b/app-antivirus/klamav/klamav-0.46.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.46.ebuild,v 1.1 2009/04/19 16:23:22 jmbsvicetto Exp $
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+MY_P="${P}-source"
+S="${WORKDIR}/${MY_P}/${P}"
+
+DESCRIPTION="KlamAV is a KDE frontend for the ClamAV antivirus."
+HOMEPAGE="http://klamav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/klamav-0.43-desktop-entry.diff"
+ )
+src_unpack(){
+ kde_src_unpack
+
+ # Assure a future version won't try to build this.
+ rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"
+
+ rm -f "${S}"/configure
+}
+
+src_compile(){
+ # Disable updates from the GUI. We have package managers for that. cf. bug 171414
+ myconf="--with-disableupdates"
+ kde_src_compile
+}
+
+pkg_postinst(){
+ kde_pkg_postinst
+
+ elog "The on-access scanning functionality is provided by"
+ elog "the Dazuko kernel module. To use it, install sys-fs/dazuko."
+}