summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/klamav/klamav-0.46.ebuild')
-rw-r--r--app-antivirus/klamav/klamav-0.46.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-antivirus/klamav/klamav-0.46.ebuild b/app-antivirus/klamav/klamav-0.46.ebuild
new file mode 100644
index 000000000000..e9af690d4348
--- /dev/null
+++ b/app-antivirus/klamav/klamav-0.46.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.46.ebuild,v 1.1 2009/04/19 16:23:22 jmbsvicetto Exp $
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+MY_P="${P}-source"
+S="${WORKDIR}/${MY_P}/${P}"
+
+DESCRIPTION="KlamAV is a KDE frontend for the ClamAV antivirus."
+HOMEPAGE="http://klamav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/klamav-0.43-desktop-entry.diff"
+ )
+src_unpack(){
+ kde_src_unpack
+
+ # Assure a future version won't try to build this.
+ rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"
+
+ rm -f "${S}"/configure
+}
+
+src_compile(){
+ # Disable updates from the GUI. We have package managers for that. cf. bug 171414
+ myconf="--with-disableupdates"
+ kde_src_compile
+}
+
+pkg_postinst(){
+ kde_pkg_postinst
+
+ elog "The on-access scanning functionality is provided by"
+ elog "the Dazuko kernel module. To use it, install sys-fs/dazuko."
+}