summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-03-03 12:21:30 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-03-03 12:21:30 +0000
commit12c72fdcdfa1d037d1f2fcc335bbf7fbcef097d4 (patch)
tree1b72f5841849d3c4a741a2c269c9ccd7df78394f /app-admin
parentAdd PYTHON_USEDEP to dependencies (diff)
downloadgentoo-2-12c72fdcdfa1d037d1f2fcc335bbf7fbcef097d4.tar.gz
gentoo-2-12c72fdcdfa1d037d1f2fcc335bbf7fbcef097d4.tar.bz2
gentoo-2-12c72fdcdfa1d037d1f2fcc335bbf7fbcef097d4.zip
Version bump, wrt bug #503298. Sync live ebuild, remove obsolete workaround for tests, add dependency on dev-python/keyczar to support accelerated mode
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ChangeLog9
-rw-r--r--app-admin/ansible/ansible-1.5.0.ebuild57
-rw-r--r--app-admin/ansible/ansible-9999.ebuild9
3 files changed, 67 insertions, 8 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index 797b769063e6..3d90fd143a74 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.34 2014/03/03 12:18:57 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.35 2014/03/03 12:21:30 pinkbyte Exp $
+
+*ansible-1.5.0 (03 Mar 2014)
+
+ 03 Mar 2014; Sergey Popov <pinkbyte@gentoo.org> +ansible-1.5.0.ebuild,
+ ansible-9999.ebuild:
+ Version bump, wrt bug #503298. Sync live ebuild, remove obsolete workaround
+ for tests, add dependency on dev-python/keyczar to support accelerated mode
03 Mar 2014; Sergey Popov <pinkbyte@gentoo.org> ansible-1.4.5.ebuild,
ansible-9999.ebuild:
diff --git a/app-admin/ansible/ansible-1.5.0.ebuild b/app-admin/ansible/ansible-1.5.0.ebuild
new file mode 100644
index 000000000000..93091fb62c0d
--- /dev/null
+++ b/app-admin/ansible/ansible-1.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.5.0.ebuild,v 1.1 2014/03/03 12:21:30 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/keyczar[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+
+DOC_CONTENTS="You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
+You have to create ansible hosts file!\n
+More info on http://docs.ansible.com/intro_getting_started.html"
+
+python_test() {
+ make tests || die "tests failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ # Hint: do not install example config files into /etc
+ # let this choice to user
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index c11e768bf57f..4945d5a73ef2 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.15 2014/03/03 12:18:57 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.16 2014/03/03 12:21:30 pinkbyte Exp $
EAPI="5"
@@ -26,6 +26,7 @@ DEPEND="test? (
)"
RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/keyczar[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
net-misc/sshpass
@@ -37,12 +38,6 @@ Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
You have to create ansible hosts file!\n
More info on http://docs.ansible.com/intro_getting_started.html"
-python_prepare_all() {
- distutils-r1_python_prepare_all
- # Skip tests which need ssh access
- sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
-}
-
python_test() {
make tests || die "tests failed"
}