summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-9999.ebuild')
-rw-r--r--app-admin/ansible/ansible-9999.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index c11e768bf57f..4945d5a73ef2 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.15 2014/03/03 12:18:57 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-9999.ebuild,v 1.16 2014/03/03 12:21:30 pinkbyte Exp $
EAPI="5"
@@ -26,6 +26,7 @@ DEPEND="test? (
)"
RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/keyczar[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
net-misc/sshpass
@@ -37,12 +38,6 @@ Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
You have to create ansible hosts file!\n
More info on http://docs.ansible.com/intro_getting_started.html"
-python_prepare_all() {
- distutils-r1_python_prepare_all
- # Skip tests which need ssh access
- sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
-}
-
python_test() {
make tests || die "tests failed"
}