summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-11 21:12:26 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-11 21:12:26 +0000
commitacb730dd39e6ce7982c64a69486fd572854ca3eb (patch)
tree06b0346088fbfeec8ff3bd124c2bd40c2c7da11e /app-admin/ide-smart/ide-smart-1.4.ebuild
parentunmasked koffice 1.2_pre (again :o) (diff)
downloadgentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.tar.gz
gentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.tar.bz2
gentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.zip
my first cvs commit - please advice if something went terribly wrong. ide-smart ebuild: a tool to read SMART information from your hdd. tells you when your disc is about to go down...
Diffstat (limited to 'app-admin/ide-smart/ide-smart-1.4.ebuild')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4.ebuild b/app-admin/ide-smart/ide-smart-1.4.ebuild
new file mode 100644
index 000000000000..ff8849f7a7b4
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Author: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool to read SMART (or S.M.A.R.T) information from harddiscs."
+
+SRC_URI="http://lightside.eresmas.com/${P}.tar.gz"
+HOMEPAGE="http://lightside.eresmas.com/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ rm ide-smart ide-smart.o
+ sed -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ -e "s:^#CC.*:CC = gcc:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ dobin ide-smart
+ doman ide-smart.8
+ dodoc README COPYING
+
+}