summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-11 21:12:26 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-11 21:12:26 +0000
commitacb730dd39e6ce7982c64a69486fd572854ca3eb (patch)
tree06b0346088fbfeec8ff3bd124c2bd40c2c7da11e /app-admin
parentunmasked koffice 1.2_pre (again :o) (diff)
downloadgentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.tar.gz
gentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.tar.bz2
gentoo-2-acb730dd39e6ce7982c64a69486fd572854ca3eb.zip
my first cvs commit - please advice if something went terribly wrong. ide-smart ebuild: a tool to read SMART information from your hdd. tells you when your disc is about to go down...
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ide-smart/ChangeLog9
-rw-r--r--app-admin/ide-smart/files/digest-ide-smart-1.41
-rw-r--r--app-admin/ide-smart/ide-smart-1.4.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/ide-smart/ChangeLog b/app-admin/ide-smart/ChangeLog
new file mode 100644
index 000000000000..a41321016ae7
--- /dev/null
+++ b/app-admin/ide-smart/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/ide-smart
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*ide-smart-1.4 (17 Mar 2002)
+
+ 17 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog :
+
+ initial release ;-)
diff --git a/app-admin/ide-smart/files/digest-ide-smart-1.4 b/app-admin/ide-smart/files/digest-ide-smart-1.4
new file mode 100644
index 000000000000..5756241608ad
--- /dev/null
+++ b/app-admin/ide-smart/files/digest-ide-smart-1.4
@@ -0,0 +1 @@
+MD5 268fb2a29224b4554073edaad50b9cb0 ide-smart-1.4.tar.gz 19739
diff --git a/app-admin/ide-smart/ide-smart-1.4.ebuild b/app-admin/ide-smart/ide-smart-1.4.ebuild
new file mode 100644
index 000000000000..ff8849f7a7b4
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Author: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool to read SMART (or S.M.A.R.T) information from harddiscs."
+
+SRC_URI="http://lightside.eresmas.com/${P}.tar.gz"
+HOMEPAGE="http://lightside.eresmas.com/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ rm ide-smart ide-smart.o
+ sed -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ -e "s:^#CC.*:CC = gcc:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ dobin ide-smart
+ doman ide-smart.8
+ dodoc README COPYING
+
+}