summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-20 02:24:37 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-20 02:24:37 +0000
commitee1e6a4870ddfdda68ca63f3b9f3231a5f320da7 (patch)
tree221c90b5ae3d38eb85c3d67b48e9541353666d32
parentAdded ~sparc keyword so cdrdao can emerge again. (diff)
downloadgentoo-2-ee1e6a4870ddfdda68ca63f3b9f3231a5f320da7.tar.gz
gentoo-2-ee1e6a4870ddfdda68ca63f3b9f3231a5f320da7.tar.bz2
gentoo-2-ee1e6a4870ddfdda68ca63f3b9f3231a5f320da7.zip
NEVER use exit in an ebuild
-rw-r--r--app-portage/portagemaster/portagemaster-0.2.0.ebuild19
-rw-r--r--app-text/ggv/ggv-1.1.94.ebuild5
-rw-r--r--dev-db/postgresql/postgresql-7.3.2.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.3.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.4-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-7.3.4.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.ebuild14
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild50
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild7
-rw-r--r--dev-lisp/cl-asdf/cl-asdf-1.78.ebuild7
10 files changed, 58 insertions, 102 deletions
diff --git a/app-portage/portagemaster/portagemaster-0.2.0.ebuild b/app-portage/portagemaster/portagemaster-0.2.0.ebuild
index 3c7b2dbb43bc..722f8013abd4 100644
--- a/app-portage/portagemaster/portagemaster-0.2.0.ebuild
+++ b/app-portage/portagemaster/portagemaster-0.2.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portagemaster/portagemaster-0.2.0.ebuild,v 1.2 2003/09/07 03:12:20 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portagemaster/portagemaster-0.2.0.ebuild,v 1.3 2003/11/20 02:19:52 vapier Exp $
DESCRIPTION="A java portage browser and installer"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
HOMEPAGE="http://portagemaster.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 -ppc sparc"
IUSE="jikes"
@@ -24,14 +24,10 @@ pkg_setup() {
if [ -z "$foo" ] ; then
eerror "You have to set the 1.4.1 JDK as your system default to compile this package."
einfo "Use java-config --set-system-vm=sun-jdk-1.4.1 (or more recent) to set it."
- exit 1
+ die
fi
}
-src_unpack() {
- unpack ${A}
-}
-
src_compile() {
if [ -z "`use jikes`" ] ; then
einfo "Configuring build for Jikes"
@@ -39,10 +35,9 @@ src_compile() {
sed 's!<property name="build.compiler" value="jikes"/>!<property name="build.compiler" value="modern"/>!' < build.xml.orig > build.xml
fi
ant
- cp src/portagemaster src/portagemaster.orig
- sed -e s:/usr/share/portagemaster/portagemaster.jar:/usr/share/portagemaster/lib/portagemaster-${PV}.jar: \
- < src/portagemaster.orig \
- > src/portagemaster || die
+ sed -i \
+ -e s:/usr/share/portagemaster/portagemaster.jar:/usr/share/portagemaster/lib/portagemaster-${PV}.jar: \
+ src/portagemaster || die
}
src_install() {
diff --git a/app-text/ggv/ggv-1.1.94.ebuild b/app-text/ggv/ggv-1.1.94.ebuild
index 5535e5bcfecc..83518b66a08d 100644
--- a/app-text/ggv/ggv-1.1.94.ebuild
+++ b/app-text/ggv/ggv-1.1.94.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.1.94.ebuild,v 1.12 2003/09/07 22:32:10 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.1.94.ebuild,v 1.13 2003/11/20 02:20:13 vapier Exp $
IUSE="nls bonobo"
@@ -59,8 +59,7 @@ pkg_postinst() {
SOURCE=xml::/etc/gconf/gconf.xml.defaults
GCONF_CONFIG_SOURCE=$SOURCE \
gconftool-1 --makefile-install-rule \
- /etc/gconf/schemas/${PN}.schemas \
- # 2>/dev/null >/dev/null || exit 1
+ /etc/gconf/schemas/${PN}.schemas
assert "gconftool-1 execution failed"
}
diff --git a/dev-db/postgresql/postgresql-7.3.2.ebuild b/dev-db/postgresql/postgresql-7.3.2.ebuild
index f4f4dfcbed09..90edc3d0cf1f 100644
--- a/dev-db/postgresql/postgresql-7.3.2.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.10 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.11 2003/11/20 02:23:20 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,7 +47,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -62,6 +62,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -165,7 +167,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.3.ebuild b/dev-db/postgresql/postgresql-7.3.3.ebuild
index cb170394c1ef..4b8f7fc28247 100644
--- a/dev-db/postgresql/postgresql-7.3.3.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.3.ebuild,v 1.5 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.3.ebuild,v 1.6 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,7 +47,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -62,6 +62,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -165,7 +167,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
index 435ba25382ed..05ada6499454 100644
--- a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.2 2003/11/17 19:19:16 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.3 2003/11/20 02:23:21 vapier Exp $
-DESCRIPTION="sophisticated Object-Relational DBMS."
+inherit flag-o-matic
+DESCRIPTION="sophisticated Object-Relational DBMS"
+HOMEPAGE="http://www.postgresql.org/ http://gppl.terminal.ru/index.eng.html"
SRC_URI="mirror://postgresql/v${PV}/${P}.tar.gz
pg-hier? ( http://gppl.terminal.ru/hier-Pg7.3-0.3.tar.gz )"
-HOMEPAGE="http://www.postgresql.org/
-http://gppl.terminal.ru/index.eng.html"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64 hppa"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib pg-hier"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -50,7 +48,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -76,6 +74,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -182,7 +182,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.4.ebuild b/dev-db/postgresql/postgresql-7.3.4.ebuild
index 0d09f3b6ae47..7b04722a8929 100644
--- a/dev-db/postgresql/postgresql-7.3.4.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4.ebuild,v 1.7 2003/10/07 20:54:00 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4.ebuild,v 1.8 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
+HOMEPAGE="http://www.postgresql.org/"
SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz
ftp://ftp8.us.postgresql.org/pub/pgsql/v${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.postgresql.org/"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64 hppa"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -48,7 +48,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -63,6 +63,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -166,7 +168,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.ebuild b/dev-db/postgresql/postgresql-7.3.ebuild
index a01e28998420..bd26c751ac83 100644
--- a/dev-db/postgresql/postgresql-7.3.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.ebuild,v 1.11 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.ebuild,v 1.12 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE="ssl nls java python tcltk perl"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,12 +47,14 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
src_compile() {
+ filter-flags -ffast-math
+
local myconf
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
@@ -154,7 +156,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild
index 615e336023bb..84b505a1c28f 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild,v 1.3 2003/09/06 22:35:54 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.73b.ebuild,v 1.4 2003/11/20 02:24:37 vapier Exp $
DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~sparc"
-IUSE=""
-DEPEND=""
-S=${WORKDIR}/${P}
+DEPEND=""
src_install() {
insinto /usr/share/common-lisp/source/asdf
@@ -27,46 +26,3 @@ pkg_postinst() {
/usr/sbin/clc-reregister-all-impl
fi
}
-
-
-### from debian cl-clan.postinst:
-
-# #!/bin/sh
-
-# set -e
-
-# pkg=cclan
-
-# # summary of how this script can be called:
-# # * <postinst> `configure' <most-recently-configured-version>
-# # * <old-postinst> `abort-upgrade' <new version>
-# # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# # <new-version>
-# # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# # <failed-install-package> <version> `removing'
-# # <conflicting-package> <version>
-# # for details, see http://www.debian.org/doc/debian-policy/ or
-# # the debian-policy package
-# #
-# # quoting from the policy:
-# # Any necessary prompting should almost always be confined to the
-# # post-installation script, and should be protected with a conditional
-# # so that unnecessary prompting doesn't happen if a package's
-# # installation fails and the `postinst' is called with `abort-upgrade',
-# # `abort-remove' or `abort-deconfigure'.
-
-# case "$1" in
-# configure)
-# /usr/sbin/register-common-lisp-source $pkg
-# ;;
-# abort-upgrade|abort-remove|abort-deconfigure)
-# ;;
-# *)
-# echo "postinst called with unknown argument \`$1'" >&2
-# exit 1
-# ;;
-# esac
-
-# #DEBHELPER#
-
-# exit 0
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
index 40ecde85285b..ce0674d08842 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.4 2003/10/08 19:11:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.77.2.ebuild,v 1.5 2003/11/20 02:24:37 vapier Exp $
DEB_PV=1
@@ -8,13 +8,12 @@ DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~sparc"
-IUSE=""
-DEPEND=""
-S=${WORKDIR}/${P}
+DEPEND=""
src_unpack() {
unpack ${A}
diff --git a/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild b/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild
index 533029e227b6..ed443b80c193 100644
--- a/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild
+++ b/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild,v 1.1 2003/10/17 00:08:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-asdf/cl-asdf-1.78.ebuild,v 1.2 2003/11/20 02:24:37 vapier Exp $
DEB_PV=1
@@ -10,13 +10,12 @@ DESCRIPTION="Another System Definition Facility for Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/devel/cl-asdf.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ~sparc"
-IUSE=""
-DEPEND=""
-S=${WORKDIR}/${P}
+DEPEND=""
src_unpack() {
unpack ${A}