summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-7.3.2.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-7.3.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-db/postgresql/postgresql-7.3.2.ebuild b/dev-db/postgresql/postgresql-7.3.2.ebuild
index f4f4dfcbed09..90edc3d0cf1f 100644
--- a/dev-db/postgresql/postgresql-7.3.2.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.10 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.11 2003/11/20 02:23:20 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,7 +47,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -62,6 +62,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -165,7 +167,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."