summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-29 14:16:35 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-29 14:16:35 +0000
commita3267a44f7b90b2e9f8b88527ef213a0de69386d (patch)
treec5b96b696efe489384771fa33aec6d2cce9f77b8
parentForgot to commit ebuild using updated patch (#463656 by Maciej Piechotka) (diff)
downloadgentoo-2-a3267a44f7b90b2e9f8b88527ef213a0de69386d.tar.gz
gentoo-2-a3267a44f7b90b2e9f8b88527ef213a0de69386d.tar.bz2
gentoo-2-a3267a44f7b90b2e9f8b88527ef213a0de69386d.zip
Use vala.eclass. Drop old.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
-rw-r--r--sys-apps/systemd-ui/ChangeLog6
-rw-r--r--sys-apps/systemd-ui/systemd-ui-1.ebuild47
-rw-r--r--sys-apps/systemd-ui/systemd-ui-2.ebuild13
-rw-r--r--sys-apps/systemd-ui/systemd-ui-9999.ebuild15
4 files changed, 22 insertions, 59 deletions
diff --git a/sys-apps/systemd-ui/ChangeLog b/sys-apps/systemd-ui/ChangeLog
index c6a74202bf5b..7924d209db93 100644
--- a/sys-apps/systemd-ui/ChangeLog
+++ b/sys-apps/systemd-ui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd-ui
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.3 2013/03/25 19:25:25 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.4 2013/03/29 14:16:34 mgorny Exp $
+
+ 29 Mar 2013; Michał Górny <mgorny@gentoo.org> -systemd-ui-1.ebuild,
+ systemd-ui-2.ebuild, systemd-ui-9999.ebuild:
+ Use vala.eclass. Drop old.
*systemd-ui-2 (25 Mar 2013)
diff --git a/sys-apps/systemd-ui/systemd-ui-1.ebuild b/sys-apps/systemd-ui/systemd-ui-1.ebuild
deleted file mode 100644
index 0ede5f9a5024..000000000000
--- a/sys-apps/systemd-ui/systemd-ui-1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-1.ebuild,v 1.1 2012/03/31 11:52:03 mgorny Exp $
-
-EAPI=4
-
-inherit autotools-utils
-
-DESCRIPTION="System and service manager for Linux"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
-SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-VALASLOT="0.14"
-
-RDEPEND="!sys-apps/systemd[gtk]
- >=dev-libs/glib-2.26
- dev-libs/libgee:0
- sys-apps/dbus
- x11-libs/gtk+:2
- >=x11-libs/libnotify-0.7"
-
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- dev-lang/vala:${VALASLOT}"
-
-# Due to vala being broken.
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- # Force the rebuild of .vala sources
- touch src/*.vala || die
-
- # Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- export VALAC="$(type -p valac-${VALASLOT})"
- autotools-utils_src_configure
-}
diff --git a/sys-apps/systemd-ui/systemd-ui-2.ebuild b/sys-apps/systemd-ui/systemd-ui-2.ebuild
index 567273edeac3..f34c9d91d8f1 100644
--- a/sys-apps/systemd-ui/systemd-ui-2.ebuild
+++ b/sys-apps/systemd-ui/systemd-ui-2.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.1 2013/03/25 19:25:25 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.2 2013/03/29 14:16:34 mgorny Exp $
EAPI=4
-inherit autotools-utils
+VALA_MIN_API_VERSION=0.14
+VALA_MAX_API_VERSION=0.20
+
+inherit autotools-utils vala
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -26,7 +29,7 @@ RDEPEND="!sys-apps/systemd[gtk]
DEPEND="${RDEPEND}
app-arch/xz-utils
- dev-lang/vala:${VALASLOT}"
+ $(vala_depend)"
# Due to vala being broken.
AUTOTOOLS_IN_SOURCE_BUILD=1
@@ -36,12 +39,12 @@ src_prepare() {
touch src/*.vala || die
# Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+ sed -i -e 's:/lib/systemd:/usr&:g' src/*.vala || die
autotools-utils_src_prepare
}
src_configure() {
- export VALAC="$(type -p valac-${VALASLOT})"
+ vala_src_prepare
autotools-utils_src_configure
}
diff --git a/sys-apps/systemd-ui/systemd-ui-9999.ebuild b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
index a5c65811e676..d5702e69ca6a 100644
--- a/sys-apps/systemd-ui/systemd-ui-9999.ebuild
+++ b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-9999.ebuild,v 1.1 2012/12/15 13:06:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-9999.ebuild,v 1.2 2013/03/29 14:16:34 mgorny Exp $
EAPI=4
@@ -12,7 +12,10 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/${PN}
inherit git-2
#endif
-inherit autotools-utils
+VALA_MIN_API_VERSION=0.14
+VALA_MAX_API_VERSION=0.20
+
+inherit autotools-utils vala
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -34,7 +37,7 @@ RDEPEND="!sys-apps/systemd[gtk]
DEPEND="${RDEPEND}
app-arch/xz-utils
- dev-lang/vala:${VALASLOT}"
+ $(vala_depend)"
#if LIVE
SRC_URI=
@@ -52,12 +55,12 @@ src_prepare() {
touch src/*.vala || die
# Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+ sed -i -e 's:/lib/systemd:/usr&:g' src/*.vala || die
autotools-utils_src_prepare
}
src_configure() {
- export VALAC="$(type -p valac-${VALASLOT})"
+ vala_src_prepare
autotools-utils_src_configure
}