summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-ui/systemd-ui-2.ebuild')
-rw-r--r--sys-apps/systemd-ui/systemd-ui-2.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-apps/systemd-ui/systemd-ui-2.ebuild b/sys-apps/systemd-ui/systemd-ui-2.ebuild
index 567273edeac3..f34c9d91d8f1 100644
--- a/sys-apps/systemd-ui/systemd-ui-2.ebuild
+++ b/sys-apps/systemd-ui/systemd-ui-2.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.1 2013/03/25 19:25:25 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-2.ebuild,v 1.2 2013/03/29 14:16:34 mgorny Exp $
EAPI=4
-inherit autotools-utils
+VALA_MIN_API_VERSION=0.14
+VALA_MAX_API_VERSION=0.20
+
+inherit autotools-utils vala
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -26,7 +29,7 @@ RDEPEND="!sys-apps/systemd[gtk]
DEPEND="${RDEPEND}
app-arch/xz-utils
- dev-lang/vala:${VALASLOT}"
+ $(vala_depend)"
# Due to vala being broken.
AUTOTOOLS_IN_SOURCE_BUILD=1
@@ -36,12 +39,12 @@ src_prepare() {
touch src/*.vala || die
# Fix hardcoded path in .vala.
- sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+ sed -i -e 's:/lib/systemd:/usr&:g' src/*.vala || die
autotools-utils_src_prepare
}
src_configure() {
- export VALAC="$(type -p valac-${VALASLOT})"
+ vala_src_prepare
autotools-utils_src_configure
}