summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-01 13:46:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-01 13:46:49 +0000
commit8f83e33ca5c7043ada7af8067806dce25db35cbf (patch)
tree926bd7ef8dcb83eadd6d95a404499abd780156c5
parenteautoconf was enough, thanks to Tiziano Müller. (diff)
downloadgentoo-2-8f83e33ca5c7043ada7af8067806dce25db35cbf.tar.gz
gentoo-2-8f83e33ca5c7043ada7af8067806dce25db35cbf.tar.bz2
gentoo-2-8f83e33ca5c7043ada7af8067806dce25db35cbf.zip
added 7.18.1 which fixes bugs #210295, #204130, #209421, #206566 and part of bug #207653. 7.17.1 has fixes from bug #206566. Thanks to Daniel Stenberg, Micha Kiedrowicz, Olivier Dole, and Fabrice Bacchella. Cleaned out some old versions too
(Portage version: 2.1.4.4)
-rw-r--r--net-misc/curl/ChangeLog11
-rw-r--r--net-misc/curl/curl-7.16.4.ebuild6
-rw-r--r--net-misc/curl/curl-7.17.1.ebuild21
-rw-r--r--net-misc/curl/curl-7.17.1_pre20071013.ebuild113
-rw-r--r--net-misc/curl/curl-7.18.1.ebuild (renamed from net-misc/curl/curl-7.17.0.ebuild)42
5 files changed, 59 insertions, 134 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 487700d77631..c2d1c037b7d6 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.114 2008/02/10 09:12:28 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.115 2008/04/01 13:46:49 dragonheart Exp $
+
+*curl-7.18.1 (01 Apr 2008)
+
+ 01 Apr 2008; Daniel Black <dragonheart@gentoo.org> -curl-7.17.0.ebuild,
+ -curl-7.17.1_pre20071013.ebuild, curl-7.17.1.ebuild, +curl-7.18.1.ebuild:
+ added 7.18.1 which fixes bugs #210295, #204130, #209421, #206566 and part of
+ bug #207653. 7.17.1 has fixes from bug #206566. Thanks to Daniel Stenberg,
+ Micha Kiedrowicz, Olivier Dole, and Fabrice Bacchella. Cleaned out some old
+ versions too
10 Feb 2008; Tobias Scherbaum <dertobi123@gentoo.org> curl-7.17.1.ebuild:
ppc stable, bug #202891
diff --git a/net-misc/curl/curl-7.16.4.ebuild b/net-misc/curl/curl-7.16.4.ebuild
index ba36507b9879..c1198a466059 100644
--- a/net-misc/curl/curl-7.16.4.ebuild
+++ b/net-misc/curl/curl-7.16.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.4.ebuild,v 1.11 2007/08/25 14:34:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.4.ebuild,v 1.12 2008/04/01 13:46:49 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -14,7 +14,7 @@ SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
LICENSE="MIT X11"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
RDEPEND="gnutls? ( net-libs/gnutls )
diff --git a/net-misc/curl/curl-7.17.1.ebuild b/net-misc/curl/curl-7.17.1.ebuild
index 257d07738bbd..697e7391cc24 100644
--- a/net-misc/curl/curl-7.17.1.ebuild
+++ b/net-misc/curl/curl-7.17.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1.ebuild,v 1.6 2008/02/10 09:12:28 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1.ebuild,v 1.7 2008/04/01 13:46:49 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -51,8 +51,9 @@ src_unpack() {
src_compile() {
myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
$(use_with idn libidn)
- $(use_enable kerberos gssapi)
+ $(use_with kerberos gssapi)
$(use_enable ipv6)
--enable-http
--enable-ftp
@@ -71,6 +72,10 @@ src_compile() {
--without-spnego"
# $(use_with libssh2)
+ if use ldap && use kerberos; then
+ die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1'
+ fi
+
if use ipv6 && use ares; then
elog "c-ares support disabled because it is incompatible with ipv6."
myconf="${myconf} --disable-ares"
@@ -92,6 +97,18 @@ src_compile() {
emake || die "install failed for current version"
}
+src_test() {
+ if use gnutls; then
+ elog 'disabling test 405 ftps as gnutls does differing return codes'
+ elog 'that the test case does not allow for. '
+ elog 'https://bugs.gentoo.org/show_bug.cgi?id=204130 refers'
+ cd "${S}"/tests
+ ./runtests.pl -a -s '!405' || die 'self test failed'
+ else
+ make check || die 'self test failed'
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install || die "installed failed for current version"
rm -rf "${D}"/etc/
diff --git a/net-misc/curl/curl-7.17.1_pre20071013.ebuild b/net-misc/curl/curl-7.17.1_pre20071013.ebuild
deleted file mode 100644
index dbdd41e2ddaa..000000000000
--- a/net-misc/curl/curl-7.17.1_pre20071013.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1_pre20071013.ebuild,v 1.3 2007/10/17 20:32:13 dragonheart Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit libtool eutils
-
-MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-#IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )"
-# libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# net-libs/libssh2 (masked) --with-libssh2
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-# epatch "${FILESDIR}"/${P}-strip-ldflags.patch
- epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
- elibtoolize
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_with idn libidn)
- $(use_enable kerberos gssapi)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
- --without-krb4
- --without-libssh2
- --without-spnego"
-# $(use_with libssh2)
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.17.0.ebuild b/net-misc/curl/curl-7.18.1.ebuild
index db3118c57169..99f55404a70c 100644
--- a/net-misc/curl/curl-7.17.0.ebuild
+++ b/net-misc/curl/curl-7.18.1.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.0.ebuild,v 1.4 2007/10/17 20:32:13 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.18.1.ebuild,v 1.1 2008/04/01 13:46:49 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-inherit libtool eutils
+inherit libtool autotools
#MY_P=${P/_pre/-}
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
LICENSE="MIT X11"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
+#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
+IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
+
+# TODO - change to openssl USE flag in the not too distant future
+# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
@@ -24,10 +27,9 @@ RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
ldap? ( net-nds/openldap )
idn? ( net-dns/libidn )
ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )"
-# libssh2? ( >=net-libs/libssh2-0.16 )"
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
-# net-libs/libssh2 (masked) --with-libssh2
# fbopenssl (not in gentoo) --with-spnego
# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
@@ -42,17 +44,26 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-strip-ldflags.patch
-# epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
+## epatch "${FILESDIR}"/${P}-strip-ldflags.patch
+ epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
+# epatch "${FILESDIR}"/${P}-null-handler-segfault.patch
+# elibtoolize
elibtoolize
+ eaclocal
+ /usr/bin/perl -i.bak -pe 's/\bmv +([^-\s])/mv -f $1/g' aclocal.m4
+ eautoheader
+ cp lib/config.h.in src/config.h.in
+ eautoconf
+ eautomake
}
src_compile() {
myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
+ $(use_enable ldap ldaps)
$(use_with idn libidn)
- $(use_enable kerberos gssapi)
+ $(use_with kerberos gssapi /usr)
+ $(use_with libssh2)
$(use_enable ipv6)
--enable-http
--enable-ftp
@@ -65,9 +76,7 @@ src_compile() {
--enable-largefile
--enable-maintainer-mode
--disable-sspi
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
--without-krb4
- --without-libssh2
--without-spnego"
if use ipv6 && use ares; then
@@ -79,10 +88,13 @@ src_compile() {
if use gnutls; then
myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
elif use nss; then
myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
elif use ssl; then
myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
else
myconf="${myconf} --without-gnutls --without-nss --without-ssl"
fi