summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/curl/curl-7.17.1.ebuild')
-rw-r--r--net-misc/curl/curl-7.17.1.ebuild21
1 files changed, 19 insertions, 2 deletions
diff --git a/net-misc/curl/curl-7.17.1.ebuild b/net-misc/curl/curl-7.17.1.ebuild
index 257d07738bbd..697e7391cc24 100644
--- a/net-misc/curl/curl-7.17.1.ebuild
+++ b/net-misc/curl/curl-7.17.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1.ebuild,v 1.6 2008/02/10 09:12:28 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1.ebuild,v 1.7 2008/04/01 13:46:49 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -51,8 +51,9 @@ src_unpack() {
src_compile() {
myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
$(use_with idn libidn)
- $(use_enable kerberos gssapi)
+ $(use_with kerberos gssapi)
$(use_enable ipv6)
--enable-http
--enable-ftp
@@ -71,6 +72,10 @@ src_compile() {
--without-spnego"
# $(use_with libssh2)
+ if use ldap && use kerberos; then
+ die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1'
+ fi
+
if use ipv6 && use ares; then
elog "c-ares support disabled because it is incompatible with ipv6."
myconf="${myconf} --disable-ares"
@@ -92,6 +97,18 @@ src_compile() {
emake || die "install failed for current version"
}
+src_test() {
+ if use gnutls; then
+ elog 'disabling test 405 ftps as gnutls does differing return codes'
+ elog 'that the test case does not allow for. '
+ elog 'https://bugs.gentoo.org/show_bug.cgi?id=204130 refers'
+ cd "${S}"/tests
+ ./runtests.pl -a -s '!405' || die 'self test failed'
+ else
+ make check || die 'self test failed'
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install || die "installed failed for current version"
rm -rf "${D}"/etc/