summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-11 12:50:08 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-11 12:50:08 +0000
commit7a3a865159d8b63b0ffe2eab80917c5830bcad16 (patch)
tree6870017ed79d78da690fd14017a8799d434e62b7
parentppc stable #302680 (diff)
downloadgentoo-2-7a3a865159d8b63b0ffe2eab80917c5830bcad16.tar.gz
gentoo-2-7a3a865159d8b63b0ffe2eab80917c5830bcad16.tar.bz2
gentoo-2-7a3a865159d8b63b0ffe2eab80917c5830bcad16.zip
Initial import of sci-mathematics/spin.
(Portage version: 2.1.7.17/cvs/Linux i686)
-rw-r--r--sci-mathematics/spin/ChangeLog10
-rw-r--r--sci-mathematics/spin/files/spin-makefile.patch13
-rw-r--r--sci-mathematics/spin/files/spin-xspin.patch26
-rw-r--r--sci-mathematics/spin/metadata.xml9
-rw-r--r--sci-mathematics/spin/spin-5.2.4.ebuild54
5 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
new file mode 100644
index 000000000000..af91d4d9cdda
--- /dev/null
+++ b/sci-mathematics/spin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/spin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.1 2010/04/11 12:50:07 phajdan.jr Exp $
+
+*spin-5.2.4 (11 Apr 2010)
+
+ 11 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> +spin-5.2.4.ebuild,
+ +files/spin-makefile.patch, +files/spin-xspin.patch, +metadata.xml:
+ Initial import.
+
diff --git a/sci-mathematics/spin/files/spin-makefile.patch b/sci-mathematics/spin/files/spin-makefile.patch
new file mode 100644
index 000000000000..83fa9e95e12f
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-makefile.patch
@@ -0,0 +1,13 @@
+--- makefile.orig 2010-04-03 12:13:41.000000000 +0200
++++ makefile 2010-04-03 12:14:21.000000000 +0200
+@@ -10,10 +10,6 @@
+ # Documentation: http://spinroot.com/
+ # Bug-reports: bugs@spinroot.com
+
+-CC=gcc -DNXT # -DNXT enables the X operator in LTL
+-# CC=cc -m32 -DNXT # for 32bit compilation on a 64bit system
+-CFLAGS=-ansi -D_POSIX_SOURCE -Wno-format-security # on some systems add: -I/usr/include
+-
+ # for a more picky compilation:
+ # CFLAGS=-std=c99 -Wstrict-prototypes -pedantic -fno-strength-reduce -fno-builtin -W -Wshadow -Wpointer-arith -Wcast-qual -Winline -Wall -g
+
diff --git a/sci-mathematics/spin/files/spin-xspin.patch b/sci-mathematics/spin/files/spin-xspin.patch
new file mode 100644
index 000000000000..72b6f36acd3b
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-xspin.patch
@@ -0,0 +1,26 @@
+--- xspin523.tcl.orig 2010-04-03 12:26:48.000000000 +0200
++++ xspin523.tcl 2010-04-03 12:27:26.000000000 +0200
+@@ -1,22 +1,4 @@
+-#!/bin/sh
+-# the next line restarts using wish \
+-exec wish c:/cygwin/bin/xspin -- $*
+-
+-# cd ;# enable to cd to home directory by default
+-
+-# on PCs:
+-# adjust the first argument to wish above with the name and
+-# location of this tcl/tk file on your system, if different.
+-#
+-# Cygwin:
+-# if you use cygwin, do not refer to the file as /usr/bin/xspin
+-# /usr/bin is a symbolic link to /bin, which really
+-# lives in c:/cygwin, hence the contortions above
+-#
+-# on Unix/Linux/Solaris systems
+-# replace the first line with something like
+-# #!/usr/bin/wish -f
+-# using the pathname for the wish executable on your system
++#!/usr/bin/wish -f
+
+ #======================================================================#
+ # Tcl/Tk Spin Controller, written by Gerard J. Holzmann, 1995-2009. #
diff --git a/sci-mathematics/spin/metadata.xml b/sci-mathematics/spin/metadata.xml
new file mode 100644
index 000000000000..9ca372f9b46f
--- /dev/null
+++ b/sci-mathematics/spin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>phajdan.jr@gentoo.org</email>
+ <name>Pawel Hajdan jr</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-mathematics/spin/spin-5.2.4.ebuild b/sci-mathematics/spin/spin-5.2.4.ebuild
new file mode 100644
index 000000000000..6835d92186f0
--- /dev/null
+++ b/sci-mathematics/spin/spin-5.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-5.2.4.ebuild,v 1.1 2010/04/11 12:50:07 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems."
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz
+ http://spinroot.com/spin/Src/xspin523.tcl"
+
+LICENSE="|| ( spin-commercial spin-educational )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_unpack() {
+ unpack "${MY_P}.tar.gz"
+ cp "${DISTDIR}/xspin523.tcl" "${S}" || die "cp failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+ epatch "${FILESDIR}/${PN}-xspin.patch"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin spin || die "dobin failed"
+ doman ../Man/spin.1 || die "doman failed"
+ dodoc ../Doc/* || die "dodoc failed"
+ if use tk; then
+ newbin xspin523.tcl xspin || die "newbin failed"
+ make_desktop_entry xspin XSpin
+ fi
+}