summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2010-05-05 02:36:41 +0000
committerPatrick McLean <chutzpah@gentoo.org>2010-05-05 02:36:41 +0000
commit76a0d1ab34bb8d2bf9ce9bce88a14298a6117013 (patch)
treec1b53e4ddcbd0a0036bd1724dea5e4e565ee78d7
parentRemoved masking for tbb-3.0* (diff)
downloadgentoo-2-76a0d1ab34bb8d2bf9ce9bce88a14298a6117013.tar.gz
gentoo-2-76a0d1ab34bb8d2bf9ce9bce88a14298a6117013.tar.bz2
gentoo-2-76a0d1ab34bb8d2bf9ce9bce88a14298a6117013.zip
Add udev USE flag to install rules file to make devicekit use ntfs3g instead of the kernel driver for mounting NTFS partitions (bug #304765).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/files/99-ntfs3g.rules1
-rw-r--r--sys-fs/ntfs3g/metadata.xml2
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild9
4 files changed, 16 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 175b1caa480e..f2989dd6c0b6 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.95 2010/04/05 20:36:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.96 2010/05/05 02:36:40 chutzpah Exp $
+
+ 05 May 2010; Patrick McLean <chutzpah@gentoo.org> +files/99-ntfs3g.rules,
+ ntfs3g-2010.3.6.ebuild, metadata.xml:
+ Add udev USE flag to install rules file to make devicekit use ntfs3g
+ instead of the kernel driver for mounting NTFS partitions (bug #304765).
05 Apr 2010; Markus Meier <maekke@gentoo.org> ntfs3g-2010.1.16.ebuild:
x86 stable, bug #308705
diff --git a/sys-fs/ntfs3g/files/99-ntfs3g.rules b/sys-fs/ntfs3g/files/99-ntfs3g.rules
new file mode 100644
index 000000000000..52dca4064766
--- /dev/null
+++ b/sys-fs/ntfs3g/files/99-ntfs3g.rules
@@ -0,0 +1 @@
+ENV{ID_FS_TYPE}=="ntfs", ENV{ID_FS_TYPE}="ntfs-3g"
diff --git a/sys-fs/ntfs3g/metadata.xml b/sys-fs/ntfs3g/metadata.xml
index 470e502a2131..71b46627c1ce 100644
--- a/sys-fs/ntfs3g/metadata.xml
+++ b/sys-fs/ntfs3g/metadata.xml
@@ -16,5 +16,7 @@ file ownership, access right.
<use>
<flag name='external-fuse'>Use external FUSE library instead of internal
one. Must be disabled for unprivileged mounting to work.</flag>
+ <flag name='udev'>Install udev rule to make devicekit-disks use
+ ntfs-3g instead of the kernel NTFS driver.</flag>
</use>
</pkgmetadata>
diff --git a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
index 926ebe0e68ea..7a848fa1f69a 100644
--- a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.2 2010/03/09 17:57:08 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.3 2010/05/05 02:36:40 chutzpah Exp $
EAPI=2
inherit linux-info
@@ -15,7 +15,7 @@ SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl debug hal suid +external-fuse"
+IUSE="acl debug hal suid udev +external-fuse"
RDEPEND="external-fuse? ( >=sys-fs/fuse-2.6.0 )
hal? ( sys-apps/hal )"
@@ -57,6 +57,11 @@ src_install() {
insinto /etc/hal/fdi/policy/
newins "${FILESDIR}/10-ntfs3g.fdi.2009-r1" "10-ntfs3g.fdi"
fi
+
+ if use udev; then
+ insinto /etc/udev/rules.d/
+ doins "${FILESDIR}/99-ntfs3g.rules"
+ fi
}
pkg_postinst() {