summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild')
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
index 926ebe0e68ea..7a848fa1f69a 100644
--- a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.2 2010/03/09 17:57:08 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.3 2010/05/05 02:36:40 chutzpah Exp $
EAPI=2
inherit linux-info
@@ -15,7 +15,7 @@ SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl debug hal suid +external-fuse"
+IUSE="acl debug hal suid udev +external-fuse"
RDEPEND="external-fuse? ( >=sys-fs/fuse-2.6.0 )
hal? ( sys-apps/hal )"
@@ -57,6 +57,11 @@ src_install() {
insinto /etc/hal/fdi/policy/
newins "${FILESDIR}/10-ntfs3g.fdi.2009-r1" "10-ntfs3g.fdi"
fi
+
+ if use udev; then
+ insinto /etc/udev/rules.d/
+ doins "${FILESDIR}/99-ntfs3g.rules"
+ fi
}
pkg_postinst() {