summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-07-28 22:59:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-07-28 22:59:02 +0000
commit61d9aaee86fd0db8eb9ea4b41e59236f0268dea4 (patch)
tree5d7a60ad2d3e634d5addaebf7a99e69901b49392
parentbump to 0.9. (diff)
downloadgentoo-2-61d9aaee86fd0db8eb9ea4b41e59236f0268dea4.tar.gz
gentoo-2-61d9aaee86fd0db8eb9ea4b41e59236f0268dea4.tar.bz2
gentoo-2-61d9aaee86fd0db8eb9ea4b41e59236f0268dea4.zip
Revision bump.
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-gentoo x86_64)
-rw-r--r--dev-python/wxpython/ChangeLog8
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild4
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild133
-rw-r--r--dev-python/wxpython/wxpython-2.8.7.1.ebuild4
4 files changed, 144 insertions, 5 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 739bd5d2ae04..b47c68636fdd 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.90 2008/07/28 21:43:11 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.91 2008/07/28 22:59:02 dirtyepic Exp $
+
+*wxpython-2.6.4.0-r2 (28 Jul 2008)
+
+ 28 Jul 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
+ +wxpython-2.6.4.0-r2.ebuild, wxpython-2.8.7.1.ebuild:
+ Revision bump.
28 Jul 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0.ebuild,
wxpython-2.6.4.0-r1.ebuild, wxpython-2.8.7.1.ebuild,
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index 054a7f716b6a..d69deb290b7e 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.15 2008/07/28 21:43:11 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.16 2008/07/28 22:59:02 dirtyepic Exp $
EAPI=1
@@ -95,7 +95,7 @@ src_install() {
for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
if [[ -d ${dir} ]]; then
- cp -R "${D}"/${site_pkgs}/wxaddons/ ${dir}
+ cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
wxaddons_copied=1
fi
done
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild
new file mode 100644
index 000000000000..02519541711c
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r2.ebuild,v 1.1 2008/07/28 22:59:02 dirtyepic Exp $
+
+EAPI=1
+
+inherit alternatives eutils multilib python wxwidgets flag-o-matic
+
+# Note, we don't use distutils.eclass because it doesn't seem to play nice with
+# need-wxwidgets
+
+MY_P="${P/wxpython-/wxPython-src-}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl unicode"
+
+RDEPEND=">=dev-lang/python-2.1
+ >=x11-libs/wxGTK-${PV}:2.6
+ >=x11-libs/gtk+-2.0
+ >=x11-libs/pango-1.2
+ >=dev-libs/glib-2.0
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ >=sys-libs/zlib-1.1.4
+ opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/wxPython/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+ epatch "${FILESDIR}"/scripts-multiver-2.6.1.0.diff
+}
+
+src_compile() {
+ local mypyconf
+ WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets ansi
+ fi
+
+ use opengl && check_wxuse opengl
+
+ append-flags -fno-strict-aliasing
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ use unicode \
+ && mypyconf="${mypyconf} UNICODE=1" \
+ || mypyconf="${mypyconf} UNICODE=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2"
+
+ python setup.py ${mypyconf} build || die "setup.py build failed"
+}
+
+src_install() {
+ local mypyconf
+ python_version
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+ use unicode \
+ && mypyconf="${mypyconf} UNICODE=1" \
+ || mypyconf="${mypyconf} UNICODE=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2"
+
+ python setup.py ${mypyconf} install --root="${D}" \
+ --install-purelib ${site_pkgs} || die "setup.py install failed"
+
+ # Collision protection.
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+
+ for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
+ if [[ -d ${dir} ]]; then
+ cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
+ wxaddons_copied=1
+ fi
+ done
+
+ [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
+}
+
+pkg_postinst() {
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ python_mod_optimize ${size_pkgs}
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers see this site for instructions on using 2.6 or 2.8"
+ elog "with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+}
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
index 9f35c2883b6d..604d7f578912 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.12 2008/07/28 21:43:11 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.13 2008/07/28 22:59:02 dirtyepic Exp $
EAPI="1"
WX_GTK_VER="2.8"
@@ -84,7 +84,7 @@ src_install() {
for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
if [[ -d ${dir} ]]; then
- cp -R "${D}"/${site_pkgs}/wxaddons/ ${dir}
+ cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
wxaddons_copied=1
fi
done