summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-text/ocaml-text-0.4.ebuild')
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/ocaml-text-0.4.ebuild b/dev-ml/ocaml-text/ocaml-text-0.4.ebuild
new file mode 100644
index 0000000..4c95a09
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit multilib findlib
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="https://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/537/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt pcre"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+virtual/libiconv
+pcre? ( dev-ml/pcre-ocaml[ocamlopt?] )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ ./configure --prefix "${EPREFIX}"/usr \
+ --mandir "${EPREFIX}"/usr/share/man \
+ --infodir "${EPREFIX}"/usr/share/info \
+ --datadir "${EPREFIX}"/usr/share \
+ --sysconfdir "${EPREFIX}"/etc \
+ --localstatedir "${EPREFIX}"/var/lib \
+ --libdir $(get_libdir) \
+ $(use_enable pcre)
+}
+
+src_install() {
+ findlib_src_install
+}