summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <wuodan@hispeed.ch>2012-07-20 16:36:45 +0200
committerStefan Kuhn <wuodan@hispeed.ch>2012-07-20 16:36:45 +0200
commitaadf86c3d5a19c9f0fa82b784108f9c9aea50daa (patch)
tree4a9ed0a036c73d1624588f0e0270e79a7552b601
parentminor update (diff)
downloadwuodan-aadf86c3d5a19c9f0fa82b784108f9c9aea50daa.tar.gz
wuodan-aadf86c3d5a19c9f0fa82b784108f9c9aea50daa.tar.bz2
wuodan-aadf86c3d5a19c9f0fa82b784108f9c9aea50daa.zip
adding apache 2.4.2 fixes
-rw-r--r--www-servers/apache/Manifest5
-rw-r--r--www-servers/apache/apache-2.4.2-r1.ebuild151
-rw-r--r--www-servers/apache/files/2.2.22-envvars-std.in28
-rw-r--r--www-servers/apache/metadata.xml28
4 files changed, 212 insertions, 0 deletions
diff --git a/www-servers/apache/Manifest b/www-servers/apache/Manifest
new file mode 100644
index 0000000..4aca616
--- /dev/null
+++ b/www-servers/apache/Manifest
@@ -0,0 +1,5 @@
+AUX 2.2.22-envvars-std.in 1071 RMD160 4613555ac600a4941ccd43128f98a9f6a95ba57d SHA1 b69dc500bb49fb14c801c6ab130a624c24e4d7fa SHA256 1721b424f2335640e49d71e671a4be15424d29fe90f55fe4f52bd241a998d3ee
+DIST gentoo-apache-2.4.1-20120401.tar.bz2 24998 RMD160 b543e9965b0a3a1040683a2a62b3ea7dc1391249 SHA1 e73f6084ceb10c564dbd0a13af9a308412fa9958 SHA256 4c6c638237ccf21e14ae45eb22f21ca46ce93d5bd11bf7b043337872fdef2c7c
+DIST httpd-2.4.2.tar.bz2 4132105 RMD160 1b97ab44075bea0f398f507dacb5f719a87b720b SHA1 8d391db515edfb6623c0c7c6ce5c1b2e1f7c64c2 SHA256 5382f9c507d3d02706e33d6308ea041f39e8511b5948aef0ca188df8f90159b8
+EBUILD apache-2.4.2-r1.ebuild 4850 RMD160 51932c2e570c649ebd04b4100eb3d1365ac95258 SHA1 7f5b5ec02d670a0d1b6107c728529caf77f61fc1 SHA256 30b6ac869923a2207ad15c5684792965a6da2c8ca8df8d7a2688d78df5294944
+MISC metadata.xml 932 RMD160 ee4ba8303731f1bb451fa96f30095dd380d7a824 SHA1 39f5bd400764a3f55b51ee17de547bc547e6c78d SHA256 f221f82c988695a174827e069157102017e724bdaae01e55f604479484e4cbaa
diff --git a/www-servers/apache/apache-2.4.2-r1.ebuild b/www-servers/apache/apache-2.4.2-r1.ebuild
new file mode 100644
index 0000000..9ebf283
--- /dev/null
+++ b/www-servers/apache/apache-2.4.2-r1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.2.ebuild,v 1.1 2012/04/20 03:58:46 patrick Exp $
+
+EAPI="2"
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20120401"
+GENTOO_DEVELOPER="patrick"
+GENTOO_PATCHNAME="gentoo-apache-2.4.1"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
+env expires ext_filter file_cache filter headers ident imagemap include info
+log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
+proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
+reqtimeout setenvif speling status substitute unique_id userdir usertrack
+version vhost_alias"
+# The following are also in the source as of this version, but are not available
+# for user selection:
+# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
+# optional_fn_import optional_hook_export optional_hook_import
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ proxy_scgi:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ socache_shmcb:SSL
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+MY_MODS="${MY_MODS} access_compat authn_core authz_core socache_shmcb unixd"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+# dependency on >=dev-libs/apr-1.4.5 for bug #368651
+RDEPEND="${RDEPEND}
+ >=dev-libs/apr-1.4.5
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+# init script fixup - should be rolled into next tarball #389965
+src_prepare() {
+ apache-2_src_prepare
+ sed -i -e 's/! test -f/test -f/' "${GENTOO_PATCHDIR}"/init/apache2.initd || die "Failed to fix init script"
+ # the folloginw patches can be removed once they're included in
+ # GENTOO_PATCHNAME="gentoo-apache-2.4.1" ...
+ # patch /etc/apache2/modules.d/40_mod_ssl.conf
+ sed -i -e 's/^SSLMutex file:\/var\/run\/ssl_mutex$/Mutex file:\/var\/run\/ssl_mutex ssl-cache/' \
+ "${GENTOO_PATCHDIR}"/conf/modules.d/40_mod_ssl.conf \
+ || die "Failed to fix 40_mod_ssl.conf"
+ # patch /etc/apache2/modules.d/00_mod_mime.conf
+ # only "DefaultType none" is allowed, throws warning
+ sed -i -e 's/^DefaultType text\/plain$/DefaultType none/' \
+ "${GENTOO_PATCHDIR}"/conf/modules.d/00_mod_mime.conf \
+ || die "Failed to fix 00_mod_mime.conf"
+ # patch /etc/apache2/vhosts.d/00_default_vhost.conf
+ # NameVirtualHost is deprecated and throws warning
+ sed -i -e 's/^NameVirtualHost \*:80$/# NameVirtualHost \*:80/' \
+ "${GENTOO_PATCHDIR}"/conf/vhosts.d/00_default_vhost.conf \
+ || die "Failed to fix 00_default_vhost.conf"
+}
+
+src_install() {
+ apache-2_src_install
+ for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
+ rm "${D}/"$i || die "Failed to prune apache-tools bits"
+ done
+
+ # well, actually installing things makes them more installed, I guess?
+ cp "${S}"/support/apxs "${D}"/usr/sbin/apxs || die "Failed to install apxs"
+ chmod 0755 "${D}"/usr/sbin/apxs
+
+ # for previous patch to 40_mod_ssl.conf
+ use ssl && dodir /var/run/ssl_mutex || die "Failed to mkdir ssl_mutex"
+}
diff --git a/www-servers/apache/files/2.2.22-envvars-std.in b/www-servers/apache/files/2.2.22-envvars-std.in
new file mode 100644
index 0000000..9493bc7
--- /dev/null
+++ b/www-servers/apache/files/2.2.22-envvars-std.in
@@ -0,0 +1,28 @@
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed with
+# this work for additional information regarding copyright ownership.
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+# envvars-std - default environment variables for apachectl
+#
+# This file is generated from envvars-std.in
+#
+if test "x$@SHLIBPATH_VAR@" != "x" ; then
+ @SHLIBPATH_VAR@="@exp_libdir@:$@SHLIBPATH_VAR@"
+else
+ @SHLIBPATH_VAR@="@exp_libdir@"
+fi
+export @SHLIBPATH_VAR@
+#
+@OS_SPECIFIC_VARS@
diff --git a/www-servers/apache/metadata.xml b/www-servers/apache/metadata.xml
new file mode 100644
index 0000000..5229f1f
--- /dev/null
+++ b/www-servers/apache/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>apache</herd>
+ <maintainer>
+ <email>apache-bugs@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>mail@ghelm.de</email>
+ <name>Gerrit Helm (proxymaint)</name>
+ </maintainer>
+ <longdescription>
+ The Apache HTTP Server Project is an effort to develop and maintain an
+ open-source HTTP server for modern operating systems. The goal of this
+ project is to provide a secure, efficient and extensible server that
+ provides HTTP services in sync with the current HTTP standards.
+ </longdescription>
+ <use>
+ <flag name='suexec'>Install suexec with apache</flag>
+ <flag name='static'>Link in apache2 modules statically rather then plugins</flag>
+ </use>
+</pkgmetadata>