summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn (Wuodan) <wuodan-gentoo@hispeed.ch>2012-08-18 03:02:27 +0200
committerStefan Kuhn (Wuodan) <wuodan-gentoo@hispeed.ch>2012-08-18 03:02:27 +0200
commit883f8bd894581d2e3c19ee7674b76a2e88175712 (patch)
tree31f3d038219607959daa94c823b2f8806075ce4c
parentdumpet - a tool to dump and debug bootable CD-like images (diff)
downloadwuodan-883f8bd894581d2e3c19ee7674b76a2e88175712.tar.gz
wuodan-883f8bd894581d2e3c19ee7674b76a2e88175712.tar.bz2
wuodan-883f8bd894581d2e3c19ee7674b76a2e88175712.zip
app-cdr/dumpet-2.1 : reviewed by sunrise but they show no interest in
adding it
-rw-r--r--app-cdr/dumpet/Manifest3
-rw-r--r--app-cdr/dumpet/dumpet-2.1.ebuild26
-rw-r--r--app-cdr/dumpet/files/dumpet-2.1-flags.patch25
3 files changed, 41 insertions, 13 deletions
diff --git a/app-cdr/dumpet/Manifest b/app-cdr/dumpet/Manifest
index 83be76b..b778d30 100644
--- a/app-cdr/dumpet/Manifest
+++ b/app-cdr/dumpet/Manifest
@@ -1,3 +1,4 @@
+AUX dumpet-2.1-flags.patch 672 RMD160 31f68aacdd35eff740599d377e6090a389ddda9e SHA1 27e4db667590197b23f61329a94be3d911731146 SHA256 a1633c301d86cfb6c25a43283972840fcdb72d72e4226b831d0a260f7f9a4a21
DIST dumpet-2.1.tar.bz2 14681 RMD160 cf1a0923c658ef285176fca59c97a3e04636b4ef SHA1 56fc8a52a8df12083912496d6d7de993f2063ec1 SHA256 2cc1fa3a1b06f885e4524d1be80bdacc5b6a55057d0577262f2f5186b49a4da3
-EBUILD dumpet-2.1.ebuild 618 RMD160 3c6fe230ab084a8bd6b3917cde190e02039f40f5 SHA1 9c8d6d36314c9bb5a4a05f8fa7e0eb966ef9bb49 SHA256 a333b3b02b07aa01f060917d9cd720f1c6c700b47990a5fb49f41a5663d88819
+EBUILD dumpet-2.1.ebuild 561 RMD160 4a1e55151e92c514265d83c90a391d540380021a SHA1 bc122b06c25627c9e9be59cd9366221f48c84e2f SHA256 f5bac5ac7adaf0106273452bec45d9d36581749b8fc461c329c318ffa5b32bf4
MISC metadata.xml 341 RMD160 22a4062d2e5e418715c2cb9b58a398c2637449b7 SHA1 50e4c81cb9fbcf565191d204cd36838defdbc0c7 SHA256 90b9a195b84a450e37e9c39dd57f4cbad58a304a3aabfda3fa63b98ab50f2f1a
diff --git a/app-cdr/dumpet/dumpet-2.1.ebuild b/app-cdr/dumpet/dumpet-2.1.ebuild
index 08a00a9..61110ff 100644
--- a/app-cdr/dumpet/dumpet-2.1.ebuild
+++ b/app-cdr/dumpet/dumpet-2.1.ebuild
@@ -3,25 +3,27 @@
# $Header: $
EAPI=4
+inherit eutils toolchain-funcs
-DESCRIPTION="dumpet - a tool to dump and debug bootable CD-like images"
-HOMEPAGE="https://fedorahosted.org/dumpet/"
-SRC_URI="https://fedorahosted.org/releases/d/u/${PN}/${P}.tar.bz2"
+DESCRIPTION="A tool to dump and debug bootable CD-like images"
+HOMEPAGE="http://fedorahosted.org/dumpet/"
+SRC_URI="http://fedorahosted.org/releases/d/u/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-libs/libxml2"
-RDEPEND=""
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
-src_prepare() {
- sed -i 's/^CFLAGS:=.*$/CFLAGS:=$\(CFLAGS\)/' Makefile || die "sed failed"
- sed -i 's/^LFLAGS:=$/LFLAGS:=$\(LFLAGS\)/' Makefile || die "sed failed"
+pkg_setup(){
+ tc-export CC
}
-src_install() {
- dobin dumpet
- doman dumpet.1
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-flags.patch
}
diff --git a/app-cdr/dumpet/files/dumpet-2.1-flags.patch b/app-cdr/dumpet/files/dumpet-2.1-flags.patch
new file mode 100644
index 0000000..bd1344f
--- /dev/null
+++ b/app-cdr/dumpet/files/dumpet-2.1-flags.patch
@@ -0,0 +1,25 @@
+--- Makefile
++++ Makefile
+@@ -2,17 +2,16 @@
+ VERSION=2.1
+ GITVERSION=$(shell [ -d .git ] && git rev-list --abbrev-commit -n 1 HEAD |cut -b 1-8)
+
+-CFLAGS:=-g3 -O2 -Wall -Werror
+-LFLAGS:=
+-CC:=gcc
++CFLAGS ?= -g3 -O2 -Wall -Werror
++CC ?= gcc
+
+-CFLAGS += $(shell pkg-config --cflags libxml-2.0)
+-LFLAGS += -lpopt $(shell pkg-config --libs libxml-2.0)
++CFLAGS += $(shell pkg-config --cflags libxml-2.0 popt)
++LIBS += $(shell pkg-config --libs libxml-2.0 popt)
+
+ all : dumpet
+
+ dumpet : dumpet.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ dumpet.o : dumpet.c dumpet.h iso9660.h eltorito.h endian.h
+ $(CC) $(CFLAGS) -c -o $@ $<