summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-11-17 13:45:44 +0200
committerIskren Slavov <iskren.s@gmail.com>2010-11-17 13:45:44 +0200
commit41c09a21ef786f27ecdf92769a18550d328e5d63 (patch)
tree9f25ce10e2ed37d3c85a1e454de8fa27f11e546b
parentliferea version bump (diff)
downloadwish-41c09a21ef786f27ecdf92769a18550d328e5d63.tar.gz
wish-41c09a21ef786f27ecdf92769a18550d328e5d63.tar.bz2
wish-41c09a21ef786f27ecdf92769a18550d328e5d63.zip
go-oo-bin fixes. fluback moved to /opt
-rw-r--r--app-backup/flyback/Manifest2
-rw-r--r--app-backup/flyback/files/flyback-0.6.5-location.patch18
-rw-r--r--app-backup/flyback/flyback-0.6.5-r2.ebuild57
-rw-r--r--app-office/go-oo-bin/Manifest2
-rw-r--r--app-office/go-oo-bin/files/50-openoffice-bin1
-rw-r--r--app-office/go-oo-bin/files/wrapper.in4
6 files changed, 84 insertions, 0 deletions
diff --git a/app-backup/flyback/Manifest b/app-backup/flyback/Manifest
index 7cac56d..c0b18ad 100644
--- a/app-backup/flyback/Manifest
+++ b/app-backup/flyback/Manifest
@@ -1,2 +1,4 @@
+AUX flyback-0.6.5-location.patch 563 RMD160 a057e3659c5fed680ca6e53f1db9806db0da7eac SHA1 5664ef192f64fc1b42e3baf1ece13c179d40e097 SHA256 a6598ee458bc9fc8c2c64df9a1aa54ef3e1e392ef9fae203a1705e16bc288aec
DIST flyback-lucid_0.6.5-1_all.deb 37668 RMD160 5c5e7938363943191c804a22ec25002a4acc02c9 SHA1 452d2e3d5658dce13244bda8346aa54b3cc3a1a6 SHA256 bdc68049afed5837e9fd110ae3d3b6b2e6a773866bec97f97ddae8f0df96bb16
EBUILD flyback-0.6.5-r1.ebuild 1217 RMD160 5bb93ebc764a9bc99f533979f63e4d49acaf62be SHA1 99126f057dc473b09df0eb4fb74ad2d3458322ed SHA256 44b44323c2d5da6598de90d427ac9d74de141ab14ca4493e6e73159b9cee254a
+EBUILD flyback-0.6.5-r2.ebuild 1250 RMD160 1e4668684cd75646b52a68479584d030b9f7c702 SHA1 b855d820bda3989a49597ce2b19fae2a1a78efc6 SHA256 7ed90dbcc863b85250125d744ff845a5fc78ad191be37195b8b82da227c10619
diff --git a/app-backup/flyback/files/flyback-0.6.5-location.patch b/app-backup/flyback/files/flyback-0.6.5-location.patch
new file mode 100644
index 0000000..7665223
--- /dev/null
+++ b/app-backup/flyback/files/flyback-0.6.5-location.patch
@@ -0,0 +1,18 @@
+--- usr/share/applications/flyback.desktop.orig 2010-11-17 12:48:46.623000082 +0200
++++ usr/share/applications/flyback.desktop 2010-11-17 12:49:15.133000069 +0200
+@@ -1,5 +1,5 @@
+ [Desktop Entry]
+-Version=0.5.0
++Version=0.6.5
+ Encoding=UTF-8
+ Name=Flyback Backup Manager
+ Type=Application
+@@ -7,7 +7,7 @@
+ Comment=Apple's Time Machine for Linux
+ Icon=/usr/share/icons/gnome/scalable/actions/stock_save.svg
+ FilePattern=flyback;
+-Exec=/usr/share/flyback/flyback.py
++Exec=/opt/flyback/flyback.py
+ Terminal=false
+ StartupNotify=false
+ Categories=Application;System;
diff --git a/app-backup/flyback/flyback-0.6.5-r2.ebuild b/app-backup/flyback/flyback-0.6.5-r2.ebuild
new file mode 100644
index 0000000..c30f99c
--- /dev/null
+++ b/app-backup/flyback/flyback-0.6.5-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+EAPI=2
+
+DESCRIPTION="Apple's Time Machine alternative for Linux"
+HOMEPAGE="http://code.google.com/p/flyback/"
+SRC_URI="http://flyback.googlecode.com/files/flyback-lucid_0.6.5-1_all.deb"
+
+IUSE=""
+SLOT="0"
+LICENSE="UNKNOWN"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip mirror"
+
+DEPEND=">=dev-lang/python-3.1.2
+ >=dev-util/glade-3.6.7[gnome,python]
+ >=gnome-base/libglade-2.6.4
+ >=dev-vcs/git-1.7.2.2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+ epatch "${FILESDIR}/${P}-location.patch"
+}
+
+src_install() {
+ BASEDIR=usr/share
+ INSTDIR=/opt
+
+ // Python files
+ insinto "${INSTDIR}/flyback"
+ for file in "${BASEDIR}"/flyback/*;
+ do
+ doins "${file}"
+ done
+
+ // Glade files
+ insinto "${INSTDIR}/flyback/glade"
+ for file in "${BASEDIR}"/flyback/glade/*;
+ do
+ doins "${file}"
+ done
+
+ // Executable file
+ exeinto "${INSTDIR}/flyback"
+ doexe "${BASEDIR}/flyback/flyback.py"
+
+ // Changelog
+ dodoc "${BASEDIR}/doc/flyback/changelog.Debian.gz"
+
+ // Icon
+ exeinto "/usr/share/applications"
+ doexe "${BASEDIR}/applications/flyback.desktop"
+}
diff --git a/app-office/go-oo-bin/Manifest b/app-office/go-oo-bin/Manifest
index 0205475..ca3d63b 100644
--- a/app-office/go-oo-bin/Manifest
+++ b/app-office/go-oo-bin/Manifest
@@ -1,3 +1,5 @@
+AUX 50-openoffice-bin 83 RMD160 cc73734b3ac5114446ed69968890c6647301f247 SHA1 6c0834e46fe055105b6294b3aadf246df65dfe13 SHA256 163a3bb6ff717b992af9b28351eec62d520fe29973073ee3648c347b65e2dbad
+AUX wrapper.in 100 RMD160 a5830a0a18f3f6046d1638eabe619e2c790d9b37 SHA1 e872a47a9527c7ec2d1975f85ce3477189b86be9 SHA256 95048af7694eab38aad1e72d89025370f0c6ac04640eed80c370b5d2e14fb25a
DIST ooobasis3.2-base-3.2.1-9505.i586.rpm 2181170 RMD160 9e5246e3343627c41c3f9450a76cae8f8b5eb8ff SHA1 4e66df65524fda50d2078b7414676b71dc5bbb7d SHA256 3f2b0b1577fa10d1b7be5568211c9745cf12aa46d739e79feb3ed23ac599cc19
DIST ooobasis3.2-base-3.2.1-9505.x86_64.rpm 2902383 RMD160 718a1acf550da0de71ee1f34f46896bb7297f18c SHA1 33bf073c5f1dc646aff5b20427b32600a839d650 SHA256 2446fe8429aa7f4e2840191d914a18ebd5ce5425a9649929d73fe03f1e7050fe
DIST ooobasis3.2-binfilter-3.2.1-9505.i586.rpm 7611611 RMD160 f5bb2494e5452ff0d13c79494dcd68f201b6d450 SHA1 b8cfb8ae34c13ae724094cb758ac2a56c9eb1895 SHA256 8a69920728293de0c6577fa787533d28106ea5ed43f3814d86cdfb306c66d46f
diff --git a/app-office/go-oo-bin/files/50-openoffice-bin b/app-office/go-oo-bin/files/50-openoffice-bin
new file mode 100644
index 0000000..12eeb60
--- /dev/null
+++ b/app-office/go-oo-bin/files/50-openoffice-bin
@@ -0,0 +1 @@
+SEARCH_DIRS_MASK="/usr/lib/openoffice /usr/lib32/openoffice /usr/lib64/openoffice"
diff --git a/app-office/go-oo-bin/files/wrapper.in b/app-office/go-oo-bin/files/wrapper.in
new file mode 100644
index 0000000..5e704af
--- /dev/null
+++ b/app-office/go-oo-bin/files/wrapper.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+export OOO_EXTRA_ARG=''
+unset PYTHONPATH
+exec /usr/LIBDIR/openoffice/program/soffice "$@"