summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-06-20 09:24:59 +0300
committerIskren Slavov <iskren.s@gmail.com>2010-06-20 09:24:59 +0300
commit05a929053565facff8d59e477a973cf5a2308022 (patch)
tree3858653ab7d8aa9087a4695af213151f50571fa5
parentGIMP 2.7.0 ebuild added and a mysql-workbench ebuild that does not need exper... (diff)
downloadwish-05a929053565facff8d59e477a973cf5a2308022.tar.gz
wish-05a929053565facff8d59e477a973cf5a2308022.tar.bz2
wish-05a929053565facff8d59e477a973cf5a2308022.zip
Updated flush. Added trickle. Some small fixes
-rw-r--r--app-emulation/wine/Manifest7
-rw-r--r--app-emulation/wine/files/wine-1.1.15-winegcc.patch55
-rw-r--r--app-emulation/wine/wine-1.1.44.ebuild178
-rw-r--r--dev-db/mysql-workbench/Manifest4
-rw-r--r--dev-db/mysql-workbench/mysql-workbench-5.2.21.ebuild60
-rw-r--r--gnome-extra/googsystray/Manifest2
-rw-r--r--gnome-extra/googsystray/googsystray-1.1.4.ebuild2
-rw-r--r--media-video/miro/Manifest2
-rw-r--r--media-video/miro/miro-3.0.1.ebuild105
-rw-r--r--net-misc/trickle/Manifest2
-rw-r--r--net-misc/trickle/trickle-1.07.ebuild24
-rw-r--r--net-p2p/flush/Manifest4
-rw-r--r--net-p2p/flush/flush-0.9.6.ebuild55
-rw-r--r--net-p2p/flush/metadata.xml4
14 files changed, 496 insertions, 8 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
new file mode 100644
index 0000000..5f2d179
--- /dev/null
+++ b/app-emulation/wine/Manifest
@@ -0,0 +1,7 @@
+AUX wine-1.1.15-winegcc.patch 1550 RMD160 086fbdd7dbe5da98c3457f00cb30705150d58b1f SHA1 0aa5a9d0947e15af9fe103797a0c993cbb3eedab SHA256 fcf4a0578774d817b8de094abae85e370683a77805a59efe6c5f7b8b87935de9
+DIST wine-1.1.44.tar.bz2 17002412 RMD160 b5bea9bf7ba64f9fb5d131b2874c35fb64f0ea11 SHA1 60f11693161b28ff9814949f2b6bbccee1d07a2c SHA256 268deeba52b1e6b5210e502cc584fbffa323252ce239a1545d3ab1abb9b0f22e
+DIST wine_gecko-1.0.0-x86.cab 8119486 RMD160 57618dbffa7b7226dcd44f86c3c569ab8a5ff938 SHA1 afa22c52bca4ca77dcb9edb3c9936eb23793de01 SHA256 7ddf697677506fb164c52771864e32dd69a359ed855b2efbc51340de2376c99c
+DIST winepulse-0.34-winecfg.patch 13066 RMD160 7a05298f68bbdcc80596e931c47b178484ae9c5a SHA1 1a495dd6fd93573a274d525af8b74713f57a7d18 SHA256 a2925d4a02db57ed8961b45b80a0f966fed1f499120e094156a4c51086e47cdc
+DIST winepulse-0.35-configure.ac.patch 2826 RMD160 e419d43667be01af9b24a0e46822c41572a6ff9d SHA1 4943381128fd9555280884e2bb5867be4a8731d9 SHA256 837bffaaddb6b7b0a474c7262a57f12e250e135cf6228dde1a22849f66de1250
+DIST winepulse-0.36.patch 101815 RMD160 9a20076436a7e49c317bc624dd71b61c93acddff SHA1 aa6a4c9d4619f8452aad8c457c879769cab8f8fc SHA256 7508b171bfecb461ecb464426cb4bcd9c3ff77645b787fcbf61e27dd34fe1b05
+EBUILD wine-1.1.44.ebuild 4929 RMD160 b90d6850c3c0a7e79fffed2ab670b440fb667635 SHA1 214f8efae3c48ef1fc49e9c21548d840351232ec SHA256 6c30826e6792cc02fb520ef6b78b13189a300fff856355df36679d48491752e1
diff --git a/app-emulation/wine/files/wine-1.1.15-winegcc.patch b/app-emulation/wine/files/wine-1.1.15-winegcc.patch
new file mode 100644
index 0000000..6e5bb22
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.1.15-winegcc.patch
@@ -0,0 +1,55 @@
+http://bugs.gentoo.org/260726
+
+--- wine-1.1.15/tools/winegcc/winegcc.c
++++ wine-1.1.15/tools/winegcc/winegcc.c
+@@ -215,10 +215,13 @@
+ strarray* files;
+ };
+
++#undef FORCE_POINTER_SIZE
+ #ifdef __i386__
+ static const enum target_cpu build_cpu = CPU_x86;
++#define FORCE_POINTER_SIZE
+ #elif defined(__x86_64__)
+ static const enum target_cpu build_cpu = CPU_x86_64;
++#define FORCE_POINTER_SIZE
+ #elif defined(__sparc__)
+ static const enum target_cpu build_cpu = CPU_SPARC;
+ #elif defined(__ALPHA__)
+@@ -968,6 +971,9 @@
+ opts.linker_args = strarray_alloc();
+ opts.compiler_args = strarray_alloc();
+ opts.winebuild_args = strarray_alloc();
++#ifdef FORCE_POINTER_SIZE
++ opts.force_pointer_size = sizeof(size_t);
++#endif
+
+ /* determine the processor type */
+ if (strendswith(argv[0], "winecpp")) opts.processor = proc_cpp;
+--- wine-1.1.15/tools/winebuild/main.c
++++ wine-1.1.15/tools/winebuild/main.c
+@@ -50,10 +50,13 @@
+ int link_ext_symbols = 0;
+ int force_pointer_size = 0;
+
++#undef FORCE_POINTER_SIZE
+ #ifdef __i386__
+ enum target_cpu target_cpu = CPU_x86;
++#define FORCE_POINTER_SIZE
+ #elif defined(__x86_64__)
+ enum target_cpu target_cpu = CPU_x86_64;
++#define FORCE_POINTER_SIZE
+ #elif defined(__sparc__)
+ enum target_cpu target_cpu = CPU_SPARC;
+ #elif defined(__ALPHA__)
+@@ -574,6 +577,10 @@
+ signal( SIGTERM, exit_on_signal );
+ signal( SIGINT, exit_on_signal );
+
++#ifdef FORCE_POINTER_SIZE
++ force_pointer_size = sizeof(size_t);
++#endif
++
+ output_file = stdout;
+ argv = parse_options( argc, argv, spec );
+
diff --git a/app-emulation/wine/wine-1.1.44.ebuild b/app-emulation/wine/wine-1.1.44.ebuild
new file mode 100644
index 0000000..b935bde
--- /dev/null
+++ b/app-emulation/wine/wine-1.1.44.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.43.ebuild,v 1.1 2010/04/20 08:11:27 vapier Exp $
+
+EAPI="2"
+
+AUTOTOOLS_AUTO_DEPEND="no"
+inherit eutils flag-o-matic multilib autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+pulse_patches() { echo "$1"/winepulse-{0.36,0.35-configure.ac,0.34-winecfg}.patch ; }
+GV="1.0.0-x86"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )
+ pulseaudio? ( `pulse_patches http://art.ified.ca/downloads/winepulse` )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl oss +perl png pulseaudio samba scanner ssl test +threads +truetype win64 +X xcomposite xinerama xml"
+RESTRICT="test" #72375
+
+RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ openal? ( media-libs/openal )
+ dbus? ( sys-apps/dbus )
+ gnutls? ( net-libs/gnutls )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ xinerama? ( x11-libs/libXinerama )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ pulseaudio? ( media-sound/pulseaudio ${AUTOTOOLS_DEPEND} )
+ gsm? ( media-sound/gsm )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( media-libs/lcms )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ !win64? ( amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ ) )
+ xcomposite? ( x11-libs/libXcomposite ) "
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
+ use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ if use pulseaudio ; then
+ EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
+ eautoreconf
+ fi
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch_user #282735
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+src_configure() {
+ export LDCONFIG=/bin/true
+
+ use custom-cflags || strip-flags
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with esd) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(! use dbus && echo --without-hal || use_with hal) \
+ $(use_with jack) \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nas) \
+ $(use_with openal) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_with truetype freetype) \
+ $(use_enable win64) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+}
+
+src_compile() {
+ emake all || die "all"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}.cab || die
+ fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+}
+
+pkg_postinst() {
+ paxctl -psmr "${ROOT}"/usr/bin/wine{,-preloader} 2>/dev/null #255055
+}
diff --git a/dev-db/mysql-workbench/Manifest b/dev-db/mysql-workbench/Manifest
index b5d996c..2b9ab50 100644
--- a/dev-db/mysql-workbench/Manifest
+++ b/dev-db/mysql-workbench/Manifest
@@ -1,4 +1,4 @@
AUX mysql-workbench-5.2.17-as-needed-modules.patch 817 RMD160 07a91a62a364ead59597317738df334a8773338a SHA1 60c17b4337adef0257e3c9dc9facefcc5b6364fe SHA256 2b2503059228381ff16135bb6bf9987807661215b8b45f91acb7c6c156c5d7da
AUX mysql-workbench-5.2.17-python-libs.patch 853 RMD160 b2ca54f9342c082395c5b5cac92e6247362531b9 SHA1 405a46f1d15f8d428dc3e6f0eada4d36cc00bb93 SHA256 8625ec48e17d3871d37dce559118868edc840a235a0010b47ea4f1afb277872b
-DIST mysql-workbench-oss-5.2.20.tar.gz 16511576 RMD160 e3ab3e6d9c03d4f496e6025e41771dad43dcc6f2 SHA1 daaa467c44bb3459d3c7be4d16fe1036d4dab210 SHA256 9aa9dfe9a654c4c2aae846aef2d32988dc03a6e7489f15919a3b1e95d8cace07
-EBUILD mysql-workbench-5.2.20.ebuild 1452 RMD160 2d0bec7932c58ad9d1c8ea965709e8bb0846d3a7 SHA1 ad40e219e5e4a1c06073d3f4d8dad340fe1b1836 SHA256 83f2648eed6c90239ed4ef676aa501f82af48f1bf76fef444e885ec9b25ba528
+DIST mysql-workbench-oss-5.2.21.tar.gz 21462203 RMD160 fc422f9f944e0b9e4ebfab16f2f956bcd0f8f09c SHA1 7a4b4254236c1595fc8c60ff58ddfbf8a09492d2 SHA256 5c90cca2d24eaa0205f4b4edf74bd4aa254c05def38bab87b50ea147c90b1e5c
+EBUILD mysql-workbench-5.2.21.ebuild 1325 RMD160 47307172e01723a27a28dd3813cfc85f22c9a024 SHA1 cc686f229fe0c239e7fee2429f036b97ea3daef6 SHA256 4c1c01e67e209d7059effc375a7366b3f2dce0a8ad6a9fa6ae14fcaba6070b38
diff --git a/dev-db/mysql-workbench/mysql-workbench-5.2.21.ebuild b/dev-db/mysql-workbench/mysql-workbench-5.2.21.ebuild
new file mode 100644
index 0000000..90301b5
--- /dev/null
+++ b/dev-db/mysql-workbench/mysql-workbench-5.2.21.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils flag-o-matic autotools
+
+MY_P="${PN}-oss-${PV}"
+
+DESCRIPTION="MySQL Workbench"
+HOMEPAGE="http://dev.mysql.com/workbench/"
+SRC_URI="mirror://mysql/Downloads/MySQLGUITools/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls readline static-libs"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ dev-libs/libsigc++:2
+ dev-libs/boost
+ >=dev-libs/libxml2-2.6.2
+ >=dev-cpp/glibmm-2.14
+ >=dev-cpp/gtkmm-2.14
+ dev-libs/libzip
+ >=virtual/mysql-5.0
+ dev-libs/libpcre
+ virtual/opengl
+ >=dev-lang/lua-5.1[deprecated]
+ gnome-base/libgnome
+ x11-libs/pango
+ || ( sys-libs/e2fsprogs-libs
+ dev-libs/ossp-uuid )
+ >=x11-libs/cairo-1.5.12[svg]
+ dev-python/pexpect
+ dev-python/paramiko
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ >=dev-cpp/ctemplate-0.95
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.2.17-python-libs.patch"
+ epatch "${FILESDIR}/${PN}-5.2.17-as-needed-modules.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable readline readline) \
+ $(use_enable debug) \
+ $(use_enable static-libs static) \
+ --with-system-ctemplate
+}
diff --git a/gnome-extra/googsystray/Manifest b/gnome-extra/googsystray/Manifest
index 4421041..9b98872 100644
--- a/gnome-extra/googsystray/Manifest
+++ b/gnome-extra/googsystray/Manifest
@@ -1,4 +1,4 @@
DIST googsystray-1.1.4.tar.gz 777944 RMD160 ac7ecaa412d04a570e12b983d86770aced665ce7 SHA1 5ad7806e599619885d751b02c8b299345e2fd222 SHA256 a455bd68695bad946e810e183e9e1d5e40a66111a2e288183f372e84f7b1873c
-EBUILD googsystray-1.1.4.ebuild 503 RMD160 e69c5df6c56c43a85dca9e7b0753c65f81790a5b SHA1 0cfa48e9f8f0390cda93fe6a8e013675a2873148 SHA256 b5d6d61a7fcf06d7aabb471fd8232b79aba50a8e5a5d43cfb982b28ea3ebedd6
+EBUILD googsystray-1.1.4.ebuild 503 RMD160 a6bad900020f8f86a240220102639aaa2350d7c8 SHA1 f194c2b7b5101427dbcd1c09f62ac8931eda2a74 SHA256 250157abd6ecc4c9345a97a15bd4e9f4e807f2ca61b98654d94cb25bea512516
MISC ChangeLog 241 RMD160 9b1ec96a52a3013965c5d6b1fe802234178480b4 SHA1 12a203a12c8f34dfc5fd39bd324ec69d7d2da49c SHA256 7a930198e47473cb42e94a3c8f431059af17afe364a4fdb54722bcff4813fb37
MISC metadata.xml 426 RMD160 d2c2d98a9be0bc7d6b3b26c95057fa2eccdf1f44 SHA1 ef0bd670d4b59ab34eadd5c8c464c142c87f7728 SHA256 a3155e629b3d733fec67cb1f6f619426e5a6a48b197103a172adf52b4a891014
diff --git a/gnome-extra/googsystray/googsystray-1.1.4.ebuild b/gnome-extra/googsystray/googsystray-1.1.4.ebuild
index c7b4e82..099dc78 100644
--- a/gnome-extra/googsystray/googsystray-1.1.4.ebuild
+++ b/gnome-extra/googsystray/googsystray-1.1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI="1"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
diff --git a/media-video/miro/Manifest b/media-video/miro/Manifest
new file mode 100644
index 0000000..3dbd578
--- /dev/null
+++ b/media-video/miro/Manifest
@@ -0,0 +1,2 @@
+DIST miro-3.0.1.tar.gz 9714508 RMD160 02f7ba94cb63752e679c00687f685691043fe2ed SHA1 3b3fe543e3e14010e715a0dfd3a02c4af8288af5 SHA256 595185646f6fbc82559448fc9003be06514e5b96646d61553f29509b6198ee76
+EBUILD miro-3.0.1.ebuild 2898 RMD160 be377b6db2bc93ff9d9a20c0fc8b4323a4cb31de SHA1 2fd62f62e42f030c6219e9df9c5c56614217e3a4 SHA256 4c9fa8199f8615a7f75c1f356e5d27af5f9891194a947f145cc55aee07078c57
diff --git a/media-video/miro/miro-3.0.1.ebuild b/media-video/miro/miro-3.0.1.ebuild
new file mode 100644
index 0000000..8df0fcb
--- /dev/null
+++ b/media-video/miro/miro-3.0.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-2.5.4.ebuild,v 1.1 2010/03/05 19:24:41 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils fdo-mime gnome2-utils python distutils
+
+DESCRIPTION="Open source video player and podcast client"
+HOMEPAGE="http://www.getmiro.com/"
+SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+gstreamer libnotify"
+
+CDEPEND="
+ dev-libs/boost[python]
+ dev-libs/glib:2
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ media-libs/xine-lib
+ >=net-libs/rb_libtorrent-0.14.1[python]
+ || ( net-libs/xulrunner:1.9 net-libs/xulrunner:1.8 )
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+RDEPEND="${CDEPEND}
+ gstreamer? ( dev-python/gst-python:0.10 )
+ libnotify? ( dev-python/notify-python )
+ || ( dev-lang/python[sqlite] dev-python/pysqlite:2 )
+ dev-python/dbus-python
+ dev-python/gconf-python
+ dev-python/gtkmozembed-python
+ dev-python/pycairo"
+DEPEND="${CDEPEND}
+ >=dev-python/pyrex-0.9.6.4
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P}/platform/gtk-x11"
+
+# NOTES:
+# it's probably not working with python-3
+# used xulrunner has to be the same as the one used for gtkmozembed-python
+# psyco can make miro speedier, add a USE flag, recommand in postinst ?
+
+# TODO:
+# create a real test suite, upstream bug 12369
+# try to have a real xine/gstreamer choice, upstream bug 12371
+
+src_prepare() {
+ # disable autoupdate
+ sed -i -e "/autoupdate/d" ../../portable/startup.py || die "sed failed"
+
+ # be sure libnotify is never used if disabled
+ if ! use libnotify; then
+ sed -i -e "s:import pynotify:import pynotifyisdisabled:" \
+ ../../portable/frontends/widgets/gtk/trayicon.py \
+ plat/frontends/widgets/application.py || die "sed failed"
+ fi
+
+ # set xine as the default renderer if gstreamer is disabled
+ if ! use gstreamer; then
+ sed -i -e "s:default=u\"gstreamer\":default=u\"xine\":" \
+ plat/options.py || die "sed failed"
+ fi
+}
+
+src_test() {
+ # there is a test suite but it has been designed to be used when installed
+ # should be fixed
+ #./run.sh --unittests || die "tests failed"
+ :
+}
+
+src_install() {
+ # doing the mv now otherwise, distutils_src_install will install it
+ mv README README.gtk || die "mv failed"
+
+ distutils_src_install
+
+ # installing docs
+ dodoc README.gtk ../../{ADOPTERS,CREDITS,README} || die "dodoc failed"
+ newdoc ../../portable/frontends/cli/README README.cli || die "dodoc failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ elog "If you can't see a video or can't heard an audio,"
+ elog "enable needed media-libs/xine-lib USE flags"
+ elog "or install required gstreamer plugins"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_icon_cache_update
+}
diff --git a/net-misc/trickle/Manifest b/net-misc/trickle/Manifest
new file mode 100644
index 0000000..4dc2743
--- /dev/null
+++ b/net-misc/trickle/Manifest
@@ -0,0 +1,2 @@
+DIST trickle_1.07.orig.tar.gz 308863 RMD160 0c3836aa3cfb2b3e2bfd3abe8aba05d095e56efd SHA1 fb524ef3ef1944ad5863312dfc235cbf802efa30 SHA256 9d36507e0b7afdfb87533244f7d75daa1c17f2768982674f4c9add5ae6c03868
+EBUILD trickle-1.07.ebuild 573 RMD160 e812160ceff1b876d9a4da9ef619b5095a98f220 SHA1 fe30487aaacf92e46f63be9750f9ac2a857978cb SHA256 c8a159ee2b977b9d1f291f22e6c075723e2641ff36dfc8c6f47bf24163e66502
diff --git a/net-misc/trickle/trickle-1.07.ebuild b/net-misc/trickle/trickle-1.07.ebuild
new file mode 100644
index 0000000..e566cd0
--- /dev/null
+++ b/net-misc/trickle/trickle-1.07.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit base
+
+DESCRIPTION="a portable lightweight userspace bandwidth shaper"
+HOMEPAGE="http://monkey.org/~marius/pages/?page=trickle"
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/t/trickle/trickle_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ base_src_compile configure
+ sed -i '/#define in_addr_t/ s:^://:' config.h
+ emake -j1 || die "make failed"
+}
+
diff --git a/net-p2p/flush/Manifest b/net-p2p/flush/Manifest
index 0d3a83b..0bb1265 100644
--- a/net-p2p/flush/Manifest
+++ b/net-p2p/flush/Manifest
@@ -1,4 +1,6 @@
DIST flush-0.9.2.tar.bz2 784602 RMD160 8e0bd8c02dec9b4d4c8150ca2eec5114913cdc01 SHA1 439fa77eefeb8e7e2f8408883b915728bb4acf49 SHA256 4672856412337d3cd0a7201fec1927bae395a51e9bf55925cdf3210adc21df99
+DIST flush-0.9.6.tar.bz2 798362 RMD160 38cbdd5dce0469448195c63a63976a6ca3a471af SHA1 ca145b160d6b8a284d4f408e1111d088181fae1a SHA256 7793fec45334da81db2959a8a1e54de85865fbb30e3ceeffa98e284dbdaa261b
EBUILD flush-0.9.2.ebuild 1047 RMD160 fd339934ed70addedd5c5616df1e6e2dc71a1523 SHA1 e37ae049c71fb58b3c32ca5644ec233a469175de SHA256 f04275bcb9e7177a181e3ca0c9a6a7f1c682386f739bbd469317944fad796066
+EBUILD flush-0.9.6.ebuild 1315 RMD160 86d9f98b30d0466a8fc88b6a59819dcb0c2cb25e SHA1 d40485f93295463ce18f32683beaefb1899c329a SHA256 34502fcc5f09accaac5bb44a76b611156867c7ed82fd2f5f9ffc1aeedc1b115a
MISC ChangeLog 220 RMD160 c0c1b9468521d2c36df2deac157fb0a145f45a27 SHA1 9ff3d1eb5da9c216a0a96314d89aaef78abe8213 SHA256 38c682ce5d4aad90e36bfba63b4218ab3a0aab917a096629eedf0116014d1e90
-MISC metadata.xml 347 RMD160 70b0df4eab68c6e2a236386a3efb19411a0c1a4f SHA1 bdb761f41dba7b31f17d90149586620dd043e1af SHA256 d6b06d5ddb6dbec5ed402049e8aa8663aa85cfa6210990388254a363953df6f7
+MISC metadata.xml 288 RMD160 1721c235b8b60c27e22f38cf1c70446b9dfb89a6 SHA1 922b7464824f1c63dfda090aa082f61b47cbc8ba SHA256 0b009300e70c1e4120ab58796cf22e44474a7053e903bf111b6e3f0cc1e0e71b
diff --git a/net-p2p/flush/flush-0.9.6.ebuild b/net-p2p/flush/flush-0.9.6.ebuild
new file mode 100644
index 0000000..168c158
--- /dev/null
+++ b/net-p2p/flush/flush-0.9.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="A GTK-based BitTorrent client by Dmitry Konishchev"
+HOMEPAGE="http://sourceforge.net/projects/flush/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.16.6
+ >=dev-cpp/gtkmm-2.16.0
+ >=dev-cpp/glibmm-2.20.1
+ >=x11-libs/libnotify-0.4.5
+
+ >=sys-devel/gettext-0.17
+ >=dev-libs/libconfig-1.3.2
+ >=dev-libs/boost-1.35.0
+ >=sys-apps/dbus-1.2.3
+
+ >=net-libs/rb_libtorrent-0.14.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --disable-bundle-package \
+ --enable-system-libconfig \
+ --enable-system-libtorrent
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc COPYING ChangeLog
+
+ # Fix icon if using different icon theme in GNOME
+ insinto /usr/share/pixmaps
+ doins ./icons/hicolor/72x72/apps/flush.png
+
+ ewarn
+ ewarn There seems to be some incompability with older version
+ ewarn configuration files. If Flush seems to be unstable or
+ ewarn too slow you can fix this with 'rm -rf ~/.flush'.
+ ewarn
+ ewarn WARNING: This will remove all your loaded torrent files.
+ ewarn
+}
diff --git a/net-p2p/flush/metadata.xml b/net-p2p/flush/metadata.xml
index 820f469..ae85c01 100644
--- a/net-p2p/flush/metadata.xml
+++ b/net-p2p/flush/metadata.xml
@@ -5,7 +5,5 @@
<maintainer>
<email>iskren.s@gmail.com</email>
</maintainer>
-<longdescription>Adobe Photoshop CS4 Colour Profiles. These are used if you'd like to
-have CMYK in GIMP.
-</longdescription>
+<longdescription>A Gtkmm-based uTorrent clone.</longdescription>
</pkgmetadata>