summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/phpmyadmin/Manifest2
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.4.0_alpha1.ebuild72
-rw-r--r--profiles/package.mask1
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index fca22ac..7ccf319 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,3 +1,5 @@
AUX postinstall-en-3.1.txt 1160 SHA256 0fa47a49b9c5604339335d36ce9d1506a1cd07644d219fb7f35e2e4432fa8dbf SHA512 7b50ab9f9e3a828bd9bff600550ea97712c28804467ab5900a52710d4adb0581fe33155a965dd3956fcd36cc153b1a18a1f001d88ac52d70c8288faf695f01ec WHIRLPOOL 5b548fd9d41ca794f74936ce8ceda15c2c410cbc8d383c3376009a8936e47bc4d350c520ece1ff1eb20b0ac899f84fa513a185db5c255db362b7f3ee0b8f69ef
DIST phpMyAdmin-4.3.11.1-all-languages.tar.xz 5446076 SHA256 6c4dd0fcf331d53668824a6b857745a5c3774c2bbd483ba453c37488417d16d5 SHA512 a924f5b9200ea05c82ddd0fefbff7200f707324267c27065ed7f3afa358c2998ecf108761b4c9be8e69955fe54887d5e526a921b864b77dbb6b6b3deb8775c36 WHIRLPOOL 6d0df5f38585e9e3c6440e1020e6a781e93d4830b8cad6b7ba42a97c46dfb8dfc5d41f1e2d1c2e67bdb8e8e240acddb6813db8f0d119922f5b55fcbfda4feff5
+DIST phpMyAdmin-4.4.0-alpha1-all-languages.tar.xz 5692784 SHA256 2c3891ad3fe65014278075a52316f727e7d84435962c794e7ec3f04af5a7d66e SHA512 409a4388f955c2e855e6626db6819c089f48bb57a3bb12206eebb62e3358e7d3ffd89035aa4e1be10483528bddfb96c1156a7196813ad40c7ec2dbe9dbdc0e05 WHIRLPOOL 4fbe2948b0f62aeaf3ac954e7743d8f27d3cc2d1e8d8235121d93fd00ca17819f79fbb34a642d673ae9b1561618713c0384acd1a496e1088f52f999702d35889
EBUILD phpmyadmin-4.3.11.1.ebuild 2007 SHA256 37f2fd3bf09c8ea635aae8c798f1316e0aa15633058ead2fc0cfeeb64652b0f9 SHA512 9779b9ccab2862205af339f59f405cf032b9e0139b949b7a2c81223ec78cfcae2b0ef6339370d290fe6fa54d541a76165baa3c08019c44f6bc6df5dc031bd38b WHIRLPOOL 1ec728bc52972f866631eee207a69a3638b846f5d94bbd933cd9c0b71be70f70b6af15c28ea1b62473a0689cc987e558916c943e5740e9ccb3b03986ebef527d
+EBUILD phpmyadmin-4.4.0_alpha1.ebuild 2011 SHA256 cccfe4b29c5ba0768d45db6c66fa3abdbd10b10544279b981a6b97e6fa6815d9 SHA512 7a7b173a03c5f5f38b69837a7eafb0b08c64ad6c1baacb937317ab55019e4981022f651e669d46848a71cf885640cfd22ddc58852658346da7b47391f9c28465 WHIRLPOOL 6d1ca72f853fd39556807b122e855e6a2b11a17b4025c52bdbee3f01dde68c21583831605de6f7f4f9d8d95dadb9a0fabac6a70f2856c6460f6673ed044c99d3
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.4.0_alpha1.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.4.0_alpha1.ebuild
new file mode 100644
index 0000000..fce9f85
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.4.0_alpha1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# dev-db/phpmyadmin-4.4.0-alpha1.ebuild v1.0 2015/03/04 16:31:30 vmacs
+
+# vmacs 6/14/2014 - inserted RDEPEND for MySQL 5.5 and php 5.3 per phpMyAdmin's official news page
+# http://www.phpmyadmin.net/home_page/news.php, which states "Welcome to phpMyAdmin 4.2.3, a bugfix version.
+# Please note that this release enforces the minimum PHP (5.3) and MySQL (5.5) versions"
+
+EAPI="4"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ !<dev-db/mysql-5.5
+ !<dev-lang/php-5.3
+ !<virtual/mysql-5.5
+
+ >=dev-db/mysql-5.5
+ >=virtual/mysql-5.5
+
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}
diff --git a/profiles/package.mask b/profiles/package.mask
new file mode 100644
index 0000000..28d6bf6
--- /dev/null
+++ b/profiles/package.mask
@@ -0,0 +1 @@
+=dev-db/phpmyadmin-4.4.0_alpha1