aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2018-05-05 16:24:05 +0100
committerStuart Shelton <stuart@shelton.me>2018-05-05 16:24:05 +0100
commit64ca6aff0a69135a16c065a37e3bd5b3e047be8a (patch)
treeef7ed752bc7b46c05139343b9f564a4c286d329f /www-servers
parentUpdate www-servers/lighttpd-1.4.45 (diff)
downloadsrcshelton-64ca6aff0a69135a16c065a37e3bd5b3e047be8a.tar.gz
srcshelton-64ca6aff0a69135a16c065a37e3bd5b3e047be8a.tar.bz2
srcshelton-64ca6aff0a69135a16c065a37e3bd5b3e047be8a.zip
Add www-servers/lighttpd-1.4.45-r1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/Manifest1
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.45-r1.ebuild223
2 files changed, 224 insertions, 0 deletions
diff --git a/www-servers/lighttpd/Manifest b/www-servers/lighttpd/Manifest
index 09b3162f..c29b7415 100644
--- a/www-servers/lighttpd/Manifest
+++ b/www-servers/lighttpd/Manifest
@@ -15,4 +15,5 @@ DIST lighttpd-1.4.45.tar.xz 660432 BLAKE2B 31ea3209b8efad32c3811d39b1c1a682d9f2d
EBUILD lighttpd-1.4.35-r1.ebuild 6875 BLAKE2B 2bac85ad31bd522a3f0b7b9a5879c577d6aead418f17d674caca52a2ae225c6485c04f8d9f7f5f4a21cde873eb9888965c9e2e472c487284cf16ca15d8271d2f SHA512 79b7ade90b8390a7910aaaca5f0cdf27dbd2a29c22b7ee46302d6f8eca6586b10fb64db950efb6088eded9458774a324947eb8f1d4a0ad348bdf21fe80f0c982
EBUILD lighttpd-1.4.35.ebuild 6838 BLAKE2B 150c398ae6db7748cf4fc57bf8f7b26d8f23e67beb6f1d8d9655127426b8bfbb30e9f56c957452be60838e68567058b3b3b9315d556938cf7e5f2b03d8ec61de SHA512 84e6f16b7d7cec9179b8568a06964fe28134540d23c906e773ae288c24d46ffd49ab3c55ad7c808a82a05bd3e47f03efb0c35869a64207cce30994ed27875fcd
EBUILD lighttpd-1.4.42.ebuild 6191 BLAKE2B 9e47afc8b4aab4a8c10be6b4d170ebe7228c451dbe473a868b619429c403abbdefc180566c01a48085f963faa8ea926d608334032d11552ef55f66d110c92dcd SHA512 7fb08a6e228622b5d6d251504dfcff22cc260bdb68ba39202c37a98d6ecb814fb0e0ec0c74db12fc9f274819d4f5f5e9a46787181b8d4ca130d24e11266e2bad
+EBUILD lighttpd-1.4.45-r1.ebuild 6170 BLAKE2B 30d96292dffbe0ac4131a0dfb23d0e85d26967bf13d7996c51334261c10f9059906da95d3ba60297e9d4bb9d3e7406f3027212a14050f46047a48ffab9dd015b SHA512 f86f8810862d640eb3ff2ff5d17b476d3b9fcb4312f5ef8ea343e2832e41c8f1c052fa356c7b867ddaafa2ce0f278f37e09a12c0dd7fcc76b15c54788e7206b7
EBUILD lighttpd-1.4.45.ebuild 6138 BLAKE2B 00a1d9dfa34ac41e6106c33bd253628207c6c09629996cb08dda0b542aeb5766de1df6fc08d74666a8dfeee4fdc6b219e4c4d59d3d3ecf439aae8b3305382122 SHA512 434b9cb1e81d64e4eeecaefaf087175640f58917552561f02cf0b93b1fc91d29a8be99a1518be89f25db4148ce3ba6f06595b129fb18a0538cd6468ab2a7b90d
diff --git a/www-servers/lighttpd/lighttpd-1.4.45-r1.ebuild b/www-servers/lighttpd/lighttpd-1.4.45-r1.ebuild
new file mode 100644
index 00000000..771f92e2
--- /dev/null
+++ b/www-servers/lighttpd/lighttpd-1.4.45-r1.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils readme.gentoo-r1 user systemd
+
+DESCRIPTION="Lightweight high-performance web server"
+HOMEPAGE="https://www.lighttpd.net/"
+SRC_URI="https://download.lighttpd.net/lighttpd/releases-1.4.x/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="bzip2 doc fam gdbm ipv6 kerberos ldap libev libressl lua minimal mmap memcached mysql pcre php rrdtool selinux ssl systemd test webdav xattr zlib"
+
+REQUIRED_USE="kerberos? ( ssl !libressl )"
+
+CDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ fam? ( virtual/fam )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( >=net-nds/openldap-2.1.26 )
+ libev? ( >=dev-libs/libev-4.01 )
+ lua? ( >=dev-lang/lua-5.1:= )
+ memcached? ( dev-libs/libmemcached )
+ mysql? ( >=virtual/mysql-4.0 )
+ pcre? ( >=dev-libs/libpcre-3.1 )
+ php? ( dev-lang/php:*[cgi] )
+ rrdtool? ( net-analyzer/rrdtool )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.7:0=[kerberos?] )
+ libressl? ( dev-libs/libressl:= )
+ )
+ webdav? (
+ dev-libs/libxml2
+ >=dev-db/sqlite-3
+ sys-fs/e2fsprogs
+ )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ zlib? ( >=sys-libs/zlib-1.1 )"
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/docutils )
+ test? (
+ virtual/perl-Test-Harness
+ dev-libs/fcgi
+ )"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-apache )
+"
+
+# update certain parts of lighttpd.conf based on conditionals
+update_config() {
+ local config="${D}/etc/lighttpd/lighttpd.conf"
+
+ # enable php/mod_fastcgi settings
+ use php && { sed -i -e 's|#.*\(include.*fastcgi.*$\)|\1|' ${config} || die; }
+
+ # enable stat() caching
+ use fam && { sed -i -e 's|#\(.*stat-cache.*$\)|\1|' ${config} || die; }
+
+ # automatically listen on IPv6 if built with USE=ipv6. Bug #234987
+ use ipv6 && { sed -i -e 's|# server.use-ipv6|server.use-ipv6|' ${config} || die; }
+}
+
+# remove non-essential stuff (for USE=minimal)
+remove_non_essential() {
+ local libdir="${D}/usr/$(get_libdir)/${PN}"
+
+ # text docs
+ use doc || rm -fr "${D}"/usr/share/doc/${PF}/txt
+
+ # non-essential modules
+ rm -f \
+ ${libdir}/mod_{compress,evhost,expire,proxy,scgi,secdownload,simple_vhost,status,setenv,trigger*,usertrack}.* || die
+
+ # allow users to keep some based on USE flags
+ use pcre || rm -f ${libdir}/mod_{ssi,re{direct,write}}.*
+ use webdav || rm -f ${libdir}/mod_webdav.*
+ use mysql || rm -f ${libdir}/mod_mysql_vhost.*
+ use lua || rm -f ${libdir}/mod_{cml,magnet}.*
+ use rrdtool || rm -f ${libdir}/mod_rrdtool.*
+ use zlib || rm -f ${libdir}/mod_compress.*
+}
+
+pkg_setup() {
+ if ! use pcre ; then
+ ewarn "It is highly recommended that you build ${PN}"
+ ewarn "with perl regular expressions support via USE=pcre."
+ ewarn "Otherwise you lose support for some core options such"
+ ewarn "as conditionals and modules such as mod_re{write,direct}"
+ ewarn "and mod_ssi."
+ fi
+ if use mmap; then
+ ewarn "You have enabled the mmap option. This option may allow"
+ ewarn "local users to trigger SIGBUG crashes. Use this option"
+ ewarn "with EXTRA care."
+ fi
+ enewgroup lighttpd
+ enewuser lighttpd -1 -1 /var/www/localhost/htdocs lighttpd
+
+ DOC_CONTENTS="IPv6 migration guide:\n
+ http://redmine.lighttpd.net/projects/lighttpd/wiki/IPv6-Config"
+}
+
+src_prepare() {
+ default
+ #dev-python/docutils installs rst2html.py not rst2html
+ sed -i -e 's|\(rst2html\)|\1.py|g' doc/outdated/Makefile.am || \
+ die "sed doc/Makefile.am failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir)/${PN} \
+ --enable-lfs \
+ $(use_enable ipv6) \
+ $(use_enable mmap) \
+ $(use_with bzip2) \
+ $(use_with fam) \
+ $(use_with gdbm) \
+ $(use_with kerberos krb5) \
+ $(use_with ldap) \
+ $(use_with libev) \
+ $(use_with lua) \
+ $(use_with memcached) \
+ $(use_with mysql) \
+ $(use_with pcre) \
+ $(use_with ssl openssl) \
+ $(use_with webdav webdav-props) \
+ $(use_with webdav webdav-locks) \
+ $(use_with xattr attr) \
+ $(use_with zlib)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ einfo "Building HTML documentation"
+ cd doc || die
+ emake html
+ fi
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ default_src_test
+ else
+ ewarn "test skipped, please re-run as root if you wish to test ${PN}"
+ fi
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # init script stuff
+ newinitd "${FILESDIR}"/lighttpd.initd lighttpd
+ newconfd "${FILESDIR}"/lighttpd.confd lighttpd
+ use fam && has_version app-admin/fam && \
+ { sed -i 's/after famd/need famd/g' "${D}"/etc/init.d/lighttpd || die; }
+
+ # configs
+ insinto /etc/lighttpd
+ doins "${FILESDIR}"/conf/lighttpd.conf
+ doins "${FILESDIR}"/conf/mime-types.conf
+ doins "${FILESDIR}"/conf/mod_cgi.conf
+ doins "${FILESDIR}"/conf/mod_fastcgi.conf
+
+ # update lighttpd.conf directives based on conditionals
+ update_config
+
+ # docs
+ dodoc AUTHORS README NEWS doc/scripts/*.sh
+ newdoc doc/config//lighttpd.conf lighttpd.conf.distrib
+ use ipv6 && readme.gentoo_create_doc
+
+ use doc && dodoc -r doc
+
+ docinto txt
+ dodoc doc/outdated/*.txt
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/lighttpd.logrotate-r1 lighttpd
+
+ keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
+ fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
+ fperms 0750 /var/l{ib,og}/lighttpd
+
+ #spawn-fcgi may optionally be installed via www-servers/spawn-fcgi
+ rm -f "${D}"/usr/bin/spawn-fcgi "${D}"/usr/share/man/man1/spawn-fcgi.* || die
+
+ use minimal && remove_non_essential
+
+ if use systemd; then
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
+ fi
+}
+
+pkg_postinst () {
+ use ipv6 && readme.gentoo_print_elog
+
+ if [[ -f ${ROOT}etc/conf.d/spawn-fcgi.conf ]] ; then
+ einfo "spawn-fcgi is now provided by www-servers/spawn-fcgi."
+ einfo "spawn-fcgi's init script configuration is now located"
+ einfo "at /etc/conf.d/spawn-fcgi."
+ fi
+
+ if [[ -f ${ROOT}etc/lighttpd.conf ]] ; then
+ elog "Gentoo has a customized configuration,"
+ elog "which is now located in /etc/lighttpd. Please migrate your"
+ elog "existing configuration."
+ fi
+}
+
+# vi: set diffopt=iwhite,filler: