aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2014-08-30 14:56:21 +0100
committerStuart Shelton <stuart@shelton.me>2014-08-30 14:56:21 +0100
commitd7807989a83634d255e6b59698251eefbc9116cb (patch)
treeedfb6707e4dc8875befbf0d73f47fec548fbbbad /dev-vcs
parentUpdate app-misc/screen-4.2.1-r2 (diff)
downloadsrcshelton-d7807989a83634d255e6b59698251eefbc9116cb.tar.gz
srcshelton-d7807989a83634d255e6b59698251eefbc9116cb.tar.bz2
srcshelton-d7807989a83634d255e6b59698251eefbc9116cb.zip
Add dev-vcs/cvsps-3.13-r1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvsps/Manifest3
-rw-r--r--dev-vcs/cvsps/cvsps-3.13-r1.ebuild39
-rw-r--r--dev-vcs/cvsps/files/cvsps-3.13-make.patch52
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-vcs/cvsps/Manifest b/dev-vcs/cvsps/Manifest
new file mode 100644
index 00000000..9129ee5c
--- /dev/null
+++ b/dev-vcs/cvsps/Manifest
@@ -0,0 +1,3 @@
+AUX cvsps-3.13-make.patch 1189 SHA256 5aa8e745d6d4a41eb3640bbf5df7c4a95879ab64787a3f1ad32afd04af7ed159 SHA512 0ddc7115a0a66f418f81468230c92b17f3b7c6a38a82505de79c27764ee46ee5805ebf1d0a12360df77718cccf9bf2ac61f45b21c1cfecb7700e648ea1187e9e WHIRLPOOL f9b4ee45f105410ce1e0f317f3d3120a94183e0b33fc6a102ca13dc5ecfedf34ab5deb6583494865f9e419457d1b5eacd1a2c982c020182e10f3470a7972804b
+DIST cvsps-3.13.tar.gz 64437 SHA256 5f078a6e02c394f663893751f128caf643fe00a30b559e87db6f45190c623799 SHA512 9fe2be4839c7a6f31a788102fd6ebb1e2e0693f09a4dad2bca5cd5d0788088eb34388d592778f04bcfec9817e3ffffb66d70db9aa47996d3bd1c45cf7cd8464f WHIRLPOOL 52694e8b2b3cb0924333d80533618f687676f0b44f782c1c4f7bbc28a4f4e6a425c966823f027db7dcee27695c27c0b136115e449e83eac43459a7da03baa57c
+EBUILD cvsps-3.13-r1.ebuild 1128 SHA256 0c076d082e3c89ec04047947e14350fb7dd7e973b3a59c9e91701e080ba0b2cb SHA512 0834f611c0486719545ff4edfb18e6d2f3289b6225af8d608d544575a2b28a619ad9e17455cb247554bca23355c778364e04f8190c272a2db7a9cc90f8e5227b WHIRLPOOL 514ef426f832032cfd9040af712112635b007ba89a9bd300b31cafc61c7e9d14aba7854bc34b4a330c1089b5b4653124d9de752dea7a547bd7beca939942dd4e
diff --git a/dev-vcs/cvsps/cvsps-3.13-r1.ebuild b/dev-vcs/cvsps/cvsps-3.13-r1.ebuild
new file mode 100644
index 00000000..4c261f80
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-3.13-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-3.13-r1.ebuild,v 1.1 2014/08/24 13:49:08 slyfox Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates patchset information from a CVS repository (supports fast-import)"
+HOMEPAGE="http://www.catb.org/~esr/cvsps/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship tests
+
+src_prepare() {
+ local gentoo_name=${PN}-3
+
+ epatch "${FILESDIR}"/${P}-make.patch
+ mv ${PN}.asc ${gentoo_name}.asc || die
+ sed -i "s/${PN}/${gentoo_name}/g" ${gentoo_name}.asc || die
+ MAKEOPTS+=" PROG=${gentoo_name}"
+
+ tc-export CC
+ export prefix="${EROOT%/}/usr"
+}
+
+src_install() {
+ default
+ dodoc README
+}
diff --git a/dev-vcs/cvsps/files/cvsps-3.13-make.patch b/dev-vcs/cvsps/files/cvsps-3.13-make.patch
new file mode 100644
index 00000000..7c96d603
--- /dev/null
+++ b/dev-vcs/cvsps/files/cvsps-3.13-make.patch
@@ -0,0 +1,52 @@
+diff --git a/Makefile b/Makefile
+index 6266c9d..4f60d2f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,6 +8,9 @@ INSTALL = install
+ prefix?=/usr/local
+ target=$(DESTDIR)$(prefix)
+
++PROG = cvsps
++MANPAGE = $(PROG).1
++
+ OBJS= debug.o \
+ hash.o \
+ sio.o \
+@@ -19,12 +22,12 @@ OBJS= debug.o \
+ cvsclient.o \
+ list_sort.o
+
+-all: cvsps
++all: $(PROG) $(MANPAGE)
+
+ deps:
+ makedepend -Y -I. *.c
+
+-cvsps: $(OBJS)
+- $(CC) -o cvsps $(OBJS) $(LDFLAGS) $(LDLIBS)
++$(PROG): $(OBJS)
++ $(CC) -o $(PROG) $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+ check:
+@@ -50,17 +53,17 @@ pylint:
+ .txt.html:
+ a2x --doctype manpage --format xhtml $*.txt
+
+-install: cvsps.1 all
++install: all
+ $(INSTALL) -d "$(target)/bin"
+ $(INSTALL) -d "$(target)/share/man/man1"
+- $(INSTALL) cvsps "$(target)/bin"
+- $(INSTALL) -m 644 cvsps.1 "$(target)/share/man/man1"
++ $(INSTALL) $(PROG) "$(target)/bin"
++ $(INSTALL) -m 644 $(MANPAGE) "$(target)/share/man/man1"
+
+ tags: *.c *.h
+ ctags *.c *.h
+
+ clean:
+- rm -f cvsps *.o core tags cvsps.1 cvsps.html docbook-xsl.css
++ rm -f $(PROG) *.o core tags $(MANPAGE) cvsps.html docbook-xsl.css
+
+ SOURCES = Makefile *.[ch] merge_utils.sh
+ DOCS = README COPYING NEWS cvsps.asc TODO