aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2014-01-27 13:54:38 +0000
committerStuart Shelton <stuart@shelton.me>2014-01-27 13:54:38 +0000
commitd95f631243baf8646e755916b03069c3465ec82d (patch)
tree59f81c6889d8e696ebb93a9d48e2e1b166c9348d /app-pda
parentUpdate screen-4.0.3-r8 (diff)
downloadsrcshelton-d95f631243baf8646e755916b03069c3465ec82d.tar.gz
srcshelton-d95f631243baf8646e755916b03069c3465ec82d.tar.bz2
srcshelton-d95f631243baf8646e755916b03069c3465ec82d.zip
Add app-pda/libplist-9999
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libplist/Manifest1
-rw-r--r--app-pda/libplist/libplist-9999.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-pda/libplist/Manifest b/app-pda/libplist/Manifest
new file mode 100644
index 00000000..d0b756f3
--- /dev/null
+++ b/app-pda/libplist/Manifest
@@ -0,0 +1 @@
+EBUILD libplist-9999.ebuild 942 SHA256 d3cf7e1eb6ec7252fffc512ef2e238371c588fa79cf1cdca4dd7f656219c9314 SHA512 15fe3bd8a28df5d74c6313de4a83781689f0ef5cf8f4af15f855388cab25e5469ed41e768a130b16d719d0029cde6ced76dca31c79f06a14e765aa9a36ff2bf0 WHIRLPOOL 4808941a0630bde579e224a6f760bd87d927a297dde57360d446c554bc0e45c859befc9fcb077be300ff0bbf44a79117d3a41fcc210a63b043cca6166fc198e8
diff --git a/app-pda/libplist/libplist-9999.ebuild b/app-pda/libplist/libplist-9999.ebuild
new file mode 100644
index 00000000..62e51494
--- /dev/null
+++ b/app-pda/libplist/libplist-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: app-pda/libplist/libplist-9999.ebuild,v 1.0 2014/01/13 17:21:55 srcs Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit autotools git-2 python-r1
+
+DESCRIPTION="A library to handle Apple Property List format in binary or XML"
+HOMEPAGE="http://www.libimobiledevice.org/"
+#SRC_URI=""
+EGIT_REPO_URI="https://github.com/libimobiledevice/libplist.git"
+#EGIT_MASTER="master"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="python"
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/cython-0.14.1-r1[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README )
+
+MAKEOPTS+=" -j1" #406365
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ use python && python_export_best
+
+ myconf=$(use_with python cython)
+ econf $myconf
+}
+
+#src_install() {
+# default
+#
+# prune_libtool_files --all
+#}